LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-26-2008, 09:02 PM   #1
Ryokei
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Rep: Reputation: 0
Question Screen blanking occurring when computer is left inactive. TTY, not X11.


So simply, my Compaq laptop is plugged into an external monitor. I am running a fairly default Slackware 12.1 install, and if I leave the keyboard or mouse inactive for a period of time, the external monitor will stop displaying the terminal and just show black. The monitor isn't put into any sort of standby mode, it just displays black. With a tap on the keyboard, the screen returns. I never use X and any of the window managers, as all my work on this computer can be done in a TTY terminal.

However, if I've just got irssi running and I'm glancing at it from time to time, it's really annoying to have to reach for the keyboard and tap it to see my status window.

Anyone got any ideas? I've checked ACPI events, and they're all NULL.

Last edited by Ryokei; 10-26-2008 at 09:05 PM.
 
Old 10-26-2008, 09:28 PM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
This is from the startup script /etc/rc.d/rc.M :

Quote:
# Screen blanks after 15 minutes idle time, and powers down in one hour
# if the kernel supports APM or ACPI power management:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
You may have to change the script or perhaps overide the settings by calling setterm from your /etc/rc.d/rc.local without the parameters.

I've not tried either so you'll have to experiment.
 
Old 10-26-2008, 10:12 PM   #3
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,263

Rep: Reputation: 648Reputation: 648Reputation: 648Reputation: 648Reputation: 648Reputation: 648
Take a look at `setterm` (see `man setterm`). I think the '-blank' option is what you want. In /etc/rc.d/rc.M, there is the following:
Code:
# Screen blanks after 15 minutes idle time, and powers down in one hour
# if the kernel supports APM or ACPI power management:
/bin/setterm -blank 15 -powersave powerdown -powerdown 60
You could probably just change that parameter -- but note that if you upgrade your system, rc.M will get overwritten (well, actually, it would put an rc.M.new file in place which you would have to merge). It may be easier to just add a new setterm command in /etc/rc.d/rc.local to override that line.

[edit]Woah, WAY off. I probably should have refreshed my page before posting. I should also learn to open fewer threads and do less at once...[/edit]
 
Old 10-27-2008, 03:13 AM   #4
Ryokei
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Great, thanks for the words of assistance. rc.M has been changed, with the script repeated in rc.local just in case I distro update and totally forget about it.

/bin/setterm -blank 15 -powersave off -powerdown 60
->
/bin/setterm -blank 0 -powersave off -powerdown 0

There wasn't anything about it in the Slackbook, which I referred to for the "generic noob help" which I kinda expected to encompass things like power management in a terminal.

Again, cheers. RTFM being executed too, for the background knowledge. :P
 
  


Reply

Tags
blank, monitor, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC Inactive when I restart my Fedora Core 5 computer maheshmahajan Linux - Networking 1 08-24-2006 09:46 AM
X11 crash after switch to virtual tty shinobi59 Red Hat 1 01-11-2006 09:27 AM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
Screen blanking ? ... phoeniXflame Linux - General 12 07-20-2003 05:41 PM
Screen Blanking bretthoward Linux - General 7 03-19-2001 05:50 AM


All times are GMT -5. The time now is 09:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration