LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2005, 01:12 AM   #1
b0mb3r
LQ Newbie
 
Registered: Sep 2004
Distribution: slackware
Posts: 8

Rep: Reputation: 0
Question Screen Blanking


I just installed Slackware 10.1 on my laptop and I have this weird problem, after my screen saver comes on and runs for about 10-15 minutes, the screen goes blank and it won't respond. The only way to get the system back is to kill the X-Windows. I have tried doing:
xset s noblank
xset s 600 600
and so on but the problem still persists. My DPMS is disabled as well.
I have also tried setting these options in the /etc/X11/xorg.conf file.

I am perfectly fine with my screen saver always being on, since the laptop has hardly any battery life.

What do I need to do to make it stop blanking my screen?

P.S. I have not had this problem with Slackware 10.0
 
Old 02-21-2005, 04:30 PM   #2
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
Have you played around with the settings using xscreensaver? What window manager are you using?
 
Old 02-21-2005, 07:21 PM   #3
b0mb3r
LQ Newbie
 
Registered: Sep 2004
Distribution: slackware
Posts: 8

Original Poster
Rep: Reputation: 0
yes I have, and it does it regardless whether I use gnome, KDE or XFCE.
 
Old 02-21-2005, 08:55 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Are you using some OpenGL screensaver? That caused some troubles sometime ago...
 
Old 02-21-2005, 10:30 PM   #5
b0mb3r
LQ Newbie
 
Registered: Sep 2004
Distribution: slackware
Posts: 8

Original Poster
Rep: Reputation: 0
nope, just a standard one.
 
Old 03-16-2005, 01:01 PM   #6
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
How about seting the option in xorg.conf for "basic blanking screen saver" to 0? Looks like it defaults to 10. Maybe there's a conflict/bug. I don't actually know if that line with the #sign in front of it is ignored or just needs to be un#ed to change that from a 10 to something else.

I assume you've tried different screen savers to see if they all stop responding after 10 or 15 minutes or just one particular one.
 
Old 03-16-2005, 03:39 PM   #7
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Might also be a good idea to check you'r machines BIOS settings. Just a thought...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
Screen blanking ? ... phoeniXflame Linux - General 12 07-20-2003 06:41 PM
RH 9.0 screen blanking corrupter Linux - Distributions 0 06-04-2003 10:11 AM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 10:05 PM
Screen Blanking bretthoward Linux - General 7 03-19-2001 06:50 AM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration