LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-19-2013, 08:16 PM   #1
DaijoubuKun
LQ Newbie
 
Registered: Jul 2005
Distribution: Slackware 13.37/14.0 + 64 14.0/14.1
Posts: 11

Rep: Reputation: 1
Screen and Konsole after upgrade


Hello everybody! Here is a tricky one that I just can't seem to resolve.

I use screen a lot, and I use Konsole as it is my favorite, but after upgrading from 14.0 to 14.1 (64bit), I can't seem to detach properly from screen sessions. If I detach, it shows detached, but I don't get my prompt back. This only happens in Konsole. Since the upgrade, the only other change outside Slackware has been the installation of a newer NVidia driver as the one I was using will not build against this new of a kernel.

Here is what I have tried.
Deleting my old .fontconfig files (I'm having a weird issue where font are not quite showing correctly, but I can get used to it).
Deleting ~/.kde/share/apps
Deleting ~/.screen*
Reinstalling screen
Reinstalling konsole

The only thing I have not tried is deleting my entire .kde directory. The only thing keeping me from doing so is all the customization I have, but I may end up deleting everything kde and trying again.

Any ideas?
 
Old 11-20-2013, 02:01 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
http://www.linuxquestions.org/questi...Ez-4175479336/
 
Old 11-20-2013, 08:37 PM   #3
DaijoubuKun
LQ Newbie
 
Registered: Jul 2005
Distribution: Slackware 13.37/14.0 + 64 14.0/14.1
Posts: 11

Original Poster
Rep: Reputation: 1
Solved

Thanks for the reply. I had a bad feeling it was going to be my drivers. The weird part was I did a search before posting and I didn't see your thread. Well thanks again. I downgraded from 331.20 to 319.49 and everything seems to be fine now. I'm glad to have my Konsole back (as much as I like xfce-terminal).

Is this a common issue? I just don't understand how a driver can cause this type of issue, but then again, there is a lot I don't understand in the lower layers of Linux. I just know enough to work on servers all day.

Anyway, thanks for the info!
 
Old 11-22-2013, 09:12 PM   #4
DaijoubuKun
LQ Newbie
 
Registered: Jul 2005
Distribution: Slackware 13.37/14.0 + 64 14.0/14.1
Posts: 11

Original Poster
Rep: Reputation: 1
I wish I didn't quite mark this as fixed, but maybe someone knows about this. Now that Konsole is working, when I'm in a screen session and use irssi, I can't use ALT + arrow keys to switch between windows. Alt + number works. Why do I have the feeling this is another nvidia thing?

EDIT:
Never mind, sorry for starting this thread again. I somehow switched my terminal settings from the default (XFree 4) to Linux console, which doesn't seem to like what I was trying to go. Once again, sorry about that, but thanks again for the information on nvidia.

Last edited by DaijoubuKun; 11-22-2013 at 10:17 PM. Reason: Solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE not shutdown with screen or konsole running sadarax Linux - Desktop 1 12-26-2012 01:41 AM
Screen blackout when start konsole hlh59 Gentoo 2 04-20-2010 12:39 AM
Upgrade from Installed Stable to Unstable Breaks Konsole (KDE) Kenji Miyamoto Debian 6 02-18-2007 01:28 PM
Blank screen in konsole after nvidia driver installation J_Szucs Linux - Hardware 7 08-20-2005 12:07 PM
Konsole 1.1 - How to Print Screen ? superken Linux - Newbie 4 05-29-2002 02:14 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration