LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   scim, skim and input to KDE programs (http://www.linuxquestions.org/questions/slackware-14/scim-skim-and-input-to-kde-programs-725402/)

ozanbaba 05-12-2009 06:33 AM

scim, skim and input to KDE programs
 
hey all,

i installed scim (offical packege) and skim (compiled from source) on
the machine for japanese input. they work fine for firefox and such.
however they didn't worked for KDE applications (including
OpenOffice). i did some search and found a post about similer problem
in linuxquestions.org debian form. i changed export QT_IM_MODULE=scim
to export QT_IM_MODULE=xim. now it works with kde applications.

my questions is that is this the right way to solve this.

Slackware 12.1

gegechris99 05-13-2009 01:31 AM

Hello,

The "standard" way to use SCIM in Slackware is described in file CHANGES_AND_HINTS.TXT of Slackware 12.1.

Quote:

Input methods for complex characters (CJK, which is shorthand for Chinese,
Japanese, Korean) and other non-latin character sets have been added. These
input methods use the SCIM (Smart Common Input Method) platform.
The environment variables for SCIM support are set in /etc/profile.d/scim.sh
The requirements for getting SCIM input methods to work in your X session
are as follows:
(1) Use a UTF-8 locale. Look in /etc/profile.d/lang.sh for setting your
language to (for instance) en_US.UTF-8. As a word of warning: maybe you
should leave root with a non-UTF-8 locale because you don't want root's
commands to be misinterpreted. You can add the following line to your
~/.profile file to enable UTF-8 just for yourself:
export LANG=en_US.UTF-8
(2) Make the scim profile scripts executable. These will setup your
environment correctly for the use of scim with X applications. Run:
chmod +x /etc/profile.d/scim.*
(3) Start the scim daemon as soon as your X session starts. The scim daemon
must be active before any of your X applications. In KDE, you can add a
shell script to the ~/.kde/Autostart folder that runs the command
"scim -d". In XFCE you can add "scim -d" to the Autostarted Applications.
If you boot your computer in runlevel 4 (the graphical XDM/KDM login)
you can simply add the line "scim -d" to your ~/.xprofile file.
This gives you a Desktop Environment independent way of starting scim.
When scim is running, you will see a small keyboard icon in your system tray.
Right-click it to enter SCIM Setup. In 'Global Setup' select your keyboard
layout, and you are ready to start entering just about any language
characters you wish! Press the magical key combo <Control><Space>
in order to activate or deactivate SCIM input. The SCIM taskbar in the
desktop's corner allows you to select a language. As you type, SCIM will show
an overview of applicable character glyphs (if you are inputting complex
characters like Japanese).
Even if you follow this "standard" way, you will still have the issue with KDE applications (at least, I still had this issue). So I used SKIM just like you. I submitted a Slackbuild to slackbuilds.org.

You then have to modify the config module from "config" to "kconfig" in the configuration screen of SKIM and restart SCIM. Basically you will be running SCIM with the config module kconfig.

For your information, SCIM has been recompiled in Slackware 12.2 and it will work with KDE applications out of the box (SKIM is no longer necessary).


All times are GMT -5. The time now is 03:13 PM.