LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2012, 08:06 AM   #1
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 435

Rep: Reputation: Disabled
scim-setup not initializing in -current


I was told to make an LQ post so here it is.

For the few of you who use scim, scim in -current has spouted some error messages since the upgrade to 1.4.14 (and for a non-programmer such as myself, it is difficult to decipher this foreign language -- somewhat ironic seeing as how scim is generally for non-English languages).

Code:
(scim-setup:2464): GLib-GObject-WARNING **: cannot register existing type `GtkWidget'

(scim-setup:2464): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(scim-setup:2464): GLib-GObject-WARNING **: cannot register existing type `GtkBuildable'

(scim-setup:2464): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(scim-setup:2464): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(scim-setup:2464): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(scim-setup:2464): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed
It hangs and I had to ^C. When run from a graphical menu, ps lists scim-setup but it isn't loaded; the same behavior when running it from a terminal.

To make sure it wasn't just me (because I have several removed packages and multilib enabled), I asked on the ##slackware channel in freenode on IRC. 3 other people confirmed it as well on -current on both 32-bit, 64-bit and on multilib.

scim-setup before the upgrade, as well as on my 13.37-multilib system, functions properly.

================================================
Edit 1: Attached log of "scim-setup 2> scim.log"
================================================================
Edit 2: I was told in IRC a patch was submitted. Now we wait.
Attached Files
File Type: log scim.log (777 Bytes, 1 views)

Last edited by TommyC7; 09-10-2012 at 08:18 AM.
 
Old 09-11-2012, 02:31 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,191

Rep: Reputation: Disabled
Scim was updated in -current. Let's add a reply so that the post is no longer on the zero-reply list.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] setup fails on most current Slackware-current March 26, 2012 AlleyTrotter Slackware 15 04-09-2012 06:05 AM
Adding RAID 10 to current setup Myiagros Linux - Hardware 6 10-28-2009 07:27 AM
SCIM font - got SCIM working, now all flash has japanese font.....help! sandaili Linux - Software 6 03-24-2009 07:27 AM
what does 'save current setup' do? Zaius Linux - Newbie 2 01-10-2004 11:08 AM
How do I REALLY save current setup newbix Linux - Newbie 1 04-20-2003 12:10 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration