LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   scim-pinyin in Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/scim-pinyin-in-slackware-14-0-a-4175453668/)

Ahau 03-11-2013 04:55 PM

scim-pinyin in Slackware 14.0
 
Hi all,

I'm relaying a question/issue related to using scim-pinyin for chinese text input in slackware. This came up on the porteus.org forum, and I've confirmed that the behavior is the same in Slackware (I tested in slackwarearm 14 and reproduced the issue, but it's happening with in Porteus i486 and x86_64 as well).

I've got scim installed together with all of the scim add-on packages (hangul, anthy, pinyin, etc) and with the exception of chinese -> pinyin, it appears to be working properly (all other languages, including other chinese variants are working fine).

When pinyin is selected and I hit ctrl+space, I continue typing in english, and no chinese characters pop up to be selected (like they do for other chinese variants). The occasional vowel gets highlighted but no chinese characters appear. Oddly enough, the letter 'v' (on my en_US keyboard) produces a 'u' with an umlaut, but otherwise nothing seems to be happening.

Has anyone else experienced this issue and found a fix for it?

Also, scim-bridge appears to still be in Slackware 14 and -current, and I believe it is no longer needed, as its functionality has been wrapped into scim 1.14. see: http://www.scim-im.org/news/scim_new...of_scim_bridge

Thanks!

Ahau

TommyC7 03-12-2013 06:40 PM

Hi there,

I also use scim to type in other foreign language characters and have had no problems with SCIM in 14.0. Have you tried following what's written in CHANGES_AND_HINTS.TXT?

ftp://ftp.slackware.com/pub/slackwar..._AND_HINTS.TXT

I just followed the directions for SCIM near the bottom, and am able to type in Chinese, Japanese and Korean.

Ahau 03-13-2013 01:23 AM

Thanks for the response, Tommy!

Yes, I have my locale set to en_US.utf8, and I have set the scripts in /etc/profile.d as executable. As such, scim is working normally for Japanese, Korean and all Chinese variants with the exception of pinyin. Are you able to properly enter text, in pinyin specifically, with your setup? That is Chinese (simplified) -> zh-pinyin in the scim menu.

Thanks again!

TommyC7 03-13-2013 10:32 PM

Hi Ahau,

Yes I was able to insert Chinese (simplified) via the zh-pinyin option in the scim menu. I'm not sure what problem you may be having. I do recall that there are some other packages related to scim-pinyin. Perhaps you have removed them or something?

Ahau 03-14-2013 10:34 AM

Thanks, Tommy!

In looking through the packages for things I might be missing, such as python scripts, etc., I finally sorted out that the 'zh-pinyin' option is actually from m17n, not scim-pinyin. Scim-pinyin has a separate entry that shows up in the scim menu in chinese script, so I wasn't able to read that it's pinyin. I matched up the icon in the "scim-pinyin" package with this entry in the scim menu and it is working properly. I'm hoping this meets our users' needs for pinyin entry.

I also went back and compiled m17n-lib and scim-m17n from source, and the problem still persists with 'zh-pinyin'. If the other entry method is working sufficiently for our users, I'll probably let this one go. Thanks again for looking into it!


All times are GMT -5. The time now is 04:38 PM.