LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   sbopkg: need help deciphering error message (http://www.linuxquestions.org/questions/slackware-14/sbopkg-need-help-deciphering-error-message-4175470354/)

textillis 07-21-2013 01:35 AM

sbopkg: need help deciphering error message
 
(BTW, I'm making small steps with package management and have just changed the repository in SBo from "14" to "git")

When I run sbopkg, I often get an error message like this:
Code:

checking for LIBJSON... no
configure: error: Package requirements ( json >= 0.9 ) were not met:

No package 'json' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBJSON_CFLAGS
and LIBJSON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

pulseaudio:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?:

Given that it comes up a lot, I wondered if it might be a problem with my configuration rather than the packages.

Any light? usual thanks in anticip,
Best,

textillis 07-21-2013 01:44 AM

Addendum to last
 
Can't install cairo for some (other) reason; this time, using sbopkg-git, i get:


Code:

-- Cairo-Dock 3.1.2 will be compiled with the following options:
--  * Use X Extensions: Yes
--  * Crypt passwords : Yes
--  * GTK version    : 3 (3.8.2)
--  * Installation in : /usr
--  * Lib directory  : /usr/lib64
--  * Themes directory: themes3.1
--
-- Configuring incomplete, errors occurred!

cairo-dock:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?:

Sbogitting along,
Best,

ponce 07-21-2013 03:04 AM

Quote:

Originally Posted by textillis (Post 4994002)
(BTW, I'm making small steps with package management and have just changed the repository in SBo from "14" to "git")

be aware that my repository for -current is incomplete, that's why it's marked as UNSUPPORTED: it includes only the fixes for the stuff I personally use on -current, not for all the thingies out there.
I consider it a very partial solution (basically for myself and for some daring users ;) ) to build the most common things on -current (-current, as it's a moving target, is officially not supported by SBo) but it's not more than that: don't expect to build everything available on SBo for 14 on -current with this repository, for the stuff not working you're basically on your own.

Quote:

When I run sbopkg, I often get an error message like this:
Code:

checking for LIBJSON... no
configure: error: Package requirements ( json >= 0.9 ) were not met:

No package 'json' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBJSON_CFLAGS
and LIBJSON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

pulseaudio:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?:


I don't use pulseaudio, but I think the error you got is related to the fact that you forgot to install the json-c dependency.
always check dependecies for the package you're about to install or reading the related .info file or visiting the related SBo page, where they are listed.
to build stuff from SBo always refer to the howto and the faq.

Quote:

Originally Posted by textillis (Post 4994003)
Can't install cairo for some (other) reason; this time, using sbopkg-git, i get:

cairo-dock doesn't build on -current as the pango library shipped with it doesn't include libpangox (you can see the error above in your build log).

textillis 07-21-2013 03:38 AM

>Ponce: many thanks
 
Quote:

Originally Posted by ponce (Post 4994014)
be aware that my repository for -current is incomplete, that's why it's marked as UNSUPPORTED: it includes only the fixes for the stuff I personally use on -current, not for all the thingies out there.
I consider it a very partial solution [...]

always check dependecies for the package you're about to install or reading the related .info file or visiting the related SBo page, where they are listed.
to build stuff from SBo always refer to the howto and the faq.


cairo-dock doesn't build on -current as the pango library shipped with it doesn't include libpangox (you can see the error above in your build log).

Ponce, thank you; I've got to slow down and read and check more.
I was very pleased when I found sbopkg; the moribund windoze-sub-persona in me jumped at it as if it were a fully-automated answer to packaging and dependency-resolution, which you have just reminded me is not the case.

I really appreciate such full and detailed responses and I know that they are having an incremental effect on my increasing autonomy with SW: I won't always be such a pest:o
Best,


All times are GMT -5. The time now is 01:54 AM.