LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   sbopkg help (http://www.linuxquestions.org/questions/slackware-14/sbopkg-help-934709/)

rng 03-15-2012 11:32 PM

sbopkg help
 
I had installed slackware-13.0 and then I installed sbopkg. On running sync of repository it used version 13.37. I realized it later and set the repository to 13.0 and ran the sync again. Is this all I need to do or do I have do some other setting adjustment to avoid sbopkg from using 13.37 repository? Thanks.

tommcd 03-16-2012 02:54 AM

Setting the repository in sbopkg to Slack 13.0 should be all that you need to do.
Using sbopkg will not alter any installed Slackware default programs or system settings as far as I know.
Unlike other distros that use "smart" package mangers, setting sbopkg to the wrong version of Slackware will not inadvertently upgrade the whole OS or major parts of it to a newer version of Slackware.
As far as I know, the worst thing that could happen from using the sbopkg 13.37 repo on Slackware 13.0 is that some programs may not work because they may depend on newer versions of libraries that are not present on Slackware 13.0.
So you should be good to go with selecting Slackware 13.0 from sbopkg.

WhiteWolf1776 03-16-2012 08:49 AM

You may want to think about upgrading to 13.37 unless there is some pressing reason not to do so. Slackbuilds, the repository used by sbopkg, generally update the scripts only for the current released version of Slackware.

rng 03-16-2012 09:06 AM

I read accounts of how upgrading may lead to 'kernel panic'. Are there many advantages of 13.37 over 13.0? What is the exact method to upgrade? How much MB of data (approx) needs to be downloaded (for a freshly installed slackware 13.0, without major additions)? Thanks for your reply.

WhiteWolf1776 03-16-2012 09:12 AM

If it's your first upgrade, you will want to read the hints and notes files for the versions between you and the one you are moving to.

slackpkg makes it much easier than it used to be. I believe going from 13.0 to 13.37 you will need to remove the blacklist of elflibs and let that update.

As for download, I think about every package has been updated, so if you have a clean install, why not just download the 13.37 cd (about 4GB) and do a clean install of that? I guess I'm wondering, why start out behind the curve unless you need the older kernel or libs for some reason?

slackpkg has a couple of standard things you can do to keep your system up to date, and even upgrade it to a new version. To keep it up to date, you slackpkg update; slackpkg install-new; slackpkg upgrade-all; slackpkg clean-system (careful on this last one or you will delete all your custom slack packages. blacklist can be your friend here)

rng 03-16-2012 09:28 AM

Your suggestion makes sense. I had earlier thought if I upgrade rather than install new version from CD, I will not have to do again all the settings that I have made while installing printer, network as well as any other packages that I may have installed (like libreoffice, wine etc). I thought this way one needs to install the system only once and keep upgrading forever (almost), as I presume they do in Arch linux?

WhiteWolf1776 03-16-2012 09:32 AM

If you have already configured the system, I'd do the upgrade. There are likely to be new config files with cups, etc, that it will prompt you to use, but the upgrade will save your current config files as .orig or the new ones with the updated packages as .new, your choice.

Worst case, you don't do the upgrade right, you just install the newest slackware anyway. (backup your /etc folder before you start... just saying )


All times are GMT -5. The time now is 12:10 AM.