LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-05-2017, 12:03 PM   #646
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,727

Original Poster
Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815

you can also let it build disabling -Werror: I think I'll do that and let the maintainer evaluate the upgrade
Code:
--- upx.SlackBuild.orig 2017-08-05 18:57:16.039269232 +0200
+++ upx.SlackBuild      2017-08-05 19:01:21.444255987 +0200
@@ -55,6 +55,8 @@
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  -exec chmod 644 {} \;
 
+sed -i "s|^CXXFLAGS_WERROR.*|CXXFLAGS_WERROR =|" src/Makefile
+
 # Extract LZMA SDK to a proper place for use at build-time
 mkdir -p $TMP/lzma465
 tar xvf $CWD/lzma465.tar.bz2 -C $TMP/lzma465
BTW, thanks for reporting!

Last edited by ponce; 08-05-2017 at 12:35 PM.
 
Old 08-05-2017, 01:15 PM   #647
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 571

Rep: Reputation: 160Reputation: 160
@ponce

OK , your fix is better , respecting the original slackbuild code , thanks.
 
Old 08-09-2017, 06:28 PM   #648
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 329

Rep: Reputation: 63
Quote:
Originally Posted by brobr View Post

Changing the ui/tools/flood-tool.cpp in inkscape-0.92.1 to that of the master - as described in that debian bug-report - is sufficient to get 0.92.1 built on my current-box.
OK, above not relevant anymore:

inkscape-0.92.2 is out and compiled fine with the sbo-slackbuild at my end.
 
Old 08-13-2017, 04:40 PM   #649
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32
Posts: 263

Rep: Reputation: 17
I installed a fresh 32-bit Slackware current today.

When I tried to compile Claws-mail v 3.14.1 and 3.15.0 , I got this (unfortunately):
Libetpan is 1.8.

Code:
libtool: link: gcc -shared  -fPIC -DPIC  .libs/pdf_viewer_la-poppler_viewer.o   /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libpangocairo-1.0.so -L/usr/lib /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libgthread-2.0.so /usr/lib/libpoppler-glib.so /usr/lib/libpoppler.so /usr/lib/liblcms2.so /usr/lib/libtiff.so /usr/lib/liblzma.so /usr/lib/libjpeg.so -lnss3 -lsmime3 -lssl3 -lsoftokn3 -lnssutil3 -lplds4 -lplc4 -lnspr4 /usr/lib/libsqlite3.so -licui18n -licuuc -licudata -lopenjp2 /usr/lib/libgio-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libmount.so /usr/lib/libblkid.so /usr/lib/libuuid.so /usr/lib/libgobject-2.0.so /usr/lib/libffi.so /usr/lib/libcairo.so /usr/lib/libpixman-1.so /usr/lib/libfontconfig.so /usr/lib/libpcre.so /usr/lib/libharfbuzz.so /usr/lib/libglib-2.0.so /usr/lib/libfreetype.so -lbz2 /usr/lib/libEGL.so /usr/lib/libgbm.so /usr/lib/libpng16.so /usr/lib/libxcb-shm.so /usr/lib/libxcb-render.so /usr/lib/libXrender.so /usr/lib/libGL.so /usr/lib/libxcb-dri3.so /usr/lib/libxcb-xfixes.so /usr/lib/libxcb-present.so /usr/lib/libxcb-sync.so /usr/lib/libxshmfence.so /usr/lib/libglapi.so /usr/lib/libXdamage.so /usr/lib/libXfixes.so /usr/lib/libX11-xcb.so /usr/lib/libxcb-glx.so /usr/lib/libxcb-dri2.so /usr/lib/libXxf86vm.so /usr/lib/libXext.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXau.so /usr/lib/libXdmcp.so /usr/lib/libdrm.so -lrt -lm /usr/lib/libetpan.so /usr/lib/libstdc++.so /usr/lib/libcurl.so /usr/lib/libidn2.so /usr/lib/libunistring.so -lssh2 /usr/lib/libldap.so /usr/lib/liblber.so /usr/lib/libexpat.so /usr/lib/libdb-4.8.so -lpthread -lz /usr/lib/libsasl2.so -ldl -lresolv -lssl -lcrypto  -O2 -march=i486 -mtune=i686 -pthread -Wl,--export-dynamic -pthread   -pthread -Wl,-soname -Wl,pdf_viewer.so -o .libs/pdf_viewer.so
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnss3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lsmime3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lssl3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lsoftokn3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnssutil3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lplds4
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lplc4
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnspr4
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:547: pdf_viewer.la] Error 1
make[5]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src/plugins/pdf_viewer'
make[4]: *** [Makefile:512: all-recursive] Error 1
make[4]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src/plugins'
make[3]: *** [Makefile:1525: all-recursive] Error 1
make[3]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src'
make[2]: *** [Makefile:1215: all] Error 2
make[2]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src'
make[1]: *** [Makefile:766: all-recursive] Error 1
make[1]: Leaving directory '/tmp/SBo/claws-mail-3.14.1'
make: *** [Makefile:541: all] Error 2
 
Old 08-13-2017, 06:09 PM   #650
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,632

Rep: Reputation: 952Reputation: 952Reputation: 952Reputation: 952Reputation: 952Reputation: 952Reputation: 952Reputation: 952
I just tested them on slackware64-current and all is working fine here

Code:
libetpan:
  MD5SUM check for 1.8.tar.gz ... OK
  Building package libetpan-1.8-x86_64-1_SBo.tgz ... OK
  Installing package libetpan-1.8-x86_64-1_SBo.tgz ... OK

claws-mail:
  MD5SUM check for claws-mail-3.15.0.tar.xz ... OK
  Building package claws-mail-3.15.0-x86_64-1_SBo.tgz ... OK
  Installing package claws-mail-3.15.0-x86_64-1_SBo.tgz ... OK
 
Old 08-15-2017, 03:45 AM   #651
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,727

Original Poster
Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815
Quote:
Originally Posted by brodo View Post
I installed a fresh 32-bit Slackware current today.

When I tried to compile Claws-mail v 3.14.1 and 3.15.0 , I got this (unfortunately):
Libetpan is 1.8.

Code:
libtool: link: gcc -shared  -fPIC -DPIC  .libs/pdf_viewer_la-poppler_viewer.o   /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libpangocairo-1.0.so -L/usr/lib /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libgthread-2.0.so /usr/lib/libpoppler-glib.so /usr/lib/libpoppler.so /usr/lib/liblcms2.so /usr/lib/libtiff.so /usr/lib/liblzma.so /usr/lib/libjpeg.so -lnss3 -lsmime3 -lssl3 -lsoftokn3 -lnssutil3 -lplds4 -lplc4 -lnspr4 /usr/lib/libsqlite3.so -licui18n -licuuc -licudata -lopenjp2 /usr/lib/libgio-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libmount.so /usr/lib/libblkid.so /usr/lib/libuuid.so /usr/lib/libgobject-2.0.so /usr/lib/libffi.so /usr/lib/libcairo.so /usr/lib/libpixman-1.so /usr/lib/libfontconfig.so /usr/lib/libpcre.so /usr/lib/libharfbuzz.so /usr/lib/libglib-2.0.so /usr/lib/libfreetype.so -lbz2 /usr/lib/libEGL.so /usr/lib/libgbm.so /usr/lib/libpng16.so /usr/lib/libxcb-shm.so /usr/lib/libxcb-render.so /usr/lib/libXrender.so /usr/lib/libGL.so /usr/lib/libxcb-dri3.so /usr/lib/libxcb-xfixes.so /usr/lib/libxcb-present.so /usr/lib/libxcb-sync.so /usr/lib/libxshmfence.so /usr/lib/libglapi.so /usr/lib/libXdamage.so /usr/lib/libXfixes.so /usr/lib/libX11-xcb.so /usr/lib/libxcb-glx.so /usr/lib/libxcb-dri2.so /usr/lib/libXxf86vm.so /usr/lib/libXext.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXau.so /usr/lib/libXdmcp.so /usr/lib/libdrm.so -lrt -lm /usr/lib/libetpan.so /usr/lib/libstdc++.so /usr/lib/libcurl.so /usr/lib/libidn2.so /usr/lib/libunistring.so -lssh2 /usr/lib/libldap.so /usr/lib/liblber.so /usr/lib/libexpat.so /usr/lib/libdb-4.8.so -lpthread -lz /usr/lib/libsasl2.so -ldl -lresolv -lssl -lcrypto  -O2 -march=i486 -mtune=i686 -pthread -Wl,--export-dynamic -pthread   -pthread -Wl,-soname -Wl,pdf_viewer.so -o .libs/pdf_viewer.so
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnss3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lsmime3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lssl3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lsoftokn3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnssutil3
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lplds4
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lplc4
/usr/lib/gcc/i586-slackware-linux/7.1.0/../../../../i586-slackware-linux/bin/ld: cannot find -lnspr4
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:547: pdf_viewer.la] Error 1
make[5]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src/plugins/pdf_viewer'
make[4]: *** [Makefile:512: all-recursive] Error 1
make[4]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src/plugins'
make[3]: *** [Makefile:1525: all-recursive] Error 1
make[3]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src'
make[2]: *** [Makefile:1215: all] Error 2
make[2]: Leaving directory '/tmp/SBo/claws-mail-3.14.1/src'
make[1]: *** [Makefile:766: all-recursive] Error 1
make[1]: Leaving directory '/tmp/SBo/claws-mail-3.14.1'
make: *** [Makefile:541: all] Error 2
hi brodo,

I think you haven't done a full install because the libraries that the compiler is reporting as missing are in the mozilla-nss package shipped with Slackware.
note that a full install is a necessary prerequisite before reporting errors in this thread (see first post).

Last edited by ponce; 08-15-2017 at 03:46 AM.
 
1 members found this post helpful.
Old 08-15-2017, 01:50 PM   #652
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 266

Rep: Reputation: 58
Hi there,

Xiphos is not building on my -current system despite having all dependencies. What is most frustrating is that the build error happens in step 132 of 133. Below is the output:

Code:
[132/133] cxx_link: build/default/src/examples/marshal_1.o build/default/src/examples/xiphos-nav_1.o -> build/default/src/examples/xiphos-nav
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../x86_64-slackware-linux/bin/ld: warning: libwebp.so.6, needed by /usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so, not found (try using -rpath or -rpath-link)
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPINewRGB'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIDelete'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIUpdate'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPGetFeaturesInternal'
collect2: error: ld returned 1 exit status
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../x86_64-slackware-linux/bin/ld: warning: libwebp.so.6, needed by /usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so, not found (try using -rpath or -rpath-link)
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPINewRGB'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIDelete'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIUpdate'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPGetFeaturesInternal'
collect2: error: ld returned 1 exit status
Waf: Leaving directory `/tmp/SBo/xiphos-4.0.5/build'
Build failed:
 -> task failed (err #1): 
        {task: cxx_link marshal_1.o,xiphos-nav_1.o -> xiphos-nav}
 -> task failed (err #1): 
        {task: cxx_link locale_set_2.o,marshal_2.o,about_modules_2.o,about_sword_2.o,about_trans_2.o,about_xiphos_2.o,bibletext_2.o,bibletext_dialog_2.o,bookmark_dialog_2.o,bookmarks_menu_2.o,bookmarks_treeview_2.o,cipher_key_dialog_2.o,commentary_2.o,commentary_dialog_2.o,dialog_2.o,dictlex_2.o,dictlex_dialog_2.o,display_info_2.o,dummy_2.o,export_bookmarks_2.o,export_dialog_2.o,find_dialog_2.o,font_dialog_2.o,gbs_2.o,gbs_dialog_2.o,gui_2.o,ipc_2.o,main_menu_2.o,main_window_2.o,menu_popup_2.o,mod_mgr_2.o,navbar_book_2.o,navbar_book_dialog_2.o,navbar_versekey_2.o,navbar_versekey_dialog_2.o,navbar_versekey_editor_2.o,navbar_versekey_parallel_2.o,parallel_dialog_2.o,parallel_tab_2.o,parallel_view_2.o,preferences_dialog_2.o,search_dialog_2.o,search_sidebar_2.o,sidebar_2.o,sidebar_dialog_2.o,splash_2.o,tabbed_browser_2.o,treekey-editor_2.o,utilities_2.o,xiphos_2.o,gs_stringmgr_1.o,module_manager_1.o,sword_main_1.o,link_dialog_1.o,editor_1.o,webkit_editor_1.o,biblesync_glue_1.o,configs_1.o,display_1.o,export_passage_1.o,global_ops_1.o,lists_1.o,main_1.o,mod_mgr_1.o,module_dialogs_1.o,modulecache_1.o,navbar_1.o,navbar_book_1.o,navbar_book_dialog_1.o,navbar_versekey_1.o,parallel_view_1.o,prayerlists_1.o,previewer_1.o,search_dialog_1.o,search_sidebar_1.o,settings_1.o,sidebar_1.o,sword_1.o,sword_treekey_1.o,tab_history_1.o,url_1.o,xml_1.o,marshal_1.o,xiphos_html_1.o,marshal_1.o,wk-html_1.o -> xiphos}
 
Old 08-15-2017, 01:53 PM   #653
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,727

Original Poster
Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815
Quote:
Originally Posted by sombragris View Post
Hi there,

Xiphos is not building on my -current system despite having all dependencies. What is most frustrating is that the build error happens in step 132 of 133. Below is the output:

Code:
[132/133] cxx_link: build/default/src/examples/marshal_1.o build/default/src/examples/xiphos-nav_1.o -> build/default/src/examples/xiphos-nav
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../x86_64-slackware-linux/bin/ld: warning: libwebp.so.6, needed by /usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so, not found (try using -rpath or -rpath-link)
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPINewRGB'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIDelete'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIUpdate'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPGetFeaturesInternal'
collect2: error: ld returned 1 exit status
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../x86_64-slackware-linux/bin/ld: warning: libwebp.so.6, needed by /usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so, not found (try using -rpath or -rpath-link)
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPINewRGB'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIDelete'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPIUpdate'
/usr/lib64/gcc/x86_64-slackware-linux/7.1.0/../../../../lib64/libwebkitgtk-3.0.so: undefined reference to `WebPGetFeaturesInternal'
collect2: error: ld returned 1 exit status
Waf: Leaving directory `/tmp/SBo/xiphos-4.0.5/build'
Build failed:
 -> task failed (err #1): 
        {task: cxx_link marshal_1.o,xiphos-nav_1.o -> xiphos-nav}
 -> task failed (err #1): 
        {task: cxx_link locale_set_2.o,marshal_2.o,about_modules_2.o,about_sword_2.o,about_trans_2.o,about_xiphos_2.o,bibletext_2.o,bibletext_dialog_2.o,bookmark_dialog_2.o,bookmarks_menu_2.o,bookmarks_treeview_2.o,cipher_key_dialog_2.o,commentary_2.o,commentary_dialog_2.o,dialog_2.o,dictlex_2.o,dictlex_dialog_2.o,display_info_2.o,dummy_2.o,export_bookmarks_2.o,export_dialog_2.o,find_dialog_2.o,font_dialog_2.o,gbs_2.o,gbs_dialog_2.o,gui_2.o,ipc_2.o,main_menu_2.o,main_window_2.o,menu_popup_2.o,mod_mgr_2.o,navbar_book_2.o,navbar_book_dialog_2.o,navbar_versekey_2.o,navbar_versekey_dialog_2.o,navbar_versekey_editor_2.o,navbar_versekey_parallel_2.o,parallel_dialog_2.o,parallel_tab_2.o,parallel_view_2.o,preferences_dialog_2.o,search_dialog_2.o,search_sidebar_2.o,sidebar_2.o,sidebar_dialog_2.o,splash_2.o,tabbed_browser_2.o,treekey-editor_2.o,utilities_2.o,xiphos_2.o,gs_stringmgr_1.o,module_manager_1.o,sword_main_1.o,link_dialog_1.o,editor_1.o,webkit_editor_1.o,biblesync_glue_1.o,configs_1.o,display_1.o,export_passage_1.o,global_ops_1.o,lists_1.o,main_1.o,mod_mgr_1.o,module_dialogs_1.o,modulecache_1.o,navbar_1.o,navbar_book_1.o,navbar_book_dialog_1.o,navbar_versekey_1.o,parallel_view_1.o,prayerlists_1.o,previewer_1.o,search_dialog_1.o,search_sidebar_1.o,settings_1.o,sidebar_1.o,sword_1.o,sword_treekey_1.o,tab_history_1.o,url_1.o,xml_1.o,marshal_1.o,xiphos_html_1.o,marshal_1.o,wk-html_1.o -> xiphos}
I think you have to rebuild your webkitgtk3 package against the newer libwebp in current.
 
1 members found this post helpful.
Old 08-15-2017, 02:07 PM   #654
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 266

Rep: Reputation: 58
Quote:
Originally Posted by ponce View Post
I think you have to rebuild your webkitgtk3 package against the newer libwebp in current.
Oh well. Here I go to 5+ hours of compile time. Anyway, thank you ponce. Will try that.
 
Old 08-15-2017, 04:32 PM   #655
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 266

Rep: Reputation: 58
Ponce: confirmed, after rebuilding webkitgtk3 I can build xiphos without any trouble. Thank you for the advice!
 
Old 08-17-2017, 02:45 PM   #656
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32
Posts: 263

Rep: Reputation: 17
Quote:
Originally Posted by ponce View Post
hi brodo,

I think you haven't done a full install because the libraries that the compiler is reporting as missing are in the mozilla-nss package shipped with Slackware.
note that a full install is a necessary prerequisite before reporting errors in this thread (see first post).
Yes, you're right.
It is interesting by the way, how mozilla-nss package escaped alone from installing/upgrading.
Big thanks !
 
Old 08-18-2017, 12:09 AM   #657
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,727

Original Poster
Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815
Quote:
Originally Posted by brodo View Post
It is interesting by the way, how mozilla-nss package escaped alone from installing/upgrading.
if you want to be sure about having a full install you can run
Code:
slackpkg install slackware
as you have installed a 32bit Slackware, while on Slackware 64bit the same command is
Code:
slackpkg install slackware64
it should propose to install whatever is missing.
 
Old 08-18-2017, 01:08 PM   #658
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,574

Rep: Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490
Just tried building qemu-2.9.0 on Slackware64-current but failed due to change here
Downloaded the latest release 2.10.0-rc3 and ran
Code:
VERSION=2.10.0-rc3 ./qemu.SlackBuild
and the resulting package is working for me.
 
Old 08-18-2017, 01:28 PM   #659
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,727

Original Poster
Rep: Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815Reputation: 1815
yes, to build on current you need at least 2.10.0-rc1: I have already pushed the necessary changes in the repository and the version there is already 2.10.0_rc2, but tomorrow I will update it to 2.10.0_rc3.

note that the SlackBuild needs little modifications to use an underscore in the $VERSION variable (you better not have a dash in there).

Last edited by ponce; 08-18-2017 at 01:45 PM.
 
1 members found this post helpful.
Old 08-18-2017, 01:34 PM   #660
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,574

Rep: Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490
Cheers Matteo.
You can trust me to be last with the latest. Just wanted to report my experience.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration