LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-01-2005, 03:11 AM   #1
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Rep: Reputation: 15
/sbin/ldconfig Not ELF


Hey all,

Im having problems. I cant use pkgtool because of this:

Code:
/sbin/ldconfig: /usr/lib/libcups.so.2 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libcups.so is not an ELF file - it has the wrong magic bytes atthe start.
This makes me unable to install .tgz files.

On top of this, my ongoing problem with make/make install freezes basically means that i cant install anything.

Any help? I really dont want to move to another Distro
 
Old 08-01-2005, 08:06 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Never run into an issue with ldconfig related to tgz files. But my issue has been with the occasional rpm. I get an ldconfig error and end up running the command ' /sbin/ldconfig -n /lib ' as root to rebuild the libraries. This info comes from the man files in ldconfig ' man ldconfig '

Brian1
 
Old 08-01-2005, 08:09 PM   #3
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try removing cups package and try again. If that works, try reinstalling cups.
 
Old 08-01-2005, 08:29 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Re: /sbin/ldconfig Not ELF

Quote:
Originally posted by Casket
Code:
/sbin/ldconfig: /usr/lib/libcups.so.2 is not an ELF file - it has the wrong magic bytes at the start.

/sbin/ldconfig: /usr/lib/libcups.so is not an ELF file - it has the wrong magic bytes atthe start.
What's the output of
ls -l /usr/lib/libcups.*
and
file /usr/lib/libcups.*

/usr/lib/libcups.so SHOULD be a symlink to /usr/lib/libcups.so.2,
so file /usr/lib/libcups.so.2 is probably more interesting.



Cheers,
Tink
 
Old 08-02-2005, 01:30 AM   #5
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Code:
james@subby:~$ ls -l /usr/lib/libcups.*
-rwxr-xr-x  1 root root 160566 2005-07-27 23:00 /usr/lib/libcups.a*
lrwxrwxrwx  1 root root     12 2005-07-27 23:00 /usr/lib/libcups.so -> libcups.so.2*
-rwxr-xr-x  1 root root 126475 2005-07-27 23:00 /usr/lib/libcups.so.2*


james@subby:~$ file /usr/lib/libcups.*
/usr/lib/libcups.a:    data
/usr/lib/libcups.so:   symbolic link to `libcups.so.2'
/usr/lib/libcups.so.2: data
Thanks mate
 
Old 08-02-2005, 02:07 AM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Did you try download and install a new cups pkg ?
because it looks like it was corrupted
 
Old 08-02-2005, 02:15 AM   #7
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Hmm.. i attempted to install CUPS, it didnt go through though because of my make/make install system hang.

What would be the reccomended next step?
 
Old 08-02-2005, 02:59 AM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
For my part, If I had this problem, I would take a look
in /var/log/syslog to see if there is no related logged
errors

Otherwise, I would consider upgrade or reinstall binutils
package and at last glibc package (but very at last )

Last edited by keefaz; 08-02-2005 at 03:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/sbin/ldconfig: /usr/lib/libgtkhtml-3.0.so.2 is not a symbolic link rosariowong Slackware 13 04-29-2005 04:41 PM
Want2use /sbin cmds undr non-root account w/o sudo. Is it safe 2 add /sbin 2 my PATH? kornerr Linux - General 4 02-25-2005 10:29 AM
messing with /sbin/ldconfig errors. Andronik Slackware 3 12-20-2004 04:43 PM
/sbin/ldconfig alaios Linux - Newbie 1 10-21-2004 05:46 PM
/sbin/ldconfig and X problems c31c Slackware 1 06-28-2004 11:24 AM


All times are GMT -5. The time now is 07:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration