LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-04-2005, 03:25 AM   #1
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Rep: Reputation: 15
SB live with 10.1 - half works!?


Ok, I'm new to Slackware and relatively new to GNU/Linux (about 2 months). I've used Debian, Ubuntu and SuSE 9.2 Pro so far. I'm checking out Slackware 10.1 and really like it so far. Here's the problem. When I installed Slackware, I had my Audigy LS installed just to see if it would work, I've never gotten it to work with any of the other distros I mentioned. It didn't. So I slapped in my old SB live which has worked with every distro I mentioned with no tweaking at all, just plug and play. With Slackware, an unusual problem has occurred. I have sound, I can aplay from a command prompt, I have system sounds, however, I can't adjust the volume from the volume control in the panel. When I try it just jumps back to the lowest setting when I drag it up. Also, if I try to launch volume control application from multimedia (using Gnome 2.6), I get the following message:

"Sorry, no mixer elements and/or devices found"

Obviously, there is a sound device running since I can play wave files and hear system sounds, however, my CD player doesn't work, figure it has something to do with this issue. Also, in Gnome, under Applications>Desktop Preferences>Advanced>Multimedia Systems Selector, you have the option of selecting and testing what sound system - ALSA, OSS or ESS - is to be used. On all my other Linux installs, those have always been the options and they always work with the SB live. On this install (Slackware 10.1) the only thing listed is 'Custom' and it does nothing except cause the selector application to crash if you try to pipe (test) the sound. It's looking like my suspicions this issue may have been caused by my not having the SB live installed when I installed Slackware is probably what's causing this strange behavior. Maybe this is a Gnome issue and has occurred because I didn't have the card in at install. Anyone have any ideas? I have never had any trouble getting an SB live to work with either Linux or Gnome, it always works by default. Thanks.
 
Old 03-04-2005, 06:04 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Which drivers are loaded the alsa drivers or the oss drivers? Please post the output from /sbin/lsmod.
good luck.
 
Old 03-05-2005, 11:17 PM   #3
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Peacedog
Which drivers are loaded the alsa drivers or the oss drivers? Please post the output from /sbin/lsmod.
good luck.
Module Size Used by Tainted: P
snd-seq-oss 23552 0 (autoclean) (unused)
snd-seq-midi-event 3264 0 (autoclean) [snd-seq-oss]
snd-seq 35024 2 (autoclean) [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 36704 0
snd-mixer-oss 12152 1 [snd-pcm-oss]
uhci 24284 0 (unused)
ehci-hcd 17516 0 (unused)
usbcore 58860 1 [uhci ehci-hcd]
nvidia 3205624 6
3c59x 26544 1
snd-emu10k1 65860 1
snd-hwdep 4352 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emu10k1]
snd-ac97-codec 52472 0 [snd-emu10k1]
snd-pcm 54504 0 [snd-pcm-oss snd-emu10k1 snd-ac97-codec]
snd-timer 13412 0 [snd-seq snd-emu10k1 snd-pcm]
snd-rawmidi 12320 0 [snd-emu10k1]
snd-seq-device 3812 0 [snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd 31268 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-hwdep snd-util-mem snd-ac97-codec snd-pcm snd-timer snd-rawmidi snd-seq-device]
soundcore 3396 8 [snd]
snd-page-alloc 4712 0 [snd-seq-oss snd-seq snd-mixer-oss snd-emu10k1 snd-hwdep snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
emu10k1-gp 1192 0 (unused)
gameport 1420 0 [emu10k1-gp]
ntfs 51232 2 (autoclean)
ide-scsi 9392 0
agpgart 45092 3


Thing is, when I run KDE everything works perfectly, I even have xine running commercial DVDs with fully synced surround sound.Seems like a Gnome issue rather than a kernel issue. What do ya think?
 
Old 03-07-2005, 11:43 AM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Could be an esd problem, kde uses arts.
good luck.
 
Old 03-07-2005, 02:54 PM   #5
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Check to see if you have /dev/dsp, if not that's your culprit. As the other poster stated, GNOME uses ESD and, unless I'm mistaken, ESD looks for /dev/dsp.

Later,
MMYoung
 
Old 03-07-2005, 03:30 PM   #6
MMYoung
Member
 
Registered: Apr 2004
Location: Arkansas
Distribution: Ubuntu 8.10
Posts: 365

Rep: Reputation: 30
Another thing you might want to do, if you haven't already, is to run alsaconf as root. This is an automated ALSA setup "routine" that will make sure (well mostly sure anyway) that your system is set up to run ALSA at boot. After alsaconf runs type in, again as root:
Code:
alsactl store
Also, check to see if you have /etc/rc.d/rc.alsa AND that it is set to run at boot (executable). The easiest way to do this is to open a terminal and just type in dir /etc/rc.d (don't have to be root). If rc.alsa is yellow then it's set to start at boot. If it ain't yellow, log in as root and type in:
Code:
chmod 755 /etc/rc.d/rc.alsa
If you don't have an rc.alsa, re-install the alsa-utils-1.0.8 package from the 10.1 CD. Also, make sure the alsa-oss package from the cd is installed. You can do this from the terminal (user or root no matter) by typing in:
Code:
dir /var/log/packages/alsa*
This will display all the alsa packages installed on your PC. If the alsa-oss-1.0.8 isn't installed you will need to install it as well. BTW, this isn't OSS (as it has been depreciated) what this is, is ALSA's OSS compatibility layer for programs that still look for OSS stuff in /dev (like /dev/dsp).

Now all the necessary ALSA packages are installed, your mixer settings are saved and ALSA will start at boot. A couple more things to be "on the safe side". You will need to edit either the /etc/modules.conf (2.4 kernel) or the /etc/modprobe.conf (2.6 kernel) and add the following to the end:

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

HTH,
MMYoung
 
Old 03-07-2005, 04:35 PM   #7
sharkzf6
Member
 
Registered: Jan 2005
Location: San Antonio, TX
Distribution: Debian Sarge, SuSE 9.2, Ubuntu Warty, Slackware 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by MMYoung
Another thing you might want to do, if you haven't already, is to run alsaconf as root. This is an automated ALSA setup "routine" that will make sure (well mostly sure anyway) that your system is set up to run ALSA at boot. After alsaconf runs type in, again as root:
Code:
alsactl store
Also, check to see if you have /etc/rc.d/rc.alsa AND that it is set to run at boot (executable). The easiest way to do this is to open a terminal and just type in dir /etc/rc.d (don't have to be root). If rc.alsa is yellow then it's set to start at boot. If it ain't yellow, log in as root and type in:
Code:
chmod 755 /etc/rc.d/rc.alsa
If you don't have an rc.alsa, re-install the alsa-utils-1.0.8 package from the 10.1 CD. Also, make sure the alsa-oss package from the cd is installed. You can do this from the terminal (user or root no matter) by typing in:
Code:
dir /var/log/packages/alsa*
This will display all the alsa packages installed on your PC. If the alsa-oss-1.0.8 isn't installed you will need to install it as well. BTW, this isn't OSS (as it has been depreciated) what this is, is ALSA's OSS compatibility layer for programs that still look for OSS stuff in /dev (like /dev/dsp).

Now all the necessary ALSA packages are installed, your mixer settings are saved and ALSA will start at boot. A couple more things to be "on the safe side". You will need to edit either the /etc/modules.conf (2.4 kernel) or the /etc/modprobe.conf (2.6 kernel) and add the following to the end:

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

HTH,
MMYoung
I'll give all this a go when I can, I'm using my Debian boot right now. It's small (6 gig) but works perfectly. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo only half works... after Slack10.2 A.C. Helm Slackware 11 09-29-2005 12:46 PM
SB live with Slackware 10.1 - half works!? sharkzf6 Linux - Hardware 7 03-04-2005 06:05 AM
Grub only half works Gsee Linux - General 32 01-16-2005 07:52 PM
Why SB Live! 5.1 digital work only half? snabgi Linux - Hardware 1 07-29-2004 12:48 PM
php works HALF on slackware tuxandme Linux - Software 1 02-04-2004 12:06 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration