LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-22-2006, 12:07 PM   #1
kkiedrowski
Member
 
Registered: Mar 2004
Posts: 47

Rep: Reputation: 15
SATA and Kernel 2.6.16


I am trying to get the 2.6.16 kernel to install on a dell SX280
The propblem is the SATA drive. [i get panic errors]
I have seached and seached but am not sure what is going on.
in the bios to get version 10.2 to install I had to enable the combined mode and I had use the sata.i image to install
I am not sure which option to enable r set as modules for this SATA drive.
Can anyone help?
 
Old 03-22-2006, 01:51 PM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
I can.
1)Firsly, tell me what is your controller in motherboard for sata.
2)You can check if it is mentioned in kernel configuration.
3)If you found it, you should compile it into the kernel.
4)Disable all other not yours controllers because they all are arguing with each other and give kernel panics.
5)Enable scsi_sata support, disable ide_sata support (it is deprecated).
6)Compile your filesystem support into the kernel.
7)Edit fstab and change hd* to sd* (don't know if it really affects how system boots (and so kernel panics) but it would be very good to do after successful reboot). Maybe someone could enlighten me about this issue.
 
Old 03-22-2006, 02:06 PM   #3
alphisb0t
Member
 
Registered: Jun 2004
Distribution: gentoo 2008.desktop
Posts: 110

Rep: Reputation: 15
Hi. Precisely the same problem here. I have no idea what my onboard controller is. My laptop is a Toshiba which has only basic details here: http://www.edmunds-enterprises.com/l...SIN/B000DT85ZK

Quote:
5)Enable scsi_sata support, disable ide_sata support (it is deprecated).
Where can I find these settings? I use make menuconfig.

- slacker
 
Old 03-22-2006, 02:08 PM   #4
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
If I am right, they should be under device drivers. Scsi under scsi block and ide under ide block. Look carefully and you won't miss. Don't know about controller. Maybe Intel SATA controler would be appropriate. Don't know really. Maybe somebody else owns this laptop. Didn't you get any docs with your computer?

Last edited by Alien_Hominid; 03-22-2006 at 02:13 PM.
 
Old 03-22-2006, 03:00 PM   #5
kkiedrowski
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
I did a search and i think this is the controller
Intel Corp. I/O Controller Hub SATA cc=ide
Class 0x1018f: Mass storage controller/IDE interface


this this part
7)Edit fstab and change hd* to sd* (don't know if it really affects how system boots (and so kernel panics) but it would be very good to do after successful reboot). Maybe someone could enlighten me about this issue.

goof up my existing kernel? it is set to look to hda2 and boots no problem
 
Old 03-22-2006, 03:09 PM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
If your new sata enabled kernel will work, it will search for sda rather than hda.
 
Old 03-22-2006, 03:11 PM   #7
kkiedrowski
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
does this then mean i should change it on lilo for both entires?
 
Old 03-22-2006, 03:33 PM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
You can try setting sda for the new kernel and leaving hda for the old one. Here is mine:
Code:
boot = /dev/sda
default = Muvo

image = /boot/vmlinuz-2.6.16-rc5
root  = /dev/sda3
label = Muvo
read-only

image = /boot/vmlinuz
root =  /dev/hda3
label = Linux-Original
read-only
If it does not boot, use Slackware 1CD and restore previous values in lilo.

My fstab:
Code:
/dev/sda3        /                ext2        defaults         1   1
/dev/sda1        /ntfs-c          ntfs        ro               1   0
/dev/sda5        /ntfs-d          ntfs        ro               1   0
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
none		/sys		sysfs		defaults	0   0

Last edited by Alien_Hominid; 03-22-2006 at 03:36 PM.
 
Old 03-22-2006, 03:38 PM   #9
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
With the Dell Optiplexes here, when the disk mode is set to combined, Slackware sees the drive as IDE (hda) and with the mode set to normal it sees it as sda. If you have problems with configuring lilo, try making sure that your kernel supports both and toggle the BIOS settings again.
 
Old 03-22-2006, 03:41 PM   #10
alphisb0t
Member
 
Registered: Jun 2004
Distribution: gentoo 2008.desktop
Posts: 110

Rep: Reputation: 15
Ok here's an update on the situation. In lilo after selecting my kernel (2.6.16) I set root=/dev/sda4 as a parameter (which I can make permanent in lilo.conf) just to see if it would boot. The kernel panic went away! However, it fails to check disk! For some odd reason it STILL sees the partition as ext2! Even if I explicitly make an initrd for ext3!

Anyway after the check disk fails, also with a warning that swap doesn't exist (because fstab says its /dev/hda3 and not /dev/sda3), it allows me to login as root to "correct the problem" and tells me to run sbin/chkfs (im not sure of the spelling sorry) manually.

I do so, but using /dev/sda4 instead of /dev/hda4 and the checkdisk completes! However as soon as I exit the single user mode it reboots. So my questions are these:

1) how can I make it use ext3 and not ext2? I've already compiled IN ext2/3/jbd support!

2) how can I make checkdisk check sda4 and not hda4? This happens every boot.

3) how can I change fstab to use sdaX instead of hdaX and STILL retain the hdaX for my 2.4 kernel???

- slacker

EDIT: I'd just like to add that my BIOS has only "standard ide" and "enhanced ide (normal)". There is no mention of combined..

Last edited by alphisb0t; 03-22-2006 at 03:49 PM.
 
Old 03-22-2006, 03:47 PM   #11
kkiedrowski
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
I have it set to combined and it does not see the hda for 2.6 but works fine for 2.4
if I HAVE tomess with fstab i will but i would prefer not too.
I even took a look at a suse 10 kernel config file [suse 10 was installed on another identical machine that works fine with its 2.6 kernel] I may just try and cimpile the kernel with that
if i had haor it would all be pulled out now
 
Old 03-22-2006, 04:07 PM   #12
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
My hackish and bad solution: in your lilo.conf comment read only section after your new kernel. Then reboot. It will complain about not read only system but won't reboot.
I think that suse's configuration is slightly different from Slackware due their patched kernel.

Last edited by Alien_Hominid; 03-22-2006 at 04:08 PM.
 
Old 03-22-2006, 08:26 PM   #13
alphisb0t
Member
 
Registered: Jun 2004
Distribution: gentoo 2008.desktop
Posts: 110

Rep: Reputation: 15
Ok here's another update. I've changed everything in fstab to point from hdaX to sdaX. This along with setting my lilo.conf to everything hdX to sdX has fixed all problems booting the 2.6 kernel.

What I have learned is that simply having a root=/dev/sda4 when booting 2.6 is NOT enough. The reason is because although it can see the partition, when it checks fstab it STILL uses the data there to do things such as fsck. And when fstab says hda and not sda there will be problems.

My 2.6 kernel boots perfectly now. I've even got ndiswrapper detecting my wireless card (although when I modprobe after turning it on the system hangs then reboots). But at least its being detected ;P

My current issue is finding those alleged sk98lin drivers for my Marvell Yukon WIRED card (yes I have a wired one too). Unfortunately EVERY single piece of information refers to a site which NO LONGER HAS those drivers. Apparently sky-whoever decided that supporting linux wasn't fun anymore.

I hope someone else can get their kernel up from my small but interesting finds.

- slacker
 
Old 03-23-2006, 12:36 AM   #14
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
You can choose sk98lin driver from linux kernel (there is an option for it).
 
Old 03-23-2006, 07:51 AM   #15
alphisb0t
Member
 
Registered: Jun 2004
Distribution: gentoo 2008.desktop
Posts: 110

Rep: Reputation: 15
Yes I've only recently noticed the drivers for Yukon chipsets there, as well as some newer ones above it. I didn't catch the "New yukon" or the other one simply because I had assumed it would start with "Marvell". I now have built in support for my wired ethernet card!

Wireless is now the issue ;P I have tried both ndiswrapper and ipw2200 with failures resulting in the dmesg log.

I'd just like to point out that the option to "allow firmware" does not exist, only its negative. "disallow firmware to be built" and some other negative. By unchecking them I assume that it has been enabled. Grepping the .config file reveals that CONFIG_FW_LOAD is =y. So it should be fine.

- slacker
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SATA support on a 2.4.31 kernel pafrica Slackware 9 02-06-2006 01:35 PM
SATA on a 2.4.31 kernel pafrica Linux - Hardware 4 02-06-2006 12:47 AM
kernel 2.4 -> kernel 2.6 problems with Maxtor SATA Bultot Linux - Hardware 2 01-19-2005 01:58 AM
SATA problem with kernel 2.6.9 Zolex Debian 6 11-15-2004 05:46 AM
RH9 and SATA - Kernel 2.4.27 - how to get SATA to work? rolf_mueller Linux - Hardware 5 10-30-2004 08:30 PM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration