LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-19-2005, 04:17 PM   #1
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
Samba without authentication


I have a linux server running samba server and want to make a share and I dont want that the login dialog box appear in the windows box when try to access my server...
if some machine try to connect to another windows box it doesnt ask for password but when trying to access the linux box it asks...

how can I leave my server share open so any machine in the network could access it without providing a password?


regards
 
Old 11-19-2005, 04:19 PM   #2
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
this is my smb.conf file:

Code:
[global]
workgroup = CODT
netbios name = LinuxFirebird
server string = Linux Server
security = user
encrypt passwords = yes
local master = no
;guest account = firebird
guest ok = yes
#===== Share Definitions =====
[homes]
comment = Home Directories
browseable = yes
writable = yes

[public]
comment = Firebird DB server
path = /var/firebird
public = yes
writable = yes
guest ok = yes
 
Old 11-19-2005, 11:59 PM   #3
slackwh0re
LQ Newbie
 
Registered: Oct 2003
Posts: 16

Rep: Reputation: 0
Code:
[global]
        workgroup = PARTYDOME
        server string = Samba Server
        map to guest = Bad User
        log file = /var/log/samba.%m
        max log size = 50
        dns proxy = No
        interfaces = 192.168.0.0/24
        bind interfaces only = yes
        map guest user = Bad User
[homes]
        comment = Home Directories
        read only = No
        browseable = No

[storage]
        comment = storage
        path = /storage
        guest only = Yes
        guest ok = Yes
thats my smb.conf

basically it does prompt the user for a login, and if the user provides a bad username/password, it will automatically direct the user to the guest account. this is not exactly what you want, but i find it works the best because you can have people authenticating to their home shares and my storage drive (as you can see), as well as just allowing guests to access the storage drive only.

if you're still after no authentication screen what so ever.. your answer is around here:

http://www.oreilly.com/catalog/samba...k/ch06_03.html

Quote:
If the share is guest only , the user is immediately granted access to the share with the rights of the user specified by the guest account parameter; no password checking is performed.
 
Old 11-21-2005, 04:33 AM   #4
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
Thanks, this helped me... I made a share like storage and it doesnt ask for a password.... but the option map guest user doesnt exist.. you can check with the command testparm


regards [ ]'s
 
Old 11-21-2005, 04:43 AM   #5
slackwh0re
LQ Newbie
 
Registered: Oct 2003
Posts: 16

Rep: Reputation: 0
whoa.. you've just pointed out a mistake ive had in my smb.conf file for possibly years !

it should be: map to guest = Bad User

see http://au1.samba.org/samba/docs/man/...mb.conf.5.html
 
Old 11-21-2005, 06:56 AM   #6
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
you helped me and I helped you, this is the beauty of the forums LOL

 
Old 11-21-2005, 06:07 PM   #7
chrisortiz
Member
 
Registered: Nov 2005
Distribution: Slackware, and of course the super delux uber knoppix universal live recovery cd
Posts: 429

Rep: Reputation: 30
Code:
[global]
workgroup = CODT
netbios name = LinuxFirebird
server string = Linux Server
security = user
encrypt passwords = yes
local master = no
;guest account = firebird
guest ok = yes
#===== Share Definitions =====
[homes]
comment = Home Directories
browseable = yes
writable = yes

[public]
comment = Firebird DB server
path = /var/firebird
public = yes
writable = yes
guest ok = yes
you could also just change

Code:
security = user
to
Code:
security = share
then:
smbd restart
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Authentication Problem Sloppyunderfoot Linux - Networking 0 01-25-2005 11:51 AM
Samba authentication leeloo2 Linux - Newbie 2 12-13-2004 06:32 PM
Samba authentication cmoloney Linux - Networking 32 12-01-2003 10:36 PM
Samba, winbind, NT authentication Karma Linux - Networking 0 10-16-2002 04:32 PM
Samba authentication ltrain Linux - Networking 1 06-13-2001 04:44 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration