Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 03-06-2007, 10:59 PM   #1
Registered: Mar 2007
Location: NJ
Distribution: Slackware 11, Fedora Core 6, Opensuse 10.2, CentOS 4.4
Posts: 31

Rep: Reputation: 15
Samba/Slack11/Permisions or Config

I think im having a prob with the config and/or directory permissions. My slack machine was able to join my windows workgroup no problem.

  comment = zomg share
  path = /home/tehfatal/shared
  public = yes
  readable = yes
  only guest = no
  writable = yes
  printable = no
  create mask = 0757
1st problem:
I cant create files in //Zomg/tehfatal/share/ but i can view the directory and view a txt file i put in there. The permissions on that directory is 757.

2st problem:
In windows, when i go into workgroup computers and click into the slack machine, 3 folders show up "shared" (which i dont have access to for some reason, "homes" and "tehfatal" (which i do have access to and have identical contents). Did i mess up pdbedit when i added myself?

Old 03-06-2007, 11:24 PM   #2
Registered: Nov 2005
Location: Waco, TX
Distribution: Fedora and DSL
Posts: 49

Rep: Reputation: 15

There are several points I would like to clear.

1. Is it a typo that the config file you have "path = /home/tehfatal/shared" as your shared directory, and when you tried to access it, you use "//Zomg/tehfatal/share/" instead of "//Zomg/tehfatal/shared/" ?

2. In terms of permission setting, I am just wondering, can you set it to 777 instead of 757? It does not make sense that everyone else can edit/modify but people in your group cannot. I think probably this is why that you cannot modify the files under the directory.

3. I am not sure if your windows username and password are identical to that of your linux machine. If you have the same username and password, then your linux box will log you in and use that permission for all the act. If your windows does not use any login and password, then the linux box will treat it as guest. The last number of permission will apply. I still think you should change the permission to 777 instead of 757 if you really want to share that in windows environment.

4. If you would like to have a protected environment, then you better set up a well defined group permission and then set up password and userIDs and make your windows login and password match it. If everything set correctly, even if you have guests, you need not worry someone else will delete your files.

5. Final thing to check, make sure that after modification of your smb setup, restart your samba service to flush the setting.
Old 03-07-2007, 12:06 AM   #3
Registered: Mar 2007
Location: NJ
Distribution: Slackware 11, Fedora Core 6, Opensuse 10.2, CentOS 4.4
Posts: 31

Original Poster
Rep: Reputation: 15
//Zomg/tehfatal/share isnt a typo its a directory in my home.

But i realized i didnt put a 'shared' folder in my home directory, once i did, i can correctly access it. thanks, need better naming conventions lol.

but still my other folders are showing homes, and tehfatal. i think im going to redo my smb.conf



conf, permissions, samba, slackware, smbconf, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Workstation Permisions On Samba Domain treedstang Linux - Enterprise 4 04-14-2006 11:56 AM
howto chowto change file permisions in multiplhange file permisions in multiple dirs? pingvina Linux - Software 3 01-13-2006 03:10 PM
Webmin cannot handle Samba config files that use the config or include directives allelopath Linux - Networking 3 01-18-2005 09:36 AM
Samba permisions trouble - directorys are fine but the contents are not rwtreke Linux - Software 0 01-13-2005 05:09 PM
Windows 2000 Permisions under Samba wyndman Linux - Networking 2 09-05-2003 02:44 PM

All times are GMT -5. The time now is 08:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration