LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Samba/Slack11/Permisions or Config (http://www.linuxquestions.org/questions/slackware-14/samba-slack11-permisions-or-config-535268/)

tehfatal 03-06-2007 10:59 PM

Samba/Slack11/Permisions or Config
 
I think im having a prob with the config and/or directory permissions. My slack machine was able to join my windows workgroup no problem.

smb.conf:
Code:

[shared]
  comment = zomg share
  path = /home/tehfatal/shared
  public = yes
  readable = yes
  only guest = no
  writable = yes
  printable = no
  create mask = 0757

1st problem:
I cant create files in //Zomg/tehfatal/share/ but i can view the directory and view a txt file i put in there. The permissions on that directory is 757.


2st problem:
In windows, when i go into workgroup computers and click into the slack machine, 3 folders show up "shared" (which i dont have access to for some reason, "homes" and "tehfatal" (which i do have access to and have identical contents). Did i mess up pdbedit when i added myself?

thanks!

dreamcarrior 03-06-2007 11:24 PM

Tehfatal,

There are several points I would like to clear.

1. Is it a typo that the config file you have "path = /home/tehfatal/shared" as your shared directory, and when you tried to access it, you use "//Zomg/tehfatal/share/" instead of "//Zomg/tehfatal/shared/" ?

2. In terms of permission setting, I am just wondering, can you set it to 777 instead of 757? It does not make sense that everyone else can edit/modify but people in your group cannot. I think probably this is why that you cannot modify the files under the directory.

3. I am not sure if your windows username and password are identical to that of your linux machine. If you have the same username and password, then your linux box will log you in and use that permission for all the act. If your windows does not use any login and password, then the linux box will treat it as guest. The last number of permission will apply. I still think you should change the permission to 777 instead of 757 if you really want to share that in windows environment.

4. If you would like to have a protected environment, then you better set up a well defined group permission and then set up password and userIDs and make your windows login and password match it. If everything set correctly, even if you have guests, you need not worry someone else will delete your files.

5. Final thing to check, make sure that after modification of your smb setup, restart your samba service to flush the setting.

tehfatal 03-07-2007 12:06 AM

//Zomg/tehfatal/share isnt a typo its a directory in my home.

But i realized i didnt put a 'shared' folder in my home directory, once i did, i can correctly access it. thanks, need better naming conventions lol.

but still my other folders are showing homes, and tehfatal. i think im going to redo my smb.conf

thanks


All times are GMT -5. The time now is 08:11 AM.