LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-20-2008, 12:31 PM   #1
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Rep: Reputation: 36
samba issues with a folder shared across a user group


hello everyone,
im trying to set up samba in SHARE level (up until now i had USER level and it seemed abit too tight for a home network)... so that all members of the group 'family' may be read-only accessing some general folders (mp3s, family photos etc) that are located in my home folder.

also there is a folder that i wanna share files with all members of user group 'family' ie so they can be uploading files to this incoming directory (namely winmx) that is also located in the subtree of my home folder...

however, even though the access rights to this folder are 775,nass,family (attr,owner,group) i can't get the other members of the user group 'family' to be able to write and create folders within this incoming folder...
the samba code is:

Quote:
[WinMX]
comment = Incomings - Downloads etc. folder
path = /home/nass/winmx
writable = yes
write list = @family
public = yes
veto files = /.ftpaccess/
any clues of what im missing here to make it work?

obviously each one of my family user accounts belong to the user group 'family' as well...

thank you for your help
nass

Last edited by nass; 01-20-2008 at 02:32 PM.
 
Old 01-21-2008, 09:29 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
I'd guess that the permissions on /home/nass don't let the other users browse to /home/nass/winmx. You could move the contents of /home/nass/winmx to somewhere else (e.g. /usr/local/winmx) and change the share to point there. After that, you could symlink the new location to the old with ln -s /usr/local/winmx /home/nass/winmx) so that you could still get there easily.

Another way would be to modify the permissions of /home/nass so that users could browse through it, but I don't recommend that.
 
Old 01-21-2008, 09:44 PM   #3
centauricw
Member
 
Registered: Dec 2005
Location: Lawrenceville GA
Distribution: Slackware, CentOS. Red Hat Enterprise Linux
Posts: 216

Rep: Reputation: 31
The best thing to do is to make "family" the group owner all files and subdirectories in the directory /home/nass/winmx. Then use "force group = family" in the [WinMX] section. This will force Samba to use the group "family" for all file accesses, regardless of their default group and ensure that everyone can read and write files.
 
Old 01-21-2008, 09:52 PM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
If the /home/nass directory is 0750 it won't matter what permissions are on /home/nass/winmx. Try the following:
Code:
Login as nass
mkdir winmx
chgrp family winmx
chmod 0775 winmx
chmod g+s winmx
Login as another member of the family group
~$ touch /home/nass/winmx/testfile
touch: cannot touch `/home/nass/winmx/testfile': Permission denied
 
Old 01-23-2008, 11:08 AM   #5
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
gilead i immediately run the 'touch' command, from a command line window and it didn't give me any permission denied messages.
in fact from the 'other' user, i could vi, mkdirs etc in the winmx folder...

the winmx folder belongs to group family and and my home folder attributes are 711 for some reason..

the story is a little more complicated than i initially stated it but it shouldn't be a problem (to my understanding)

i have 'binded' through fstab the folder winmx to another folder outside my home directory as:

Quote:
/home/nass/winmx/ /mnt/hd/current/winmx/ bind defaults,bind,rw 0 0
and the samba entry 'populates' the binded folder '/mnt/hd/current/winmx/'

Quote:
[WinMX]
comment = Incomings - Downloads etc. folder
path = /mnt/hd/current/winmx
# path = /home/nass/winmx
writable = yes
write list = @family
public = yes
as i told you, from command line, another user can read/write in the winmx folder or its binded folder. but from a winXP machine, only the user nass can write into the folder.... so im thinking its something to do with my samba config, rather than with the folder attributes....
 
Old 01-24-2008, 01:58 PM   #6
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
Have you tried running testparm to see whether Samba has any problems with the config? Also, is the any info in the logs (usually under /var/log/samba) that gives more detail? By itself, there doesn't look to be a problem with that share setup.
 
Old 01-27-2008, 07:56 AM   #7
nass
Member
 
Registered: Apr 2006
Location: Athens, Greece
Distribution: slack(64|32)_v(13.37|14.0), debian6, ubuntu
Posts: 630

Original Poster
Rep: Reputation: 36
yes i tried, it says everything is ok.
in the end what did the trick is the 'force group = family' option...
i dunno y... and im not sure i mind if all files are family owned but ill keep it at that for now
thank you all for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba password protected shared Folder Mrpeepers310 Linux - Networking 5 09-18-2010 10:04 AM
hide SAMBA shared folder in other user sasi.rrkay Linux - Software 0 06-26-2007 06:05 AM
I can see SAMBA shared folder in XP but can't access it vishivishi Linux - Networking 6 08-30-2006 01:13 AM
I can not open the user folder in home and write in a shared folder jorge_ivan Linux - General 8 08-02-2006 11:28 AM
samba : access denied for some user in same NT group on a folder mtrento Linux - Networking 0 06-27-2005 10:01 AM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration