LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-21-2006, 08:34 PM   #1
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Rep: Reputation: 15
Samba and authentication


Hi,

I have slackware and am trying to connect to my windows network.

In slackware (KDE) I go to Remote Places and then Samba shares.
Mshome then shows up and I click on that and my windows machine shows up. It is called, "64bit(LargeDesk)".

An authorization dialog box comes up and I have to enter a username and password. This box comes up over and over.

I went to the /etc/samba file and here's what is in it, "Private, smb.conf-sample and smb.conf-sample~"

I edited smb.conf-sample and put these in

[HTML][global]
workgroup = MSHOME

hosts allow = 192.168.1.1 (actually hosts had a ; in front of it and I have taken it out.

Interfaces = 192.168.1.66

Share Definitions
[homes]
comment = Home
browseable = yes
writable = yes
create mode = 0750

I put this believing that cdrive is a directory. I placed cdrive directory in /mnt

[cdrive]
comment= C Drive on 64 bit
path = /mnt/c
valid users = michshelly
public = yes
writable = yes.

/HTML]

Here's what windows says in My Network Places:

View workgroup computers: Mshome
LargeDesk(64 bit) shows up.

Linux does not show up on Windows at all.

I am totally bamboozled and your help would be most appreciated.
 
Old 08-21-2006, 09:21 PM   #2
bernied
Member
 
Registered: Mar 2006
Location: Edinburgh, UK
Distribution: debian
Posts: 304

Rep: Reputation: 30
I'm not sure I can help you but I can at least stop you looking in the wrong direction - that smb.conf file is for the samba shares on your linux machine, it has no effect on remote shares.

Have you checked that smbfs (smb file system) is installed - I don't know how this is done in slack. Look for a package called smbfs would be a start.
 
Old 08-21-2006, 09:44 PM   #3
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hi Bernie,

Thanks for your help and reply. That is a good thought.

I did 'locate smbfs' and there is a heap of stuff about smbfs.

eg:
/lib/modules/2.4.31/kernel/fs/smbfs
/lib/modules/2.4.31/kernel/fs/smbfs/smbfs.o.gz
/usr/src/linux02.4.31/fs/smbfs
/sur/src/linux-2.4.31/fs/smbfs/Makefile
etc
etc
etc
/usr/src/linux-2.4.31/Documentation/filesystems/smbfs.txt


I hope I just need to install it. I shall have a read of the txt file and see what happens.

Linux :-< - there's a lot to learn!

Thanks again
Michshelly
 
Old 08-21-2006, 10:07 PM   #4
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
Get smb4k from linuxpackages

You will need to chmod +s smbmnt and smbumount on your PC ( and do this again every time samba gets upgraded)
 
Old 08-21-2006, 10:11 PM   #5
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hi davidsrsb,

Hmnn, can you tell me how to do this please?

To get smb4k do I do apt smb4k ?

And how about mounting?

thanks
Michshelly
 
Old 08-22-2006, 12:34 AM   #6
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hi again,

I managed to get smb4k.tar.gz. I installed it by ./configure, make, make install.

But I still can't connect to windows network.

How do I know that I am actually using samba 4?

Your help once again would be appreciated.

Thanks
michshelly

Last edited by michshelly; 08-22-2006 at 12:38 AM.
 
Old 08-22-2006, 04:20 AM   #7
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
Smb4k has nothing to do with Samba v4, it stand for smb for kde, where smb is the Windows protocol name.
You can get a tgz package linuxpackages at this url:
http://www.linuxpackages.net/pkg_details.php?id=8014
Download it and install with installpkg.
You need to su to root to chmod the two samba executables I mentioned. Do NOT chmod +s smbmount.
 
Old 08-22-2006, 05:05 AM   #8
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hello Davidsrsb

I went to that site and got the package and installed it using installpkg smb4k-0.7.0.i486 -lasz. Did it overwrite the other one I installed?

The last line of the displays says:
Executing install script for smb4k-0.7.0-i486-lasz...

Then I'm back at the bash shell.

What am i supposed to do now? Has it installed? How do I access it from the web browser Konqueror?

Where do I find the executables?

Thanks so very much for your help. I am totally baffled by all of this but hope to learn it.

Hey, I went to Utilities and found Smb4k(The SMB/CIFS share Browser) and clicked on it. It showed up on the panel bar down below and shows the busy sign and then just disappears.



Michshelly

Last edited by michshelly; 08-22-2006 at 05:09 AM.
 
Old 08-23-2006, 11:59 PM   #9
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hi,

Can someone please tell me why these files:
[HTML]"Private, smb.conf-sample and smb.conf-sample~"[/HTML]

are called samples? Am I in the right place to change the settings etc?

thanks
Michelle
 
Old 08-29-2006, 10:48 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Rep: Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531Reputation: 531
Hi michshelly,

Did you resolve your question?

I've been playing with samba lately with my home network. While looking for some ideas for my own questions I ran across your thread. Here are some thoughts that might help:

1. The sample files are just that: samples. First thing to do is rename smb.conf-sample to smb.conf (without the -sample suffix).
2. Next copy smb.conf-sample~ to smb.conf-sample. The tilde (~) means the file is a backup file. You want to restore the original sample file for future reference.
3. With that said, the /etc/samba/smb.conf is for the samba server, not the samba client. That configuration file has nothing to do with using samba as a client to connect to a Windows box.
4. To use samba to connect to your windows box, use the smbmount command. You also should learn about the smbclient command to test your connections and network.
5. You do not need to execute/run the /etc/rc.d/rc.samba script to run the samba client tools.

If you are using the stock Slackware then you have all the packages and commands already installed to run samba.

I hope this helps.
 
Old 09-01-2006, 11:14 AM   #11
michshelly
Member
 
Registered: Feb 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Hi Woodsman,

thanks for your help. I shall try and look at it this weekend.

Michshelly
 
Old 09-04-2006, 02:18 AM   #12
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
I think ? ? that all you have to do is go into 'control panel' then 'local network browsing' and just put in your windows 'user name' and windows 'password' that you use on your lan and you should be fine. that is supposed to pass your log in's for you. This would of course require you to have the same username and pass on the various windows pc's that you have on your lan, which many people do, so maybe this will take care of your issue? gl.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/XP authentication jxrod2000 Linux - Networking 3 08-09-2006 07:37 PM
Samba without authentication maginotjr Slackware 6 11-21-2005 05:07 PM
Samba authentication leeloo2 Linux - Newbie 2 12-13-2004 05:32 PM
Samba authentication cmoloney Linux - Networking 32 12-01-2003 09:36 PM
Samba authentication ltrain Linux - Networking 1 06-13-2001 03:44 PM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration