LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Salome-Meca doesn't work after slackpkg upgrade-all (http://www.linuxquestions.org/questions/slackware-14/salome-meca-doesnt-work-after-slackpkg-upgrade-all-834397/)

theCapitain 09-25-2010 03:30 AM

Salome-Meca doesn't work after slackpkg upgrade-all
 
Hi, I need help again!
I installed Slackware64 13.1, then Salome-Meca 2010 (and other useful stuff) and everything was fine. Yesterday I upgraded Slackware using slackpkg (great tool!) but now Salome-Meca doesn't work anymore: the Salome GUI starts but becomes unresponsive as far as I enter a module (Geometry or Mesh ). This is rather strange because Salome-Meca is a stand-alone package and AFAIK doesn't relay on system libraries. What has changed?

sahko 09-25-2010 06:17 AM

Whats salome-meca and what did slackpkg upgrade?

Eternal_Newbie 09-25-2010 06:51 AM

salome-meca looks like something to do with CAD/CAM. Depending on when you updated from there is an xorg update and kernel update that could affect things if you are using 3rd party xorg drivers (fglrx or nvidia) and hadn't rebuilt them. It's always a good idea to rebuild 3rd party drivers after kernel or xorg updates.

It does sound like hardware acceleration isn't working. what is the output of
Code:

glxinfo | grep direct
EDIT: looks like Salome-Meca itself has a kernel module, that might also need rebuilding if you installed the kernel update since installing salome-mecha

theCapitain 09-25-2010 08:39 AM

Code:

root@darkstar:~# glxinfo | grep direct
Error: glXCreateContext failed

Oh was that! Thank you Eternal_Newbie, you saved me. I reinstalled the NVIDIA driver and everything is back to normal.


All times are GMT -5. The time now is 12:39 AM.