LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-25-2010, 03:30 AM   #1
theCapitain
LQ Newbie
 
Registered: Jul 2010
Location: Northern Italy
Distribution: Slackware, Slax
Posts: 20

Rep: Reputation: 0
Salome-Meca doesn't work after slackpkg upgrade-all


Hi, I need help again!
I installed Slackware64 13.1, then Salome-Meca 2010 (and other useful stuff) and everything was fine. Yesterday I upgraded Slackware using slackpkg (great tool!) but now Salome-Meca doesn't work anymore: the Salome GUI starts but becomes unresponsive as far as I enter a module (Geometry or Mesh ). This is rather strange because Salome-Meca is a stand-alone package and AFAIK doesn't relay on system libraries. What has changed?
 
Old 09-25-2010, 06:17 AM   #2
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Whats salome-meca and what did slackpkg upgrade?
 
Old 09-25-2010, 06:51 AM   #3
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
salome-meca looks like something to do with CAD/CAM. Depending on when you updated from there is an xorg update and kernel update that could affect things if you are using 3rd party xorg drivers (fglrx or nvidia) and hadn't rebuilt them. It's always a good idea to rebuild 3rd party drivers after kernel or xorg updates.

It does sound like hardware acceleration isn't working. what is the output of
Code:
glxinfo | grep direct
EDIT: looks like Salome-Meca itself has a kernel module, that might also need rebuilding if you installed the kernel update since installing salome-mecha

Last edited by Eternal_Newbie; 09-25-2010 at 07:34 AM.
 
Old 09-25-2010, 08:39 AM   #4
theCapitain
LQ Newbie
 
Registered: Jul 2010
Location: Northern Italy
Distribution: Slackware, Slax
Posts: 20

Original Poster
Rep: Reputation: 0
Code:
root@darkstar:~# glxinfo | grep direct
Error: glXCreateContext failed
Oh was that! Thank you Eternal_Newbie, you saved me. I reinstalled the NVIDIA driver and everything is back to normal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After upgrade all using slackpkg upgrade, configuration is failed to read ethereal1m Linux - Newbie 3 04-28-2010 01:03 AM
slackpkg upgrade-all does not show an upgrade sycamorex Slackware 6 11-03-2009 05:29 AM
error when using slackpkg to upgrade-all vdemuth Slackware 4 04-28-2009 05:02 PM
Upgrade with slackpkg STARHARVEST Slackware 11 05-17-2008 07:07 PM
slackpkg upgrade _mu_ Slackware 9 01-29-2004 08:28 PM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration