LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-12-2010, 10:14 AM   #1
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Rep: Reputation: 0
Question Salckware 13.1 64 bits - Kernel 2.6.34.1 - PCIe PME _OSC error -13


Hi.
I'm sorry. I don't speak English very well.

I have Slack 13.1 64 bits. I compiled my Kernel 2.6.34.1
The Kernel has start normally but I found this message:
Code:
[    0.507900] pcieport 0000:00:10.0: Failed to receive control of PCIe PME service: no _OSC support
[    0.507906] pcie_pme: probe of 0000:00:10.0:pcie01 failed with error -13
[    0.507911] pcieport 0000:00:12.0: Requesting control of PCIe PME from ACPI BIOS
[    0.507916] Firmware did not grant requested _OSC control
[    0.507918] pcieport 0000:00:12.0: Failed to receive control of PCIe PME service: no _OSC support
[    0.507923] pcie_pme: probe of 0000:00:12.0:pcie01 failed with error -13
[    0.507999] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
I don't know What to do. My Kernel is working very well without problem. I believe that's something wrong here.
 
Old 07-12-2010, 10:35 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,529
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209
well says you do not have anything connected to your PCIE.
PCI express video port you either have a built in video card or a pci video card. PCIE is enabled in your bios it is ok. nothing to worry about.
and then you may have forgot to enable pcie suport
when configuring your kernel.

Last edited by Drakeo; 07-12-2010 at 10:39 AM.
 
1 members found this post helpful.
Old 07-12-2010, 03:04 PM   #3
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Post

PCIE support I think is enabled.

I sent two files( kernel-2.6.34.1.txt and config-2.6.34.1.txt )
Attached Files
File Type: txt kerne-26.34.1.txt (68.9 KB, 3 views)
File Type: txt config-2.6.34.1.txt (66.4 KB, 4 views)

Last edited by mobjr; 07-12-2010 at 03:49 PM.
 
Old 07-12-2010, 08:45 PM   #4
hotchili
Member
 
Registered: Sep 2009
Location: Germany
Distribution: slackware64-current
Posts: 69

Rep: Reputation: 17
Hey there,

just wanted to say that I see similar messages with my 2.6.34.1

Code:
[    1.131083] pcieport 0000:00:02.0: Requesting control of PCIe PME from ACPI BIOS
[    1.131091] pcieport 0000:00:02.0: Failed to receive control of PCIe PME service: no _OSC support
[    1.131097] pcie_pme: probe of 0000:00:02.0:pcie01 failed with error -13
[    1.131100] pcieport 0000:00:0a.0: Requesting control of PCIe PME from ACPI BIOS
[    1.131104] pcieport 0000:00:0a.0: Failed to receive control of PCIe PME service: no _OSC support
[    1.131108] pcie_pme: probe of 0000:00:0a.0:pcie01 failed with error -13
Only just noticed because I looked at dmesg , isn't PME some powermanagement stuff?

Edit:
Found that: http://lkml.org/lkml/2010/5/23/104
as I understand it, no big deal, so I will just ignore this message for now.

Last edited by hotchili; 07-12-2010 at 08:58 PM.
 
1 members found this post helpful.
Old 07-12-2010, 11:19 PM   #5
mobjr
Member
 
Registered: Apr 2009
Location: Brazil
Distribution: Slackware
Posts: 50

Original Poster
Rep: Reputation: 0
Thumbs up

Understood.

OK, thanks.
 
  


Reply

Tags
bits, error, kernel, pcie, slack13


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCIe re-enumation in linux driver question (pcie hotplug doesn't work) blavo Programming 5 08-02-2012 02:12 PM
Can I install Linux 32 bits on system 64 bits? miros84 Linux - Software 7 01-06-2010 07:49 AM
How do you make the Linux kernel inherit bios pcie config dbrazeau Linux - Embedded & Single-board computer 1 10-20-2009 08:11 PM
Kernel Recompile - Blank screen - ATI X800 PCIe kailun Slackware 10 09-15-2006 05:55 PM
32 bits version distros running 64 bits CPU javb Linux - General 4 04-02-2006 07:21 AM


All times are GMT -5. The time now is 12:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration