LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Running slackware 14 current can not upgrade kernel. (http://www.linuxquestions.org/questions/slackware-14/running-slackware-14-current-can-not-upgrade-kernel-4175444889/)

zrdc28 01-09-2013 08:48 PM

Running slackware 14 current can not upgrade kernel.
 
Running slackware current 32 bit, when I do a slackpkg upgrade-all it shows that kernel 3.7 loads & installs but when I do a uname -a the kernel shows to be 3.2.29-smp. It never asks for me to run lilo like it did on my other 64 bit machine. I have upgraded 2 times and had the same problem each time. Running lilo changes nothing. If have a solution please reply.

perbh 01-09-2013 10:20 PM

Check if it can be found in /boot _and_ /lib/modules. If so, just update lilo/grub/whatever-you-use to use the new kernel

zrdc28 01-10-2013 10:00 AM

Thanks, I will try that when I get home this afternoon!

zrdc28 01-10-2013 06:11 PM

I looked in both /boot and in /lib/modules and there is no info of any kind to any kernel except the 3-2-29, for some reason the newer 3-7 kernel is not being installed. When I look at my 64 bit machine using current it only has kernel 3-7-1. I will try qne more update and see what develops. Thanks

zrdc28 01-10-2013 06:28 PM

I found the problem, I had blacklisted old kernel in /etc/slackpkg/blacklist. I never remember doing it but it was blacklisted.


All times are GMT -5. The time now is 03:55 AM.