LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-18-2006, 07:47 PM   #1
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
Running cupsd on startup


After upgrading to Slack 10.2, it seems cupsd is no longer started for me on boot. Where is the "correct place" to put this? I can't find it in /etc/rc.d. Also, is there a way to allow it to print (from the single computer you're using it on), but without it opening up a port with ipp listening for outside connections?
 
Old 01-18-2006, 07:54 PM   #2
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 49
You can either put it in /etc/rc.d (make sure it's executable), or you can put a link to it in rc.local

As to your second question ... I have no idea
 
Old 01-18-2006, 08:15 PM   #3
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Got it, thanks. I would like to know about that port though if anyone has ideas. It doesn't seem like I should have to open up to the outside world just to send files to my printer.
 
Old 01-18-2006, 08:24 PM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
There are some settings in /etc/cups/cupsd.conf that might do what you want. Have a look at `man cupsd.conf` for Browsing and in the conf file itself for BrowseAllow and BrowseDeny
 
Old 01-18-2006, 08:24 PM   #5
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
you can check /etc/cups/cupsd.conf
for config options

iirc, it denies all but localhost by default
 
Old 01-18-2006, 11:30 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,471

Rep: Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519
Quote:
Got it, thanks. I would like to know about that port though if anyone has ideas. It doesn't seem like I should have to open up to the outside world just to send files to my printer.
With root privileges, with a text editor open /etc/cups/cupsd.conf. Search for the following:

# Listen to (Port/Listen)

Comment out all line in that section by adding a hash mark (#) at the beginning of the line. Then add thee following in that same section:

Listen 127.0.0.1:631

This command will limit cups to listening only on port 631 of the box the printer is attached.

To make these changes effective immediately, as root type:

/etc/rc.d/rc.cups restart

if the rc.cups script is not executable type:

sh /etc/rc.d/rc.cups restart

Before making the changes effective, from the command line type:

nmap -v localhost

Restart the cups daemon and then run nmap again. You should see a difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Programs at Startup burningsun1981 Linux - Newbie 2 07-03-2005 07:56 PM
Running scripts on startup darrenjhopkins Linux - Newbie 7 12-09-2004 04:51 AM
Parallel-port CD not mounting when cupsd is running marcelocp Slackware 2 11-04-2003 02:53 PM
Running programs at X startup azid Slackware 3 05-24-2003 11:12 AM
Running a service at startup correro Linux - General 14 02-18-2003 07:00 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration