LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2014, 06:50 PM   #1
slack_
Member
 
Registered: Oct 2013
Distribution: Slackware, Arch
Posts: 91

Rep: Reputation: Disabled
Rubygems install fails with ruby error


Trying to install the rubygems slackbuild and I received this error:

Code:
/usr/lib64/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method `find_by_path' for Gem::Specification:Class (NoMethodError)
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/config_file.rb:34:in `<class:ConfigFile>'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/config_file.rb:12:in `<top (required)>'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/gem_runner.rb:8:in `<top (required)>'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from setup.rb:25:in `<main>'
I got a ruby error while trying to install a ruby package manager. Not a clue where to begin.

EDIT: For those who have troubles with this, using this slackbuild worked out for me: http://slackbuilds.org/repository/14...bygems-update/

Last edited by slack_; 04-27-2014 at 07:42 PM.
 
Old 06-22-2014, 05:25 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,140
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
Thanks for posting the nfo.
Off of the 0-reply list now.


//NTLB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with ruby on ubuntu linux [rubygems also] BlackHawk Linux - General 1 01-15-2013 11:41 PM
Ruby/Rake install error on SiriProxy fmillion Linux - Software 1 01-23-2012 09:52 PM
LXer: How to install Ruby and RubyGems LXer Syndicated Linux News 0 08-13-2009 04:21 PM
[SOLVED] Slackware, ruby, rubygems and rubygames. Linux.tar.gz Linux - Software 5 09-17-2008 04:33 PM
error when emerging rubygems *CLI> Linux - Server 2 03-25-2008 03:16 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration