LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Rubygems install fails with ruby error (http://www.linuxquestions.org/questions/slackware-14/rubygems-install-fails-with-ruby-error-4175503170/)

slack_ 04-27-2014 06:50 PM

Rubygems install fails with ruby error
 
Trying to install the rubygems slackbuild and I received this error:

Code:

/usr/lib64/ruby/1.9.1/rubygems.rb:206:in `try_activate': undefined method `find_by_path' for Gem::Specification:Class (NoMethodError)
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/config_file.rb:34:in `<class:ConfigFile>'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/config_file.rb:12:in `<top (required)>'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /tmp/SBo/rubygems-1.3.4/lib/rubygems/gem_runner.rb:8:in `<top (required)>'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib64/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from setup.rb:25:in `<main>'

I got a ruby error while trying to install a ruby package manager. Not a clue where to begin.

EDIT: For those who have troubles with this, using this slackbuild worked out for me: http://slackbuilds.org/repository/14...bygems-update/

unSpawn 06-22-2014 05:25 AM

Thanks for posting the nfo.
Off of the 0-reply list now.


//NTLB


All times are GMT -5. The time now is 05:36 AM.