LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2007, 04:52 AM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,218

Rep: Reputation: 176Reputation: 176
RPPPoEK. How to make it global?


There is a clever little program from Roaring Pengiun that installs a GUI for pppoe on the KDE desktop. In the tray, actually.
It only lets root set it up and install it and once done I cannot use it as a user. I have to open a terminal box sign in as root, run "pppoe-start," and then I can watch the little globe turn green when the connection is made.
I've read what I can find, but can't figure out how to set it up so a user can start and stop pppoe with it.
Any ideas would be greatly appreciated.
Thanks.
 
Old 03-21-2007, 03:26 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Change the permissions of the executable or group permissions. I'd imagine it's using other things only root is allowed to access but I've never used RPPP.

I'd just setup sudo access to the command for the users you want to have access to, perhaps make it passwordless even to not be bothered with a password.
 
Old 03-21-2007, 03:35 PM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
You could also try writing a script to run that, chown the script to root, and set the SUID bit on the script.
 
Old 03-21-2007, 09:59 PM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,218

Original Poster
Rep: Reputation: 176Reputation: 176
I gone through and changed the permissons on every file I can find that is related to rppppoe and pppoe and nothing has change. Root is still the only what can use the gui to rppppoe.
 
Old 03-22-2007, 10:28 AM   #5
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally Posted by cwizardone
I gone through and changed the permissons on every file I can find that is related to rppppoe and pppoe and nothing has change. Root is still the only what can use the gui to rppppoe.
Like mentioned before, it's not just rpppoe, it most likely uses devices and other files that only root has access to. You're probably better off setting up sudo for the program to the users you want to have access to instead of changing permissions on files that might hinder functionality of the program, etc.
 
Old 04-30-2007, 08:02 PM   #6
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,218

Original Poster
Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by trickykid
Like mentioned before, it's not just rpppoe, it most likely uses devices and other files that only root has access to. You're probably better off setting up sudo for the program to the users you want to have access to instead of changing permissions on files that might hinder functionality of the program, etc.
Well, I finally found my way to their web site and dug around and if you want to run pppoe-start as a user, that is what you have to do, i.e., set up a /etc/sudoers file.
This really completely defeats the purpose of having their little RPPPPoEK .40 utility.
Regardless, I cut and pasted their example to the /etc/sudoers file, but I can't get it to work. It says it has to be edit with visudo, so I tried that. Still doesn't work. I read the MAN on visudo and don't see where it says how to save and exit once you have finished your editing.
When I run any of the commands from the file I get the same error, i.e., "syntax error. line 34. Parse error in etc/sudoers near line 34.

Here is my /etc/sudoers file:
# sudoers file.
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the sudoers man page for the details on how to write a sudoers file.
#

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults specification

# Runas alias specification

# User privilege specification
root ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
# %wheel ALL=(ALL) ALL

# Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL

# Samples
%users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom,/sbin/mount /dvd,/sbin/umount /dvd
%users ALL=/sbin/mount /cdrom2,/sbhin/umount /cdrom2
%users localhost=/sbin/shutdown -h now
%users localhost=/sbin/shutdown -r now

# Allow members of the group "dialout" to connect to the internet:
%dialout ALL=(ALL) NOPASSWD: /usr/sbin/pppoe-start, /usr/sbin/pppoe-stop
%users ALL=(ALL) NOPASSWD: /usr/sbin/pppoe-start, /usr/sbin/pppoe-stop

Any help would be greatly appreciated.
Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I like global warming. slapNUT General 177 12-12-2006 04:04 AM
php UG for global betterworld07 Linux User Groups (LUG) 0 04-02-2006 06:11 PM
proftp, global ip and a few more;) dslboy Linux - Networking 1 08-20-2004 02:51 AM
How make a script in order to set global alias? RickHunter_Ve Linux - Newbie 7 06-08-2004 02:13 PM
WAS Global Security haobaba1 Programming 0 03-11-2004 08:19 PM


All times are GMT -5. The time now is 05:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration