LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   router port forwarding/ssh (http://www.linuxquestions.org/questions/slackware-14/router-port-forwarding-ssh-129840/)

epoo 12-29-2003 02:19 PM

router port forwarding/ssh
 
im trying to allow ssh connections to my slackbox through the router. i changed it to port 55, and im able to connect to the machine fine through the internal ip, but when i try to connect to the external ip on port 55 using ssh, it times out. ive added the internal router ip - 192.168.0.1 - to the hosts.allow file, but it still doesnt work. any suggestions ?

trey85stang 12-29-2003 03:05 PM

i thought ssh was port 22?

epoo 12-29-2003 07:43 PM

usually it is, but i changed it to 55.

trey85stang 12-29-2003 08:13 PM

Quote:

Originally posted by epoo
usually it is, but i changed it to 55.
thats odd that it will not let you connect.. are you going through a comapny firewall??

epoo 12-29-2003 08:30 PM

no, this is all through home. im just wondering which files i should look at, or anything special i have to do to enable outside connections. it should just show as connecting through 192.168.0.1 , right ?

h3pc4t 12-30-2003 03:02 AM

Uh, is your router set up to forward port 55 to your machine?

epoo 12-30-2003 02:08 PM

of course it is.
the router setting is really very simple. and sshd on the slackbox works fine. im just wondering if theres any entries i have to make in order for it to accept connections from the router as opposed to from inside the network.

trey85stang 12-30-2003 03:02 PM

epoo.. I just recently installed slack.. last week as a matter of fact.. all i fowarded on my router was 22... and i was able to connect to my (home) slackbox from work.

might want to try moving it back to 22 and try it that way?


All times are GMT -5. The time now is 01:48 PM.