LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-14-2007, 01:47 PM   #1
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Rep: Reputation: 15
Router not seeing my linux machin :(


Hello everybody again
My netgear router wont give any IP adress to my Slackware Machin
and i dont know why :'(

Any suggestions what i can do?
 
Old 03-14-2007, 01:57 PM   #2
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
is your card recognized, do you have drivers?
does it work with windows?
have you plugged a cable into your wireless card ?
 
Old 03-14-2007, 02:06 PM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 10,882
Blog Entries: 1

Rep: Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307Reputation: 1307
Quote:
Originally Posted by linuxfreak3
Hello everybody again
My netgear router wont give any IP adress to my Slackware Machin
and i dont know why :'(

Any suggestions what i can do?
Hi,

A little more information. Wired or wireless? Is your network device being recognized? Did you run netconfig? Edit /etc/rc.d/rc.inet1.conf?

As root from cli;
Code:
#dmesg |grep eth                #what eth device(s)
#dmesg |grep wlan               #any wirreless
#ifconfig -a                    #see net device(s information
#route -n                       #route table
The above will provide some information.
 
Old 03-14-2007, 02:39 PM   #4
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Original Poster
Rep: Reputation: 15
I got Wired Network card.
It seems to have drivers :-p
i can activate it inside Slackware so

I run ifconfig and got that my network card got ip adress 127.0.0.1 :S
i put it on DHCP but that doesnt seem to work
i tried to put a fixed ip from the router to it would work but it didnt
 
Old 03-14-2007, 02:48 PM   #5
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
well, is your card called "lo"?

run ifconfig -a, there should be a eth0 entry.
could you give ous the output of
lspci | grep Ethernet
?
 
Old 03-14-2007, 02:51 PM   #6
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Original Poster
Rep: Reputation: 15
my keyboard is mucked up at my server so i cant type | :-p
I checked Ifconfig -a again and yes it was "lo"
the others dont show any adress :S

Last edited by XavierP; 04-01-2007 at 12:50 PM.
 
Old 03-14-2007, 03:35 PM   #7
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
Try using dhcp again. Make sure it's enabled in the router set up. And also that dhcp is enabled when you run netconfig.
 
Old 03-14-2007, 03:50 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,530

Rep: Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674Reputation: 674
FYI lo i.e. IP address 127.0.0.1 is the local loopback adapter. It is a virtual device that in a nutshell allows network applications to run without a physical network.

If you do not see any info for eth0 then you need to verify the correct module is being loaded. As already stated post the output of the console command:
lspci
 
Old 03-14-2007, 03:53 PM   #9
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by simcox1
Try using dhcp again. Make sure it's enabled in the router set up. And also that dhcp is enabled when you run netconfig.
Tryed that
Enabled DHCP again and ran netconfig without any success .
any other suggestions? :-p
 
Old 03-14-2007, 04:53 PM   #10
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 48
You will not get anywhere until you have a driver loaded for your network card (as others have said).

run /sbin/lspci

When we know what your Ethernet controller is, we can proceed!

It will also help if you get your keyboard set up correctly.

When you installed slackware there was a keyboard setup routine where you test that the keys work properly -
so you can put your slack disk1 back in and run setup (keymap) again. (Or, if the keyboard problem is only in X, then you need to correct the /etc/X11/xorg.conf in the Inputdevices section. You need to specify the country and number of buttons on your keyboard) You can also run xorgconfig to do this for you, but you need to know your computer specs before you start this (and make a copy of your original xorg.config file in case it goes wrong).

While you are doing all this, find out what the ip address of your router is. 192.168.0.1 is a common one. It will be in the instruction booklet -or the cd. Then we can help you get networking going.

tobyl

Last edited by tobyl; 03-14-2007 at 05:05 PM.
 
Old 03-15-2007, 02:54 AM   #11
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Original Poster
Rep: Reputation: 15
i got it working with some configs and after a few reboots :-p.
Thanks for the help guys
 
Old 03-15-2007, 07:25 AM   #12
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,004

Rep: Reputation: 474Reputation: 474Reputation: 474Reputation: 474Reputation: 474
Smile

Quote:
Originally Posted by linuxfreak3
i got it working with some configs and after a few reboots :-p.
Thanks for the help guys
Cool. If possible could you let us know what you did so that users having your issue in the future can benefit from your experience?
Glad you're up and running.
 
Old 03-19-2007, 01:31 PM   #13
linuxfreak3
Member
 
Registered: Feb 2004
Location: UK
Distribution: Debian/Backtrack
Posts: 55

Original Poster
Rep: Reputation: 15
i could if i know what i did :-p
haha
it went down again now :-p
so now i need help again hehe
 
Old 03-19-2007, 02:46 PM   #14
sparc86
Member
 
Registered: Jul 2006
Location: Nuremberg, Germany
Distribution: Debian, Gentoo
Posts: 294
Blog Entries: 1

Rep: Reputation: 31
Well, if DHCP doesn't works, maybe you should try to set it manually:

#ifconfig ethX (Where X is the number of your ethernet card) 192.168.0.13 (your IP) netmask 255.255.255.0

#route add default gw 192.168.0.1 (router's IP)


Rodrigo.
 
Old 03-31-2007, 06:38 PM   #15
UhhMaybe
Member
 
Registered: Jul 2004
Location: Salt Lake City, Utah
Distribution: Absolute 12.0 Studio 64 1.3.0
Posts: 470

Rep: Reputation: 30
Cool

We want to help our friends. When we ask for some output...post the output. When we ask for the hardware...post the hardware. When we ask a question...please answer as best YOU can. Thank YOU for YOUR time. I am where I am because YOU cared.
 
  


Reply

Tags
linux, router


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Small Linux Router/firewall behind D-Link Hardware router dleidlein Linux - Networking 6 04-30-2007 05:12 AM
perl script to execute my a c executable on remote machin sharad Linux - General 5 12-14-2006 07:56 AM
linux as router/gateway/firewall to dsl-router sjoerdvvu Linux - Networking 2 02-24-2006 10:56 PM
Linux Router & Netgear Wireless Router DMaCATO Linux - Wireless Networking 1 04-30-2004 09:16 AM
/etc/resolv.conf configuration when behind a router(not a linux router) rmanocha Linux - Networking 2 04-28-2004 01:52 AM


All times are GMT -5. The time now is 11:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration