LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2006, 09:51 PM   #1
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Rep: Reputation: 31
Rosegarden 1.4 on Slackware


Bought a synth a few months ago and on a whim, wanted to try Rosegarden via midi via synth.

When to LinuxPackages and got the package and had some dependencies that I worked thru, but when I went to start Rosegarden, I got this

Code:
cmmiller@ladytron:/opt/kde/bin$ ./rosegarden
./rosegarden: error while loading shared libraries: libraptor.so.1: cannot open shared object file: No such file or directory
A few googles later, looks like it is only in rpm format, not .tgz, and I do know there is a way to conver rmp to tgz...but I also found


http://www.develia.org/tarballs.php?...h&q=Rosegarden


So was wondering...Does anyone use Rosegarden on Slackware from a package and how did they get it installed correctly?

thanks
 
Old 12-20-2006, 10:15 PM   #2
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
i've compiled it and its deps
...seems to work fine.
 
Old 12-20-2006, 11:34 PM   #3
rigelan
Member
 
Registered: Jul 2005
Location: Iowa
Distribution: Slackware
Posts: 172

Rep: Reputation: 19
I think I found it on linuxpackages.com. I remember it had about 8 dependancies that I didn't have available, and had to download those too from linuxpackages. They were all compiled by the same guy.
 
Old 12-21-2006, 02:54 AM   #4
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 766

Rep: Reputation: 92
Downloaded and compiled the source straight from the rosegarden website. No dependency issues at all, and runs sweet as a nut. Only thing is it needs scons to compile, but that is no biggy.
 
Old 12-21-2006, 01:27 PM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,011

Rep: Reputation: 110Reputation: 110
Don't use linuxpackages for Rosegarden because it has those optional dependencies that you very well don't need or want. I've got a minimal dependency RoseGarden package, if you want it.
 
Old 12-21-2006, 08:55 PM   #6
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Original Poster
Rep: Reputation: 31
Tuxdev, may need yr package....

Because, I went to the Rosegarden site and installed scons, and d/l and installed from the bzip2 file that is on their site, but no dice.

There were no errors and Rosegarden doesn't have a directory under /opt/kde/bin

Anyway to troubleshoot what went wrong here?

thanks
 
Old 12-22-2006, 01:27 AM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,749

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
If you can stand the looks of it or don't have or want KDE, I have the older version of rosegarden which uses only xlibs:
http://distro.ibiblio.org/pub/linux/...pl4-i486-1.tgz
On the other hand I know that tuxdev has some experience with rosegarden as he helped me work out support fro scons in my PkgBuild system using the newer rosegarden (1.4 is newer than 2.1 -figure that out...).
Anyway I compiled the newer version with only QT and kdelibs installed, as I recall, but I never uploaded it to my site.
 
Old 12-22-2006, 10:01 AM   #8
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by gnashley
If you can stand the looks of it or don't have or want KDE, I have the older version of rosegarden which uses only xlibs:
http://distro.ibiblio.org/pub/linux/...pl4-i486-1.tgz
On the other hand I know that tuxdev has some experience with rosegarden as he helped me work out support fro scons in my PkgBuild system using the newer rosegarden (1.4 is newer than 2.1 -figure that out...).
Anyway I compiled the newer version with only QT and kdelibs installed, as I recall, but I never uploaded it to my site.
I use KDE as my desktop, so this probably won't work.

TuxDex, I'm going to shoot you a PM...

thanks
 
Old 12-30-2006, 09:51 AM   #9
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,011

Rep: Reputation: 110Reputation: 110
Sorry, turns out it wasn't as handy as a thought. So I tried to rebuild it, with little success. I've been wrangling with a sick system. It seems to crash and do funny stuff when doing CPU intensive tasks.

Last edited by tuxdev; 12-30-2006 at 09:53 AM.
 
Old 12-30-2006, 10:00 AM   #10
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by tuxdev
Sorry, turns out it wasn't as handy as a thought. So I tried to rebuild it, with little success. I've been wrangling with a sick system. It seems to crash and do funny stuff when doing CPU intensive tasks.
Fair enough, I'll just fall back on linuxpackages.net and try to work thru the dependencies, will probably post back more here in the next few days to give a status update.

thanks again
 
Old 12-30-2006, 10:36 AM   #11
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,011

Rep: Reputation: 110Reputation: 110
Another approach would be to let me give you the PkgBuild I created for RoseGarden. You'll have to snatch scons from linuxpackages and PkgBuild from amigolinux.

Or, gnashley could build a package and upload it, but I don't really want to impose.
 
Old 12-30-2006, 08:18 PM   #12
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Original Poster
Rep: Reputation: 31
After installing all of the extra files, Rosegarden is ready to go.

I started the program up from the command line (from Konsole, I have KDE running) and got this output:

Code:
root@ladytron:/opt/kde/bin# ./rosegarden
ERROR: KUniqueApplication: Can't determine DISPLAY. Aborting.
A quick google search returns errors with XGL and people who are in runleve 3...So I'm not sure why I'm getting this...?

I see that Rosegarden has an entry under the K Menu, so I clicked on it to see what would happen, and it started up but I get this warning message:

Code:
System timer resolution is too low
Rosegarden was unable to find a high-resolution timing source for MIDI performance.
This may mean you are using a Linux system with the kernel timer resolution set too low. Please contact your Linux distributor for more information.

Any input?

thanks


BTW: I'm new to the midi world, looks like I'm in for a hell of a learning curve...
 
Old 12-30-2006, 09:15 PM   #13
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,011

Rep: Reputation: 110Reputation: 110
I don't know what the first error is about, but I got the second one and it didn't seem to be much of a problem.
 
Old 12-30-2006, 10:57 PM   #14
zetabill
Member
 
Registered: Oct 2005
Location: Rhode Island, USA
Distribution: Slackware, Xubuntu
Posts: 348

Rep: Reputation: 30
For that second error you'll definitely want to check out the CPU settings in your kernel config and make sure that the timer frequency is not at the lowest level. I usually set my timer frequency to 1000 and I don't have any problems with anything. If you're running a "newer" desktop or laptop then you'll probably be safe switching it up. Also, you might want to look at making sure that the ALSA synthesizer is synchronized with RTC. That should solve your problem. If you make any changes then you'll have to recompile the kernel.

EDIT: By the way... your first error about not finding a suitable display was probably because you were trying to run Rosegarden as root. Root usually doesn't have access to an X server so it vomits when you try. It ran fine the second time because you ran it as user by executing from the K menu.

Last edited by zetabill; 12-30-2006 at 10:59 PM.
 
Old 12-31-2006, 01:46 AM   #15
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,749

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Sorry I hadn't been watching this thread. Here'S the package that I created:
http://distro.ibiblio.org/pub/linux/...4.0-i486-1.tgz

I haven't tested it, but you're welcome to do so :-).
This should need only QT and kdelibs to run, although I had to install kdebase and of course scons to compile it with.
If it doesn't work let me know and I'll work on it more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound with Rosegarden linmix Linux - Software 27 11-25-2006 10:39 AM
jack and rosegarden cabinetcrafter Linux - Software 1 02-04-2006 08:37 PM
Rosegarden Help drethenerd Linux - Software 6 11-21-2005 02:19 PM
Rosegarden 4 sequencer js72 Linux - Software 0 10-05-2005 09:18 AM
Rosegarden-4-0.9.9 Darkfalz Linux - Software 1 11-03-2004 07:08 PM


All times are GMT -5. The time now is 09:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration