LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Root file sys check on JFS during boot fails with e2fsck message (http://www.linuxquestions.org/questions/slackware-14/root-file-sys-check-on-jfs-during-boot-fails-with-e2fsck-message-790528/)

catkin 02-21-2010 04:59 AM

Root file sys check on JFS during boot fails with e2fsck message
 
Hello :)

After creating a new JFS root file system, boot (actually /etc/rc.d/rc.S ?) fails when checking it with:
Code:

fsck 1.41.8
/sbin/e2fsck: Bad magic number in super-block while trying to open /dev/sda7:
The superblock ...

After booting using the old ext4 root file system, using the same command as used by /etc/rc.d/rc.S:
Code:

root@CW8:~# /sbin/fsck -C -a /dev/sda7
fsck 1.41.8 (11-July-2009)
fsck.jfs version 1.1.14, 06-Apr-2009
processing started: 2/21/2010 16.10.13
Using default parameter: -p
The current device is:  /dev/sda7
Block size in bytes:  4096
Filesystem size in blocks:  3662812
**Phase 0 - Replay Journal Log
Filesystem is clean.

The JFS root file system mounts OK during boot with "VFS: mounted root (jfs filesystem) readonly on device 8:7"

This is happening on Slackware 13.0 32-bit with a separate ext3 /boot file system and with /usr on root.

A workaround would be to create /etc/fastboot but that's not ideal.

Best

Charles

rg3 02-21-2010 05:09 AM

I haven't hit this problem myself, but it seems it tries to fsck the JFS filesystem using e2fsck, which is for ext[234] filesystems, so the problem may stem from there. Maybe your /etc/fstab indicates the wrong filesystem, or something similar.

catkin 02-21-2010 05:29 AM

Quote:

Originally Posted by rg3 (Post 3871303)
I haven't hit this problem myself, but it seems it tries to fsck the JFS filesystem using e2fsck, which is for ext[234] filesystems, so the problem may stem from there. Maybe your /etc/fstab indicates the wrong filesystem, or something similar.

Thanks, rg3 :) Hole in one! Changed fstab and testing (am confident that was the problem, though).

EDIT: yup, that was it :)


All times are GMT -5. The time now is 05:50 AM.