LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-19-2002, 01:00 AM   #1
icyfire
Member
 
Registered: Feb 2002
Location: Bay Area, California
Distribution: Ubuntu
Posts: 110

Rep: Reputation: 15
rivafb destroys X server


I recently installed Slack 9.0b (or what is to become it) and love it. I use the 1024x768 framebuffer in my text console (using rivafb), but I went to install rivaTV, drivers for a TV tuner on my Asus V7100 Deluxe Combo. In order for that install to stop whining, I had to disable the framebuffer, and now when i want it back, it does nothing. When i switch to a text console, it messes up, is in some insanely big resolution (either 640 or even 320) and creates two purple dots instead of a cursor. When i switch back to X, the server corrupts and I have to reboot (the three-fingered salute doesn't work).

I read about this in a forum, but it didn't help at all. The person who responded said to stop using NVdriver, and instead use the nv driver that comes with X. However, if it worked before I installed rivaTV, how can i make it work again?

Thanks,

icy

edit: i sort of fixed it; stupid ol' me forgot to run /sbin/lilo after he edited lilo.conf. However, I still can't turn the framebuffer OFF properly....

Last edited by icyfire; 11-19-2002 at 03:12 AM.
 
Old 11-19-2002, 03:28 AM   #2
LNXman
Member
 
Registered: Jul 2002
Location: California (USA)
Distribution: Slackware
Posts: 97

Rep: Reputation: 15
I had a similar problem when the 2.4.X kernels first came out when I wanted to have both OpenGL support on both VT's and XFree86. After a bit of thinking, and a bit of tinkering, I realized what the cause was for crashes, lock ups and the such. . . BUT, since I was in denial I searched Google nontheless to prove my theory wrong. . . Unfortunately my theory held. . . 8^(

And this is a quote I found in Google which proved it:


Q: My system hangs when vt-switching if I have rivafb enabled.

A: Using both rivafb and the NVdriver kernel module at the same
time is currently broken. In general, using two independent
software drivers to drive the same piece of hardware is a bad
idea.


In short, you can only use one of the drivers. Since you are trying to use XFree86, then I would suggest recompiling the kernel back to using regular vesa for your vt's and use the NVdriver for your XFree86 sessions. . .

If you have a native NVidia chipset you want to use the NVdriver for you card to take full advantage of its processing power and features. The nv driver that comes with XFree86 uses a software render for OpenGL based on MESA, which means you will have OpenGL support for your card, but performance will be un-acceptable because the rendering is not performed directly by your card's native OpenGL hardware renderer.

If performance is what you want, use native!!!

GL
 
Old 11-19-2002, 03:42 AM   #3
icyfire
Member
 
Registered: Feb 2002
Location: Bay Area, California
Distribution: Ubuntu
Posts: 110

Original Poster
Rep: Reputation: 15
well, i got the framebuffer in the first place with liloconfig, and it asked me if i wanted a framebuffer. the framebuffer worked before AND after i installed the NVdriver. However, when i disabled the framebuffer and booted to a shell, the shell was messed up big time. i would like to know how to properly disable the framebuffer (unloading the rivafb module at boottime) as vga=normal in lilo.conf does nothing. it works great now, but when i want to use rivaTV (the TV module I explained earlier), I need to disable the framebuffer.

interestingly enough, ive gotten so confused that i really dont know what im asking anymore.....

icy
 
Old 11-19-2002, 04:26 AM   #4
LNXman
Member
 
Registered: Jul 2002
Location: California (USA)
Distribution: Slackware
Posts: 97

Rep: Reputation: 15
If rivafb is a module (&& assuming you have the vesa frame buffer present as a backup fb), then you can tell lilo to load the default vesa instead of rivafb with the following line in lilo:
append="video=vesa:mtrr: pmipal: pro: ywrap" <- Get rid off the spaces . . . spaces added, otherwise you get !!!! >8^(


(Make sure you rerun lilo)

A side note(s): If rivafb is compiled in the kernel, then you can disable it with the line video=rivafb: off <- Get rid off the space. . . similar reason as above

Hope this helps,

GL

edit: /tried to get rid off graphical faces

Last edited by LNXman; 11-19-2002 at 04:41 AM.
 
Old 11-19-2002, 08:35 AM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
OT.
LNXman,
If you click the Post Reply button you will find a "Disable Smilies in This Post" option below the text box.
append="video=vesa:mtrr:pmipal:pro:ywrap"
 
Old 11-19-2002, 12:57 PM   #6
LNXman
Member
 
Registered: Jul 2002
Location: California (USA)
Distribution: Slackware
Posts: 97

Rep: Reputation: 15
Code:
 ____   ___  _   _ _
|  _ \ / _ \| | | | |
| | | | | | | |_| | |
| |_| | |_| |  _  |_|
|____/ \___/|_| |_(_)   I was tired . . . :p !
Thanks for the tip.
 
Old 11-19-2002, 06:29 PM   #7
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Heh,heh.
Your welcome :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis destroys network for Windows johnnyjumpup MEPIS 5 10-09-2005 02:29 AM
Mozilla destroys the load? piratebiter Linux - Software 1 05-26-2005 01:44 PM
Still Destroys Windows Partition? JSmith Fedora 6 01-08-2005 02:51 PM
Rivafb question thrix Linux - General 0 01-26-2004 05:10 PM
new kernel destroys pcmcia networking? insomniac Linux - Networking 3 10-10-2003 09:58 AM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration