LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-04-2004, 07:34 PM   #1
abs
Member
 
Registered: Oct 2003
Posts: 203

Rep: Reputation: 30
restore mbr (in lilo and grub)


hi
was wondering...
what's the grub equivalent of: lilo -U -s /boot/boot.NNNN ?

and is there any way to force grub or lilo to copy the backed up mbr file data back to the mbr ie. restore the original mbr (even if lilo or grub aren't installed) ? (so when the mbr get's messed up...)

i tried it with lilo (above cmd) and it said the mbr didn't have a lilo signature (failure).

ty
abs

Last edited by abs; 02-04-2004 at 07:35 PM.
 
Old 02-06-2004, 10:29 AM   #2
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
I'm a hardcore lilo user, but you should be able to find something
here.
 
Old 02-06-2004, 02:38 PM   #3
sovietpower
Member
 
Registered: Jun 2003
Distribution: Slackware64 14.1 and -current
Posts: 207

Rep: Reputation: 30
Yeah I am also a hardcore LILO user its way easier I think to use LILO then GRUB
 
Old 02-06-2004, 06:43 PM   #4
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
k
perhaps one of u could help me figure out the problem here.
ty
 
Old 02-06-2004, 08:20 PM   #5
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
Quote:
Originally posted by abs
k
perhaps one of u could help me figure out the problem here.
ty
looks like something munged your mbr...

your lilo.conf in the other thread looks like it will fly, so just try:

Code:
/sbin/lilo
also, if your computer sees all of your drive - correct size - then your BIOS settings are OK - don't fix, it ain't broke
 
Old 02-07-2004, 02:39 PM   #6
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
well, i already installed lilo during the installation...and it didn't work out. i just happened to read the thing about where the backup of the mbr was stored so saved my as$ that time. all my drives are read at the correct capacity. by bios and by cfdisk/fdisk when i used them before install. maybe i'll post the part info on my drives here. what's the command for fdisk to print the partition table? or should i do 'p' when in fdisk and then copy/paste it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub and lilo on MBR with Windows xp blotch Linux - General 6 11-18-2005 09:57 PM
grub/lilo conflicts in mbr bandofmercy Linux - Newbie 5 09-25-2004 11:54 PM
lilo / grub in MBR? neilcpp Slackware 4 03-28-2004 10:26 AM
How do I restore LILO in the MBR? josedsilva Linux - Software 2 03-20-2003 12:51 PM
Does lilo/grub have to be in the MBR? wincen Linux - General 9 06-20-2002 07:32 AM


All times are GMT -5. The time now is 12:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration