LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Required packages for aRts (http://www.linuxquestions.org/questions/slackware-14/required-packages-for-arts-419592/)

slackernewb 02-25-2006 08:26 PM

Required packages for aRts
 
I'm trying to do a minimal Slackware install with KDE. Everything is working except for aRts. Whenever I start KDE it tells me "The application sound server (artsd) crashed and caused the signal 11 (SIGSEGV)." I believe I am missing a needed package, because when I do a full install everything works fine. Can anyone tell me the required packages for aRts? Thanks in advance.

mebrelith 02-25-2006 09:16 PM

Im puzzled... doesn't Slack have a package manager?

piete 02-25-2006 09:35 PM

pkgtool (Slack's package manager) doesn't track dependencies.

I fished out the compilation dependencies from here (obscure place, I know!): http://www.rocklinux.net/packages/arts.html

As for run-time dependencies? Honestly, I can't say for absolute certainty. Perhaps some stuff in kde-multimedia, maybe some alsa stuff ... sounds unlikely, even to my ears.

I would advise a) install everything, strip back a handful of packages at a time or b) install nothing, then add a few at a time. Certainly start with installpkg slackware/kde/*.tgz and see where that gets you.

I'm sorry for not being much more useful ...

- Piete.

slackernewb 02-26-2006 07:28 AM

Okay, I'll do that. Thanks.

__spc__ 03-05-2006 02:11 AM

Did you solce this? artsd crashes whenever users on my machine log in - works fine under root.

(Slack 10.1, KDE 3.5.1, kernels 2.6.15.4 and .5)


All times are GMT -5. The time now is 07:59 PM.