LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-15-2017, 02:18 PM   #2101
atelszewski
Member
 
Registered: Aug 2007
Distribution: Slackware
Posts: 721

Rep: Reputation: Disabled

Hi,

xorg-server 1.19.3 released.

--
Best regards,
Andrzej Telszewski
 
2 members found this post helpful.
Old 03-16-2017, 03:25 PM   #2102
atelszewski
Member
 
Registered: Aug 2007
Distribution: Slackware
Posts: 721

Rep: Reputation: Disabled
Hi,

Guile 2.2.0 released.

--
Best regards,
Andrzej Telszewski
 
Old 03-16-2017, 03:30 PM   #2103
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,442

Rep: Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402Reputation: 2402
Window Maker 0.95.8 was released on March 11th 2017.

I prefer FVWM, but still others could like Window Maker, so...
 
1 members found this post helpful.
Old 03-17-2017, 08:20 PM   #2104
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib." FreeBSD.
Posts: 3,410
Blog Entries: 1

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Firefox-52.0.1 has been released to fix a "critical vulnerability,"

Quote:
2017-08 integer overflow in createImageBitmap()
https://www.mozilla.org/en-US/securi...#firefox52.0.1

Last edited by cwizardone; 03-18-2017 at 03:57 AM. Reason: Typo.
 
Old 03-18-2017, 01:22 AM   #2105
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,596

Rep: Reputation: 931Reputation: 931Reputation: 931Reputation: 931Reputation: 931Reputation: 931Reputation: 931Reputation: 931
it has been fixed in current
 
1 members found this post helpful.
Old 03-18-2017, 03:59 AM   #2106
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib." FreeBSD.
Posts: 3,410
Blog Entries: 1

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Quote:
Originally Posted by willysr View Post
it has been fixed in current
That was quick!

Quote:
Sat Mar 18 00:30:40 UTC 2017
xap/mozilla-firefox-52.0.1-x86_64-1.txz: Upgraded.
This release contains security fixes and improvements.
For more information, see:
https://www.mozilla.org/security/kno...s/firefox.html
(* Security fix *)
Johnson,
Thanks for all the recent updates!
 
1 members found this post helpful.
Old 03-18-2017, 03:33 PM   #2107
Darth Vader
Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 991

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
How about enabling the XMLRPC extension into PHP?

It needs just adding --with-xmlrpc flag to configure, the overhead is insignificant and that XMLRPC extension is needed, for example by Moodle, a widely used e-Learning Portal.

PS. I checked for, and this extension is enabled also by your idols, the Arch Linux, so another motivation for!

Last edited by Darth Vader; 03-18-2017 at 05:39 PM.
 
1 members found this post helpful.
Old 03-19-2017, 04:51 AM   #2108
franzen
Member
 
Registered: Nov 2012
Distribution: slackware
Posts: 163

Rep: Reputation: 69
Hi,
request to recompile audacious-plugins against ffmpeg.

Code:
--- audacious-plugins.SlackBuild.orig   2017-03-19 10:48:12.013994499 +0100
+++ audacious-plugins.SlackBuild        2017-03-19 10:48:31.093002869 +0100
@@ -83,7 +83,6 @@
   --sysconfdir=/etc \
   --mandir=/usr/man \
   --disable-aac \
-  --with-ffmpeg=none \
   --program-prefix= \
   --program-suffix= \
   ${ARCHOPTS} \
 
1 members found this post helpful.
Old 03-19-2017, 02:23 PM   #2109
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 518

Rep: Reputation: Disabled
Thanks for this !!!!!!


Quote:
Sun Mar 19 05:27:13 UTC 2017
l/SDL2-2.0.5-i586-1.txz: Added.
l/SDL2_gfx-1.0.3-i586-1.txz: Added.
l/SDL2_image-2.0.1-i586-1.txz: Added.
l/SDL2_mixer-2.0.1-i586-1.txz: Added.
l/SDL2_net-2.0.1-i586-1.txz: Added.
l/SDL2_ttf-2.0.14-i586-1.txz: Added.
l/ffmpeg-3.2.4-i586-2.txz: Rebuilt.
The package now includes ffplay, which required the SDL2 libraries.
 
1 members found this post helpful.
Old 03-19-2017, 02:31 PM   #2110
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,362

Rep: Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747Reputation: 2747
I would have liked to see SDL2_mixer built against FluidSynth and modplug.

For your own systems, I highly recommend at least rebuilding it against FluidSynth and then setting SDL_SOUNDFONTS to be the path to an .sf2 file.

I know that DOOM Retro and PrBoom both take advantage of that.

Also worth pointing out: SDL 1 is already being built against mikmod.

Last edited by dugan; 03-19-2017 at 05:21 PM. Reason: SDL2_mixer. Not SDL2.
 
1 members found this post helpful.
Old 03-20-2017, 05:14 AM   #2111
MarcT
Member
 
Registered: Jan 2009
Location: UK
Distribution: Slackware 14.2
Posts: 96

Rep: Reputation: 41
Request for a Kernel parameter change to enable EDAC (Error Detection & Correction) modules for ECC memory:

Quote:
-# CONFIG_EDAC_MM_EDAC is not set
+CONFIG_EDAC_MM_EDAC=m
...and all of the EDAC modules (list from kernel 4.10.1):

Quote:
+CONFIG_EDAC_AMD64=m
+# CONFIG_EDAC_AMD64_ERROR_INJECTION is not set
+CONFIG_EDAC_E752X=m
+CONFIG_EDAC_I82975X=m
+CONFIG_EDAC_I3000=m
+CONFIG_EDAC_I3200=m
+CONFIG_EDAC_IE31200=m
+CONFIG_EDAC_X38=m
+CONFIG_EDAC_I5400=m
+CONFIG_EDAC_I7CORE=m
+CONFIG_EDAC_I5000=m
+CONFIG_EDAC_I5100=m
+CONFIG_EDAC_I7300=m
+CONFIG_EDAC_SBRIDGE=m
+CONFIG_EDAC_SKX=m
Plus include the latest edac-utils from here:
https://github.com/grondo/edac-utils.git

...which I believe will require this Kernel change:

Quote:
-CONFIG_EDAC_LEGACY_SYSFS=y
+# CONFIG_EDAC_LEGACY_SYSFS is not set
Thanks & Kind Regards,
Marc

Last edited by MarcT; 03-20-2017 at 05:15 AM. Reason: minor correction
 
1 members found this post helpful.
Old 03-20-2017, 10:21 AM   #2112
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib." FreeBSD.
Posts: 3,410
Blog Entries: 1

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Mesa-17.0.2.
The announcement, https://lists.freedesktop.org/archiv...ch/148702.html

OpenSSH-7.5p1
The change log, http://ftp.openbsd.org/pub/OpenBSD/O...able/ChangeLog
 
1 members found this post helpful.
Old 03-20-2017, 11:14 AM   #2113
Raveriux
Member
 
Registered: Jul 2013
Location: Lithuania
Distribution: Slackware64 14, Slackware64 -current, Maemo
Posts: 107

Rep: Reputation: Disabled
Quote:
Originally Posted by dugan View Post
I would have liked to see SDL2_mixer built against FluidSynth and modplug.

For your own systems, I highly recommend at least rebuilding it against FluidSynth and then setting SDL_SOUNDFONTS to be the path to an .sf2 file.

I know that DOOM Retro and PrBoom both take advantage of that.

Also worth pointing out: SDL 1 is already being built against mikmod.
also audacious-plugins would benefit from modplug and rebuilding against it for the playing of music module files like .xm, .s3m, .mod and etc.
 
1 members found this post helpful.
Old 03-20-2017, 12:28 PM   #2114
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.2 64-bit with multilib
Posts: 2,350

Rep: Reputation: 634Reputation: 634Reputation: 634Reputation: 634Reputation: 634Reputation: 634
Fix the OpenGL crash with NVIDIA in audacious

Quote:
Originally Posted by Raveriux View Post
also audacious-plugins would benefit from modplug and rebuilding against it for the playing of music module files like .xm, .s3m, .mod and etc.
Speaking of audacious - it should be built with -qt to fix that crashing issue when trying to use the OpenGL visualisation plugin with NVIDIA cards.

Last edited by Jeebizz; 03-20-2017 at 12:36 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to show the current time at the top in the current shell Always ? rohitchauhan Linux - General 5 04-09-2014 03:05 PM
Slackware ARM (current) epic mistake: the current Android kernels are kicked out! Darth Vader Slackware 16 08-25-2013 04:36 PM
[SOLVED] setup fails on most current Slackware-current March 26, 2012 AlleyTrotter Slackware 15 04-09-2012 06:05 AM
Observation of Feb -current vs March -current Hangaber Slackware 14 03-12-2010 08:26 AM
cvs diff the most current and second last current version powah Linux - Software 1 03-30-2006 01:02 PM


All times are GMT -5. The time now is 01:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration