LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Requested 'gio-2.0 >= 2.25.9' but version of GIO is 2.22.5 (http://www.linuxquestions.org/questions/slackware-14/requested-gio-2-0-%3D-2-25-9-but-version-of-gio-is-2-22-5-a-914521/)

seflyer 11-20-2011 09:20 AM

Requested 'gio-2.0 >= 2.25.9' but version of GIO is 2.22.5
 
I am trying to install google chrome under Slackware 13.1(32bit); to do that somehow I need to install GConf first, during which the following error occurs. Any advice would be appreciated...

Code:

configure: error: Package requirements (glib-2.0 > 2.14.0 gio-2.0 >= 2.25.9 gthread-2.0 gmodule-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0 ORBit-2.0 >= 2.4.0) were not met:

Requested 'gio-2.0 >= 2.25.9' but version of GIO is 2.22.5

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPENDENT_CFLAGS
and DEPENDENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

So, if a upgrade is needed, which package should I install? I did not find any package named Gio. Or if, as suggested in the error message, some change in the environment variable should be made, what is that?

janhe 11-20-2011 11:11 AM

Code:

janhe@computer:~$ pkg-config --list-all | grep gio
gio-2.0                    GIO - glib I/O library
gio-unix-2.0                GIO unix specific APIs - unix specific headers for glib I/O library

This was executed on Slackware 13.37

It looks like the version of glib2 in slackware 13.1 is too old for your chrome release. (Or the other way around, you try to install a version of chrome that is too recent.)

AFAIK, you cannot simply upgrade glib, you will need to upgrade your Slackware. 13.37 has glib2-2.28.6

seflyer 11-20-2011 08:25 PM

Thanks janhe, if it is so I guess I would first give the latest Firefox a try...

UPDATE:
Turns out that an older GConf(2.28, instead of the latest version 2.32) would fix the problem.
Latest GConf requires the latest glib.

seflyer 11-28-2011 10:51 PM

I found this only after I upgraded slackware to 13.37 at home. But at least I can get along well with 13.1 at the lab now.


All times are GMT -5. The time now is 11:39 AM.