LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-19-2010, 05:21 AM   #1
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Rep: Reputation: 4
rendering and glxgears after november updates


Hello again!
I have hp laptop 6910p and giving issue with glxgears.
Code:
init@ntagil-it:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.830 FPS
300 frames in 5.0 seconds = 59.841 FPS
300 frames in 5.0 seconds = 59.843 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 1923 requests (1923 known processed) with 0 events remaining.
Code:
init@ntagil-it:~$ uname -a
Linux ntagil-it 2.6.35.8 #5 SMP Fri Nov 19 10:40:25 YEKT 2010 i686 Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz GenuineIntel GNU/Linux
Code:
init@ntagil-it:~$ glxinfo |grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20100330 DEVELOPMENT x86/MMX/SSE2
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 30be
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 43
	Region 0: Memory at e4400000 (64-bit, non-prefetchable) [size=1M]
	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 4000 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
		Address: fee0300c  Data: 4179
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
		Bridge: PM- B3+
	Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
	Subsystem: Hewlett-Packard Company Device 30be
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at e4500000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
		Bridge: PM- B3+
Im put Xorg.0.log for more detail
Attached Files
File Type: log Xorg.0.log (24.0 KB, 6 views)
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 11-19-2010, 05:30 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
So what's the issue you are having? Nothing you've posted indicates any problem.

Adam
 
Old 11-19-2010, 05:33 AM   #3
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by adamk75 View Post
So what's the issue you are having? Nothing you've posted indicates any problem.

Adam
thinking, that its low FPS, usual this indicates about 700 FPS
 
Old 11-19-2010, 05:33 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
It explains why it's roughly 60 fps.

Adam
 
Old 11-19-2010, 05:39 AM   #5
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by adamk75 View Post
It explains why it's roughly 60 fps.

Adam
Hmmm, how I understand, this is normal situation?
In this way how to find real FPS?
 
Old 11-19-2010, 05:46 AM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Quote:
Originally Posted by anti_user View Post
Hmmm, how I understand, this is normal situation?
Really depends on the driver and the application.

Quote:
In this way how to find real FPS?
I do not know if it's possible to get glxgears or the intel driver to not vsync by default. However, you really shouldn't be using glxgears to get any determination of performance. I would recommend one of the applications mentioned here: http://dri.freedesktop.org/wiki/Benchmarking

Adam

Last edited by adamk75; 11-19-2010 at 05:53 AM.
 
2 members found this post helpful.
Old 11-19-2010, 05:55 AM   #7
anti_user
Member
 
Registered: May 2008
Location: Russia, Ural
Distribution: Slackware Current
Posts: 69

Original Poster
Rep: Reputation: 4
Wink

Quote:
Originally Posted by adamk75 View Post
Really depends on the driver and the application.



I do not know if it's possible to get glxgears or the intel driver to not vsync by default. However, you really shouldn't be using glxgears to get any determination of performance. I would recommend one of the applications mentioned here: http://dri.freedesktop.org/wiki/Benchmarking

Adam
Thanks, Adam
 
  


Reply

Tags
glx, glxgears, glxinfo, intel, vga


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Intel WiFi 4965 doesn't work after November updates anti_user Slackware 1 11-20-2010 10:30 AM
No xfprot updates since November! otropogo Puppy 4 12-24-2008 07:02 PM
LXer: Android phone could come in November LXer Syndicated Linux News 0 08-19-2008 06:00 AM
VanLUG - November 15 - Gumstix! mcleodnine Linux User Groups (LUG) 0 11-11-2004 05:23 PM
Microsoft plans Linux OS by November! CragStar General 15 03-15-2002 01:54 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration