LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-04-2005, 04:14 PM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
removed SCSI from kernel. ide-scsi gone.


Err, i've just said no to all SCSI support on my laptop (2.4.28), thinking that i don't need it since it doesn't have any scsi devices on it..

However, now when i reboot, i get an error 'can't load module ide-scsi'. not found..

and when i try mounting /mnt/cdrom, or /dev/sr1 (dvd writer through usb2), it says
mount: /dev/cdrom is not a valid block device

Anyone knows specifically what i need to reenable in SCSI support in the kernel? (as Y or M?)

Thanks.
 
Old 01-04-2005, 05:27 PM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i think you should enable scsi-emulation in your kernel-config
( ata/atapi..etc support--->scsi emulation )

egag
 
Old 01-04-2005, 05:45 PM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Sneeky... When i disabled SCSI, it also disabled and greyed that!. I'll enable SCSI (but nothing in there), set SCSI emulation to (Y), recompile, and see if it works.

Cheers.
 
Old 01-04-2005, 06:39 PM   #4
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Still doesn't work. I've enabled the following:
SCSI Support (Y)
SCSI generic support (Y)
SCSI emulation support (Y)

but i still get modprobe failed: can't locate module ide-scsi at bootup =/

================
EDIT:
================
I think i also need to enable SCSI CD-ROM support. Will try that now.

Last edited by xushi; 01-04-2005 at 06:53 PM.
 
Old 01-04-2005, 07:12 PM   #5
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
with such errors, i always use the rule : " if unsure say modular "
you can check later if things work what you really need ( lsmod....)

egag
 
Old 01-04-2005, 07:51 PM   #6
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Success!
For anyone else who gets the same problem, just enable the following

ATA/IDE/MFM/RLL support
Block Devices:

SCSI Emulation support (M)

SCSI Support:
SCSI support (y)
SCSI CD-ROM support (y)
Enable vendor-specific extensions (for SCSI CDROM) (n)
SCSI Generec support (y)

And recompile.
 
Old 01-04-2005, 08:00 PM   #7
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
oke..
nice all works...

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB or LILO boot to SCSI drive on SCSI system w/ IDE card mkl838 Linux - General 1 03-06-2005 10:01 PM
Recompiling kernel without ide-scsi emulation techrolla Linux - Software 1 06-21-2004 01:52 PM
CD Writing without ide-scsi emulation in 2.6 kernel xgreen Linux - Software 6 02-19-2004 10:49 AM
Recompiling kernel for IDE-SCSI support jspaceman Slackware 4 10-03-2003 07:58 AM
How to Enable ide-scsi emulation in the kernel? shassouneh Linux - Software 29 05-31-2002 02:28 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration