LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-03-2007, 03:22 AM   #1
dmrr
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware 12
Posts: 12

Rep: Reputation: 0
ReiserFS horribly slow when using custom kernel


Hello,
I recently installed kernel 2.6.19 in my slack 11.0 (to get a wireless mouse/kbd combo working right) and everything works fine except the file system (reiserfs) that is VERY slow. To confirm this, I booted up with 2.4.33 (which came with slack) and copied a ~350 mb file. It took 16 seconds. Then I tried with 2.6.19 and it took more than 3 minutes and while it copied the system was slow as hell. Its also noticeable in every program I use like playing music, firefox, etc. Everything that uses the hd a little its slow.
The kernel config options for the reiserfs I used are

Code:
CONFIG_REISERFS_FS=y
# CONFIG_REISERFS_CHECK is not set
# CONFIG_REISERFS_PROC_INFO is not set
# CONFIG_REISERFS_FS_XATTR is not set
I think there is nothing wrong there.
Is there any other option that will mess so much with the fs/hdd?

Thanks.
 
Old 05-03-2007, 03:57 AM   #2
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 31
Is your hard disk set up for DMA? Try running:

Code:
hdparm -d /dev/hda
If that says your hard drive is not using DMA then run:

Code:
hdparm -d1 /dev/hda
 
Old 05-03-2007, 04:22 AM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello,

are you sure that this problem has something to do with reiserfs? I had a similar Problem after recompiling a 2.6 kernel and found out, that the problem was highmem.
I have 1.5GB of RAM and configured my kernel with highmem (for RAM between 1GB and 4GB) and the system became horribly slow. Then I appended in my lilo.conf "append mem=1536M" and everything is running well. With the default kernel 2.4.33 I had no Problems.

Another idea: your swapspace is setup correctly?

Markus

Last edited by markush; 05-03-2007 at 05:28 AM.
 
Old 05-03-2007, 04:34 AM   #4
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
I'd also suggest comparing the output of
Code:
mount
between 2.4 and 2.6, although I'm not aware of any defaults changing it could be something silly like the FS being mounted as sync instead of async.

HTH

Jamie
 
Old 05-03-2007, 10:29 AM   #5
dmrr
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware 12
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Linux~Powered
Is your hard disk set up for DMA? Try running:

Code:
hdparm -d /dev/hda
If that says your hard drive is not using DMA then run:

Code:
hdparm -d1 /dev/hda
You were right, it was off.
Aparently the auto setting for dma was turned off when I used make oldconfig and instead turned on IDEDMA_ONLYDISK which its for:
"This is used if you know your ATAPI Devices are going to fail DMA Transfers"
I dont think that should happen, maybe its an error in the make scripts.

Thanks to everyone who aswered.
 
Old 05-03-2007, 11:24 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Check 'man hdparm' for even more optimization stuff to help speed it up. Do note that some stuff gives you warnings about 'massive filesystem corruption' ... might wanna stay away from those

See #1 f) on here:
http://www.linuxquestions.org/questi...09#post2672909
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu HORRIBLY SLOW...even after removing beagle! coolblue Ubuntu 2 05-02-2007 07:21 PM
Custom kernel image on custom slack build using CUSS nykey Slackware 2 07-15-2006 03:05 AM
Kernel compilation gone horribly wrong sleepisforwimps Slackware 1 06-04-2005 04:08 PM
Horribly slow transfer speeds with SAMBA jordanyeo Linux - Networking 6 11-18-2003 07:13 AM
Are ext3 and ReiserFS slow? General_Tso Linux - General 8 04-20-2003 09:26 PM


All times are GMT -5. The time now is 08:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration