LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2004, 05:30 PM   #1
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Rep: Reputation: 16
Question ReiserFS and LILO read-write


My file system is reiserfs and lilo.conf looked like this:
Code:
image = /boot/vmlinuz-2.6.7
  root = /dev/hdb1
  label = slack-2.6.7
  read-only
image = /boot/vmlinuz-ide-2.4.26
  root = /dev/hdb1
  label = linux
  read-only
I somewhere read that reiserfs should be mounted read-write and not read-only, so I edited my lilo.conf with read-write instead of read-only. But when I booted again I got a messag:
Code:
*** ERROR: Root partition has already been mounted read-write. Cannot check!
For filesystem checking to work properly, your system must initially mount
the root partition as read only. Please modify your kernel with 'rdev' so that
it does this. If you're booting with LILO, add a line:
read-only
to the Linux section in your /etc/lilo.conf and type 'lilo' to reinstall it.
If you boot from a kernel on a floppy disk, put it in the drive and type:
rdev -R /dev/fd0 1
If you boot from a bootdisk, or with Loadlin, you can add the 'ro' flag.
This will fix the problem *AND* eliminate this annoying message. :^)

Press ENTER to continue.
I know this is a fsck error but how can I fix this, and does reiserfs need to mount in read-write at all.

Last edited by kule; 07-11-2004 at 05:32 PM.
 
Old 07-11-2004, 05:43 PM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,290

Rep: Reputation: 69
Quote:
I somewhere read that reiserfs should be mounted read-write and not read-only
where ? And maybe it was not good setting for / partition.

fsck won't perform check on a read-write mounted partition (do man reiserfsck, and look at the -check option), I would redo the change to Lilo (read-only)
 
Old 07-11-2004, 07:17 PM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
no, its XFS that you are allowed to mount read-write, not reiserfs.
 
Old 07-12-2004, 06:58 AM   #4
kule
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 87

Original Poster
Rep: Reputation: 16
Thanks guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 12:17 PM
Example share in smb.conf doesn't work - read/write vs read only kleptophobiac Linux - Networking 0 09-01-2004 07:14 PM
Trouble bootine SuSE 8.2 with ReiserFS in Read/Write mode alan8373 Linux - General 2 03-07-2004 12:09 AM
Open office read only, K-write read/write mode lwtvh Linux - Newbie 1 07-19-2003 11:33 AM
Change from Read only to Read Write File System? justiceisblind Linux - Newbie 3 03-03-2002 07:23 PM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration