LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   recompiling kernal slackware 7.1 (http://www.linuxquestions.org/questions/slackware-14/recompiling-kernal-slackware-7-1-a-90247/)

gamji44 09-07-2003 03:58 PM

recompiling kernal slackware 7.1
 
i have an issue back here that has bedeviled me since friday i am trying to recompile my kernal but after doing the make,dep,make bzImage,make install, make modules, did all that now my issue is i try running the /sbin/lilo now i am getting

value expected for 'image' near line 9 in file /etc/lilo.conf

please help me with a detailed step's on how i can get this working thanks......also how i can get my sound going.......


thanks in advance :newbie:

trickykid 09-07-2003 04:11 PM

Can you post details on your lilo.conf or post it here, describing your setup, etc. Also have you or are you following the directions provided in the very top or first thread in this forum regarding compiling kernel's in Slackware? Good detailed information.

If you run make install when using Slackware and compiling the kernel, you don't need to run /sbin/lilo as its already made the necessary changes. Hopefully you've edited your old kernel image information so its not lost, etc so if your new kernel doesn't boot, then you can still boot into your old kernel to fix....

About sound, well, how can we help you if you don't give us any details about your setup, hardware used, etc... ?

gamji44 09-07-2003 05:28 PM

ok her is what my lilo.config look like, i did follow the direction oh by the way i have a cyrstal sound card which i included in the kernal.......hope this suffice...........


# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /boot/boot_message.txt
prompt
timeout = 1200
image /vmlinuz.old
root/dev/hda2
label=slackware.old
read-only
# VESA framebuffer console @ 1024*768*64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024*768*64k
#=791
# VESA framebuffer console @ 1024*768*32k
#=790
# VESA framebuffer console @ 1024*768*256
#=773
# VESA framebuffer console @ 800*600*64k
#=788
# VESA framebuffer console @ 800*600*32k
#=787
# VESA framebuffer console @ 800*600*256
#=771
# VESA framebuffer console @ 640*480*64k
vga=785
# VESA framebuffer console @ 640*480*32k
vga=784
# VESA framebuffer console @ 640*480*256
#769
# End LILO global section
#Linux bootable partition config begins
image = /vmlinuz
root = /dev/hda2
label = linux
read-only
# Linux bootable partition config ends

trickykid 09-07-2003 06:53 PM

Well just like the error states on Line 9 in your config file, make sure you have a space and = sign between root and /dev/hda2 for your old kernel config:

image /vmlinuz.old
root = /dev/hda2
label = slackware.old
read-only

gamji44 09-07-2003 09:00 PM

thanks a bunch it seems like it went through , but now i cant seem to get into my x windows i get

fetal server error
open_framebuffer: failed to open /dev/fb0 ( nno such device)

thnaks in advance

trickykid 09-08-2003 12:41 AM

Did you leave out framebuffer support when compiling the new kernel?


All times are GMT -5. The time now is 12:14 AM.