LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2004, 05:53 PM   #1
erif
LQ Newbie
 
Registered: May 2004
Location: Stockholm
Distribution: Slackware 9.1
Posts: 3

Rep: Reputation: 0
reboot does not kill sshd


Hi,

I use Slackware 9.1, Linux 2.4.26.

Reboot doesn't kill sshd which makes my ssh client to get stuck till reboot is done.

My solution was to put this in /etc/rc.d/rc.6 :
if [ -x /etc/rc.d/rc.sshd ]; then
/etc/rc.d/rc.sshd stop
fi
(before "# Stop the Apache web server:")

Comments/How could this be done differently?
 
Old 05-11-2004, 05:56 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
in a term window type..........

ps aux

find pid number of sshd(process ID number)
and type.......
kill <pid>
 
Old 05-11-2004, 06:00 PM   #3
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
You have to find in /etc/rc.d the script who lauch sshd, then comment the lines...
 
Old 05-11-2004, 07:41 PM   #4
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 30
chmod 644 /etc/rc.d/rc.sshd

That will still allow you to use the ssh client to connect to other computers but shuts down the ssh daemon on your own machine, so other people can't connect to you.
 
Old 05-11-2004, 09:41 PM   #5
subgenius
Member
 
Registered: Mar 2004
Distribution: Slackware 9.1
Posts: 41

Rep: Reputation: 15
One thing I am sure of -- sshd can not still be running while the
computer is rebooting!

It is obviously restarting when the OS (Slackware) reboots.

The previous post's suggestion should take care of it.
 
Old 05-12-2004, 06:50 AM   #6
erif
LQ Newbie
 
Registered: May 2004
Location: Stockholm
Distribution: Slackware 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
320mb: This is what '/etc/rc.d/rc.sshd stop' does.
Linux.tar.gz: If I wanted to do that, Kovacs suggestion is better.

I don't want to turn off the ssh daemon.
This is a machine on which I run Slackware GNU/Linux, FreeBSD and DragonFly multibooting with GRUB. I mostly work remote on that machine (except when I screw things up :) and I use a ssh client to connect to it.

The problem _is_ (or was until my "fix") that my ssh client (either I connected from a windos box using putty or from an other Linux/BSD machine using its own ssh client) got stuck till reboot was done, when rebooting from linux.
The problem _is not_ that sshd is running at all.
I don't know if this is a slackware-only problem or if all linux distros are affected by it, maybe some of them has solved this the way I did.

I have not got this problem when rebooting from FreeBSD or DragonFly.

Last edited by erif; 05-12-2004 at 06:55 AM.
 
Old 05-12-2004, 11:39 AM   #7
erif
LQ Newbie
 
Registered: May 2004
Location: Stockholm
Distribution: Slackware 9.1
Posts: 3

Original Poster
Rep: Reputation: 0
Topic should say something like "reboot does not kill sshd properly" because the process actually is killed by /etc/rc.d/rc.6.
Maybe rc.6 kills something important before it kills sshd. I have no idea.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What if 'kill -9' fails to kill a task? chii-chan Linux - Newbie 15 03-27-2013 03:47 PM
how to use kill to kill a batch of processes with same name? dr_zayus69 Linux - Software 2 09-03-2005 06:35 PM
cannot kill process (kill -9 does not work) mazer13a Linux - General 1 05-27-2005 02:32 PM
SSHD Won't Start after Server Reboot Louie55 Linux - Software 2 01-20-2005 08:34 PM
Enabling SSH in mandrake 9.2 - sshd vs. sshd-xinetd DogTags Linux - Newbie 7 11-25-2003 12:17 PM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration