LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-08-2007, 03:30 PM   #1
odin123
Member
 
Registered: May 2002
Location: Lebanon
Distribution: PCLinuxOS
Posts: 80

Rep: Reputation: 15
Realtek RTL8139C Problem


Hi all,

I installed Slackware 12 on my PC and accessed the internet with rp-pppoe because I need to use a service name. All went fine with the connection.

Yesterday I did the same Slackware 12 install on my laptop (Toshiba S3000-400) with a Realtek RTL8139C network card. I followed exactly the same steps as I did with the PC but can't get a connection.

The network card is seen, but I get a Timeout message when I start the connection.

ifconfig -a shows both eth0 (no ip), and lo
lsmod shows 8139too

Any suggestions?

Thanks a lot!
 
Old 08-08-2007, 03:32 PM   #2
ShellyCat
Member
 
Registered: Jul 2007
Distribution: Slackware 13
Posts: 178

Rep: Reputation: 28
Question Need more info:

What are the results of these commands?

lscpi

ifconfig -a
 
Old 08-08-2007, 03:45 PM   #3
odin123
Member
 
Registered: May 2002
Location: Lebanon
Distribution: PCLinuxOS
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks, ShellyCat

bash-3.1# lspci
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 11)
00:01.0 PCI bridge: Intel Corporation 82815 815 Chipset AGP Bridge (rev 11)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801BAM ISA Bridge (LPC) (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801BAM IDE U100 Controller (rev 03)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 03)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 03)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801BA/BAM AC'97 Modem Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 Go] (rev b2)
02:00.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
02:00.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)



bash-3.1# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:02:3F:01:3E:A6
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:893 errors:0 dropped:0 overruns:0 frame:0
TX packets:276 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:55254 (53.9 KiB) TX bytes:28346 (27.6 KiB)
Interrupt:5 Base address:0x3000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4876 (4.7 KiB) TX bytes:4876 (4.7 KiB)
 
Old 08-08-2007, 03:47 PM   #4
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
if u want my idea
buy anther card
do u want to know why??
see my article
http://www.linuxquestions.org/questi...d.php?t=571513

Last edited by ahmed gamal; 08-08-2007 at 03:48 PM.
 
Old 08-08-2007, 03:52 PM   #5
odin123
Member
 
Registered: May 2002
Location: Lebanon
Distribution: PCLinuxOS
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks, ahmed gamal,

but the card is built-in with the laptop, so I think I'll have to live with it!
 
Old 08-08-2007, 03:59 PM   #6
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
look u can buy a usb lan or other lan if u want
it is up to u
 
Old 08-08-2007, 04:57 PM   #7
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
i did
lspci
the o/p
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 02)
u had rev 10 and i have rev 02
what is the difference
 
Old 08-08-2007, 05:11 PM   #8
vyankey
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware 13.37
Posts: 5

Rep: Reputation: 0
Did you make the proper changes in your /etc/rc.d/rc.inet1.conf file?
 
Old 08-08-2007, 06:26 PM   #9
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
sorry vyankey
i don't understand what u said??
 
Old 08-08-2007, 06:50 PM   #10
vyankey
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware 13.37
Posts: 5

Rep: Reputation: 0
When I upgraded to Slackware 12 I had to configure the new scripts that are executed when I boot my computer. One of them is the rc.inet1.conf script. I had to enter my IPADDR, NETMASK and GATEWAY so that the rc.inet1 script could configure my ethernet card correctly.

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
.
.
.
# Default gateway IP address:
GATEWAY=""

One mine, since there are only a few computers on my home network, I assigned IP addresses to each of them.

One of the computers is an internet gateway for the others. It gets it's IP address from my ISP's DHCP server so set the USE_DHCP to Y and DHCP_HOSTNAME to the address my ISP specified.
 
Old 08-09-2007, 12:37 AM   #11
ShellyCat
Member
 
Registered: Jul 2007
Distribution: Slackware 13
Posts: 178

Rep: Reputation: 28
I would like to add to vyahkey's information...

...but it depends on your setup. Are you trying to use this Ethernet connection through a router?
 
Old 08-09-2007, 12:40 AM   #12
ShellyCat
Member
 
Registered: Jul 2007
Distribution: Slackware 13
Posts: 178

Rep: Reputation: 28
Also, check your "/etc/resolv.conf"

It is probably just empty right now. You get your DNS server information from your ISP. Here is an example "/etc/resolv.conf":

Code:
nameserver 66.189.0.29
nameserver 66.189.0.30
You should have 2 or 3 of those.
 
Old 08-09-2007, 03:27 AM   #13
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
mr ShellyCat
do u mean the name server is the dns address
then which is the preferred or alternate dns?
 
Old 08-09-2007, 03:33 AM   #14
ahmed gamal
Member
 
Registered: Aug 2005
Location: Egypt
Distribution: slackware + XP
Posts: 591

Rep: Reputation: 30
mr ShellyCat
do u mean the name server is the dns address
then which is the preferred or alternate dns?
 
Old 08-09-2007, 04:03 AM   #15
TylerD75
Member
 
Registered: Aug 2004
Location: Norway
Distribution: Gentoo
Posts: 94

Rep: Reputation: 17
Here's a quick test to see if the interface works:
Code:
# ifconfig eth0 192.168.0.2 netmask 255.255.255.0 gw 192.168.0.1 up
You might have to use a different ip address and gateway address.

Then you have to setup routes (if it is not done automagically):
Code:
route add default gw 192.168.0.1 eth0
Now you should be able to ping most computers, although you might have to configure your dns servers first:
Edit /etc/resolv.conf:
Code:
nameserver <ip-addr-of-your-isps-dns-server>
nameserver <ip-addr-of-your-isps-secondary-dns-server>
Now you should be able to ping www.google.com

If all this works, then the only problem you have is that your interface is not configured at boot.
I have no idea where you do this in your distro, but in Gentoo it is in /etc/conf.d/net.
The syntax in that file also depends on your distro. It might be like vyankey wrote, or like this (again, this is Gentoo syntax):
Code:
iface_eth0="192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0"
# or alternativly:
# config_eth0=( "192.168.0.2 netmask 255.255.255.0 brd 192.168.0.255" )
# Another possibility is that you might have to define the default route:
# routes_eth0=( "default gw 192.168.0.1" )
In gentoo you also have to create a symlink:
Code:
cd /etc/init.d/ && ln -s net.lo net.eth0
As you might understand, I use Gentoo so to enable eth0 at boot I have to do this too: # rc-update add net.eth0 default
The above command adds the interface eth0 to the default rc level. Which enables it when the computer is booted.

You might have to study how those procedures are done in your distro though
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek 8180 problem cccp Linux - Wireless Networking 5 08-30-2005 04:05 PM
realtek 8150 problem huno Linux - Hardware 0 01-02-2005 07:52 AM
Realtek 8139 Problem w3bbuilder Linux - Networking 2 08-14-2003 05:10 AM
rtl8139c-abit kr7a/raid-mandrake 9.1 strange problem patton Linux - Hardware 3 05-06-2003 06:08 AM
PCMCIA Realtek problem grayFalcon Linux - Networking 0 01-12-2003 03:58 AM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration