LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2007, 02:02 PM   #1
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Realtek 8139 network not working - DHCP unable to get IP address


hey,
I installed Slackware 11 on my friends comp and upgraded the kernel to 2.6.18. The comp detects the onboard realtek 8139 card and the mac address correctly. But dhcpcd is unable to get the ip address of the machine ( although it works fine in Windows)

I have already run netconfig etc.

Any suggestions?

Last edited by duryodhan; 01-27-2007 at 02:04 PM.
 
Old 01-27-2007, 08:06 PM   #2
ferradura
Member
 
Registered: Jun 2006
Location: PT
Distribution: CRUX & Slackware
Posts: 100

Rep: Reputation: 15
That chipset works fine on my pc. It uses the modules
Code:
8139too
&
Code:
mii
--------
You might try
Code:
#dhcpcd eth0
eth0 or whatever the device is.
But it should work after netconfig, if you have the modules.

Last edited by ferradura; 01-27-2007 at 08:10 PM.
 
Old 01-27-2007, 11:48 PM   #3
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
I just checked : it has the modules 8139too, 8139cp and mii (as part of the 2.6.18 generic package that came with Slackware 11 DVD).

And "ifconfig etho up" shows the NIC with the correct mac address. But dhcpcd is unable to obtain the IP address. So I was wondering if anyone has ever encountered this problem? Can there be any other reason for something like this?
 
Old 01-28-2007, 07:49 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,122
Blog Entries: 3

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Quote:
Originally Posted by duryodhan
I just checked : it has the modules 8139too, 8139cp and mii (as part of the 2.6.18 generic package that came with Slackware 11 DVD).

And "ifconfig etho up" shows the NIC with the correct mac address. But dhcpcd is unable to obtain the IP address. So I was wondering if anyone has ever encountered this problem? Can there be any other reason for something like this?
Hi,

Please post the output of;

Code:
ifconfig -a
route -n
Also post your /etc/rc.d/rc.inet1.conf. As for the correct MAC, are you comparing the MAC with the printed assigned MAC on the card?

Does your server/router use MAC filtering?
 
Old 01-28-2007, 08:09 AM   #5
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
ifconfig -a gives three interfaces eth0 , sit0 and lo.

route -n just gives

Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

dhcpcd eth0 didn't help


And I am comparing it to the mac my friend has registered under his a/c ... we behind a NAT and our netadmin assigns IPs to us (172.*.*.*) according to our MAC addresses.
 
Old 01-28-2007, 12:24 PM   #6
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,160

Rep: Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525Reputation: 525
Good luck with this one! My other Slackware box running Slackware 11 (2.6.17.13) has a realtek card and it sits behind a router, gets an IP address with DHCP. No issues to speak of.
Is there a possibility that you've mis-configured your set-up for DHCP?
 
Old 01-28-2007, 09:56 PM   #7
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
No , No chance of that ... cos I am behind the same NAT and I have configured it the exact same way .. and my comp is getting an IP address whereas his isn't!
 
Old 01-28-2007, 09:59 PM   #8
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
Does the realtek card act like a PCMCIA card or a simpler PCI card?

I am asking cos it shows up right after rc.pcmcia in bootup.
 
Old 01-29-2007, 07:12 AM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,122
Blog Entries: 3

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Quote:
Originally Posted by duryodhan
ifconfig -a gives three interfaces eth0 , sit0 and lo.

route -n just gives

Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

dhcpcd eth0 didn't help


And I am comparing it to the mac my friend has registered under his a/c ... we behind a NAT and our netadmin assigns IPs to us (172.*.*.*) according to our MAC addresses.
Hi,

When you are requested for information for diagnosis, please post un-edited and complete. A lot of information can be provided that you may over look.

As for your problem, you do not have a defined route in your routing table. If you have the gateway as 192.168.0.1 then;
Code:
route add default gw 192.168.0.1    #define default gw
This should provide;
Code:
#route -n            #man route to get switches
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.1     0.0.0.0         UG    1      0        0 eth0
for the device eth0.
 
Old 01-29-2007, 10:31 AM   #10
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
Yeah, but all of that is provided by the DHCP server. I am behind the same NAT and DHCP provides everything.


Sorry, but I can't post the whole output cos that comp doesn't have NET access and the USB ports are erratic at best.
 
Old 01-30-2007, 03:40 AM   #11
riodeuno
Member
 
Registered: Jan 2007
Location: India
Distribution: Slackware 12.1
Posts: 53

Rep: Reputation: 15
i have a similar problem

i have a similar problem as stated by duryodhan above,
except i never see a 'sit0' but i see 'eth0' and 'lo'
i have tried
'dhcpcd eth0 up'
and all of what is said above
but without any success
i too have a realtek 8139 NIC fast ethernet
i had the same problem with my previous kernel(2.6.18.3)
so i upgraded it
i am using a kernel version 2.6.19.2.
my kernel has the appropriate drivers for the ethernet card and also it detects my mac address
i am using a DHCP server behind a NAT.
i have no such problems with windows xp which is also installed alongside linux



Quote:
bash-3.1# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo


bash-3.1# ifconfig
eth0 Link encap:Ethernet HWaddr 00:14:2A:A3:BB:BC
inet6 addr: fe80::214:2aff:fea3:bbbc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:929 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7112 (6.9 KiB) TX bytes:7112 (6.9 KiB)


bash-3.1# route add default gw 172.16.7.254
SIOCADDRT: Network is unreachable
 
Old 01-30-2007, 05:54 AM   #12
jumapeg
Member
 
Registered: Jul 2006
Location: Spain
Distribution: Slackware current
Posts: 32

Rep: Reputation: 15
I have a laptop with that network card, when I configure it without DCHP, using netconfig and static ip option everything seems to be ok, ifconfig shows the card configured but I'm unable to send a byte.

I found the solution in google, the command "noirqdebug" has to be added at startup, as a kernel option, in the boot manager. I have to use this command in Slackware, Debian, Ubuntu...

Try using this command.
 
Old 01-30-2007, 08:52 AM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,122
Blog Entries: 3

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
Quote:
Originally Posted by duryodhan
And I am comparing it to the mac my friend has registered under his a/c ... we behind a NAT and our netadmin assigns IPs to us (172.*.*.*) according to our MAC addresses.
Hi,

If your admin assigns you a IP, then why are you doing dhcp?

BTW, you can compare all you want! The MAC is unique to the card. Be a NIC or wireless adapter. The MAC is pre-assigned to the unit by the manufacture from a pool of allocated MACs. Your friends MAC is different than yours therefore the IP assigned to his unit will only work for him.

If the admin gave you an IP then just edit /etc/rc.d/rc.inet1.conf and add the information for the device, IP, netmask, and gateway. Don't forget to add your nameserver(s) to /etc/resolv.conf.

Last edited by onebuck; 01-30-2007 at 08:55 AM.
 
Old 01-30-2007, 09:39 AM   #14
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
Jumapeg : How do I add the command ? will
Quote:
append ="noriqdebug=yes"
in lilo.conf work?
 
Old 01-30-2007, 10:41 AM   #15
jumapeg
Member
 
Registered: Jul 2006
Location: Spain
Distribution: Slackware current
Posts: 32

Rep: Reputation: 15
duryodhan:
Just "noirqdebug" in lilo.conf
Quote:
append ="noirqdebug"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
realtek 8139 Suse 9.3 not working internet and network Evily Linux - Newbie 1 01-17-2006 02:11 AM
Realtek 8139 not working on debian Ben136 Linux - Hardware 16 12-15-2005 09:37 AM
Mandrake 10.2 Realtek 8139 Ethernet unable to connect SgC.9711 Linux - Newbie 20 10-11-2005 01:33 AM
eth0 not working on realtek 8139 gregorya Linux - Networking 9 03-12-2005 12:46 PM
Can't get internet working on Slackware 9.1, kernel 2.4.22, realtek 8139 with dhcp ygnas Slackware 6 03-02-2004 11:06 AM


All times are GMT -5. The time now is 12:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration