LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2007, 05:02 PM   #1
kahnakha
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Rep: Reputation: 0
Read-Only filesystem


my slack is on hda2
and when he load it says that there is some problem with the partition couse is on read-only format, and will be batter if i type: e2fsck -n <device>
when i type: e2fsck -n /dev/hda2 on the root screen it says that he is not able to continue couse is not able to find superblock (or something like that.. i,m not able to make screenshot there) and will be batter to type: e2fsck -b 8391 <device> to use alternate superblock.
When i type it... it says will be batter if i type: e2fsck -n <device>
and so, and so on...

however... i fount the way to boot my slack. with bootable diskate and command mount root=/dev/hda2 rw
everything loads fine... but i see somewhere in loading screen error with filesystem and to fix it i need to change a lilo.conf file in /etc/ to add the line read-only and that will fix the problem... but when i open it, i see that this line was here all the time...
 
Old 02-24-2007, 01:48 AM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
This seems like a Slackware specific issue, or at least, I think it is.

I honestly have almost no idea what you are trying to say here other than there is some file system error which is preventing you from booting the machine, and you are trying to get it started and resolved.
 
Old 02-24-2007, 02:09 AM   #3
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
Im not overly sure either about what it is you want, but here is my take:

Linux mounts the root file system read-only, its safe, but realistically, you need it to be read/write (and going that you used the "rw" option to mount, i think thats what you want). The solution, in this case, is that your distros boot scripts (if you even have any) fail to remount the root file system with read/write, issue the command
Code:
mount -o remount -rw /
as root, that will give you a read/write root filesystem.
 
Old 02-24-2007, 01:07 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,983
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Moved: This thread is more suitable in <SLACKWARE> (maybe someone here can understand what you're after), and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 02-24-2007, 06:42 PM   #5
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
I'm not sure what's exactly going on, but I suspect a hardware fault. Your hard drive might be dying.
 
Old 03-07-2007, 12:04 PM   #6
animeresistance
Member
 
Registered: Feb 2004
Distribution: Slackware
Posts: 191

Rep: Reputation: 20
Hi, one question, you got this problem after recompiling your kernel or after installing Slackware ?

Greetings
 
Old 03-07-2007, 12:23 PM   #7
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 188

Rep: Reputation: 33
The part about not finding a superblock doesn't sound good, thought I'm not sure as I've never run into that. Check /etc/fstab to make sure you're mounting hda2 rw. Initially on boot-up it's supposed to be mounted ro, but then it gets remounted as rw(along with any other options you've got in /etc/fstab). So check that file and if you're not sure post it up here.
 
Old 03-07-2007, 12:40 PM   #8
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
Perhaps you could try booting from the diskette and then e2fsck /dev/hda2 while it is not mounted.
As I suspect a filesystem error is preventing you from mounting as rw.

tobyl

Last edited by tobyl; 03-07-2007 at 12:42 PM.
 
Old 03-07-2007, 01:18 PM   #9
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
I ran into this before, and it was fstab related.
I had mistakenly put in etc/fstab to mount device '/dev/hda' instead of '/dev/hda5' for example.
I forgot to specify the partition, and the result was identical to the problem the original poster is having.
Took a few close looks before noticing the typo. After that correction, all was perfect.
 
Old 04-18-2007, 09:40 AM   #10
TheLateJC
Member
 
Registered: Apr 2007
Location: Sydney
Distribution: Debian. (Formerly Slackware, Gentoo, RHEL, and Suse)
Posts: 80

Rep: Reputation: 15
I think I have the same problem as the original poster. The problem only exists when I try to start a 2.6 kernel. The 2.4 kernel is fine, and all disks are fine when booting huge26.s from the cd.

everything looks good during boot, all disks are detected, until e2fsck posts an error: No such device or address while trying to open /dev/hda2. Which I notice happens when fstab has invalid entries.

I'm given the option to login to reboot. I can login with hda2's root password, and I'm given hda2 which I can remount rw and write to the disk, but I cannot mount any other volumes nor open disks with fdisk. It's as if the devices are not connected and I'm very confused.
 
Old 04-21-2007, 07:09 AM   #11
TheLateJC
Member
 
Registered: Apr 2007
Location: Sydney
Distribution: Debian. (Formerly Slackware, Gentoo, RHEL, and Suse)
Posts: 80

Rep: Reputation: 15
Nuked Slack and tried Debian, the system now boots and all drives are detected.

Performance of drives attached to the ITE8212 sucks for an as yet unknown reason, but at least I can use them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I have: Root has Read-Write, user has read only for the boot filesystem? xmrkite Linux - Software 6 10-16-2008 04:31 AM
read-only filesystem karunesh Linux - General 1 09-30-2005 10:04 AM
read only filesystem ONLY greg108 Linux - General 3 08-26-2004 06:11 PM
Read-only filesystem neillans Linux - General 2 06-11-2004 01:27 PM
how do I change the filesystem from read-only to read-write? les_chow Linux - Newbie 5 05-26-2004 03:14 PM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration