LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-20-2013, 08:46 AM   #1
cmyster
Member
 
Registered: Oct 2004
Location: Israel
Distribution: Slackware64-current
Posts: 38

Rep: Reputation: 1
rdesktop segfaults in current


on latest 64 current (Sat Oct 19 03:42:15 UTC 2013) it seems that rdesktop -P (bitmap caching) is causing a segmentation fault:
/usr/bin/rdesktop -P -z -a 32 -x 0x81 -T [dev]:[10.0.0.141] -r clipboard:CLIPBOARD -g 1913x1021 -u xxxxxx -p xxxxxx -r disk:local=/home/rd 10.0.0.141
Connection established using SSL.
WARNING: Remote desktop does not support colour depth 24; falling back to 16
Segmentation fault

removing the -P works.

rebuilding from source did not help.
 
Old 10-20-2013, 09:52 AM   #2
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware, Slackware 64, Slackware ARM, Gentoo, Fedora
Posts: 160

Rep: Reputation: Disabled
This issue was reported upstream, see bugs 367 and 368. It seems to have been fixed with commit 1732. 1731 is needed to patch cleanly (1732 reverts the change made in this commit), 1741 silences a build warning introduced by 1732 but isn't essential.
 
Old 10-20-2013, 09:59 AM   #3
cmyster
Member
 
Registered: Oct 2004
Location: Israel
Distribution: Slackware64-current
Posts: 38

Original Poster
Rep: Reputation: 1
Thanks turtleli.
Since this is not in an official patch I'll just won't use -P.
Now I wonder, is this big an issue enough to be addressed in 14.1?
 
Old 10-20-2013, 01:41 PM   #4
mancha
Member
 
Registered: Aug 2012
Posts: 362

Rep: Reputation: Disabled
Hi.

Please test this patch I put together based on upstream revisions and let us know if the issue gets resolved.

These fixes will be in the 1.8.1 release but I've taken a quick look at rdesktop's release cycle and it doesn't seem this will happen before 14.1.
Pat might consider the patch in this case.

--mancha
 
Old 10-20-2013, 02:57 PM   #5
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 505

Rep: Reputation: 84
mancha,

It is working here. Thank you.
 
Old 10-21-2013, 11:19 PM   #6
mancha
Member
 
Registered: Aug 2012
Posts: 362

Rep: Reputation: Disabled
@BrZ:

Thank you for testing the patch. You'll be happy to see it made its way into RC2.

--mancha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
google-chrome segfaults on Slackware64 -current TL_CLD Slackware 26 05-27-2012 11:13 AM
[SOLVED] 64-current 2010-08-27 - segfaults - zlib? no: libxml2 ponce Slackware 13 06-21-2011 12:18 PM
[SOLVED] Ash segfaults on second backspace 64-current GazL Slackware 15 04-02-2010 05:40 AM
Slackware64-current: Creation of LUKS encrypted partition segfaults titopoquito Slackware 16 08-16-2009 05:02 AM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration