LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-02-2010, 12:09 PM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,092

Rep: Reputation: 147Reputation: 147
RaLink RT2760 Wireless


Well, I decided to join the world of the wireless and bought the only (literally) wireless PCI card I could find in town.
According to lspci it is a, "RaLink RT2760 Wireless 802.11n 1T/2R Cardbus."
Running lsmod showed several references to rt28000 modules and some are being "used" by rt2x00pci and all are being used by rt2800pci or rt2800lib or rt2x00usb.
Regardless, the card is not being seen by wicd (1.70).
Any suggestions would be greatly appreciated.
Thank you very much.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 09-02-2010, 12:25 PM   #2
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 871
Blog Entries: 9

Rep: Reputation: 103Reputation: 103
Hi, I too have a ralink 802.11n card, and found that the rt2x00 drivers are completely useless (as they say in the kernel doc and on their web). I had to blacklist them and resort to using the ralink drivers from the kernel staging directory. I guess your card might work with the rt2860 module.
In any case, ralink provides official opensource drivers, which you can get on their website, and they usually work.

good luck, Serafean
 
1 members found this post helpful.
Old 09-02-2010, 12:38 PM   #3
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 418

Rep: Reputation: 58
I'm using a Ralink 2870 USB wireless adapter but this should work for your adapter as well. The rt2800 modules are loaded and conflict with the rt2x00 modules. The way I fixed this was to blacklist all the rt2800 modules by creating the file: /etc/modprobe.d/ralink.conf

Code:
# blacklist Ralink kernel drivers
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2800lib
That will take effect on the next reboot. I didn't have to install any additional drivers from Ralink with 13.1. Hope that works for you too!

Last edited by Chuck56; 09-02-2010 at 12:50 PM.
 
2 members found this post helpful.
Old 09-02-2010, 09:59 PM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,092

Original Poster
Rep: Reputation: 147Reputation: 147
Thank you, Chuck56 and Serafean, for your suggestions, they are greatly appreciated.
I have tried writing a blacklist just as suggested by Chuck56 and regardless of what I do
all the rt modules are still loaded and appear each time I run lsmod.
Here are the lines from lsmod that pertain to the rt drivers:
rt2860sta 557562 0
rt2800pci 9883 0
rt2800lib 21629 1 rt2800pci
rt2x00usb 7949 1 rt2800lib
rt2x00pci 5283 1 rt2800pci
crc_ccitt 1323 1 rt2800pci
rt2x00lib 26634 4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
led_class 2785 1 rt2x00lib
mac80211 171226 3 rt2x00usb,rt2x00pci,rt2x00lib
cfg80211 128711 2 rt2x0lib,mac80211
rfkill 15860 1 cfg80211
eeprom_93cx6 1368 1 rt2800pci
 
Old 09-03-2010, 08:14 PM   #5
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,092

Original Poster
Rep: Reputation: 147Reputation: 147
As mentioned in the message just above, the blacklist method doesn't work, i.e., the modules are still loaded.
Perhaps the list should be in a different directory?
Any suggestions?
Thanks.
 
Old 09-03-2010, 09:29 PM   #6
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 418

Rep: Reputation: 58
It's never easy with some of these wireless cards. I did a little searching on your card and an Arch user reported success with "blacklist rt2800pci, rt2800usb, rt2x00pci and rt2x00usb, then modprobe rt2860sta".

The /etc/modprobe.d directory is right. If you like you can add your newlines directly to the blacklist.conf file but be prepared if an upgrade overwrites that file in the future.
 
Old 09-04-2010, 03:39 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,112

Rep: Reputation: Disabled
I had this issue with the RaLink driver too on my EEE pc - I wrote an artivcle about how I blacklisted the new drivers here: http://alien.slackbook.org/blog/upgr...epc-to-2-6-33/

Eric
 
Old 09-04-2010, 10:41 AM   #8
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 871
Blog Entries: 9

Rep: Reputation: 103Reputation: 103
I personnally simply blacklist the rt2x00lib module, and thats that. Absolutely no rt2x00 module gets loaded after that.
Code:
blacklist rt2x00lib
in /etc/modprobe.d/blacklist.conf

Serafean
 
Old 09-04-2010, 08:59 PM   #9
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,092

Original Poster
Rep: Reputation: 147Reputation: 147
Well.... Guess I was making it more difficult than necessary.
It is very embarrassing to admit this, but I was reading through other posts on the subject and after running a few line commands, e.g., ifconfig -a, iwconfig, iwlist, ifconfig wlan0 up and wlan0 scan, it was apparent the card was actually working. So.... I looked at the preferences for Wicd and realized I had forgotten to put "wlan0" in the wireless interface box...


Thanks to everyone for their patience and their help.


Last edited by cwizardone; 09-04-2010 at 11:30 PM.
 
Old 12-16-2010, 04:47 AM   #10
Atrumsalus
LQ Newbie
 
Registered: Dec 2010
Posts: 3

Rep: Reputation: 0
Thank you

Just to clarify. Easiest way to get file is to use netpkg, aptitude or something like that to install rt2860-firmware-26-fw-1.txz. If you webget use the site is http://www.ralinktech.com/support.php?s=2

Quote:
Originally Posted by Chuck56 View Post
I'm using a Ralink 2870 USB wireless adapter but this should work for your adapter as well. The rt2800 modules are loaded and conflict with the rt2x00 modules. The way I fixed this was to blacklist all the rt2800 modules by creating the file: /etc/modprobe.d/ralink.conf

Code:
# blacklist Ralink kernel drivers
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2800lib
That will take effect on the next reboot. I didn't have to install any additional drivers from Ralink with 13.1. Hope that works for you too!
This worked great for me. Just make sure you do ifconfig wlan0 up before you reboot. Also for Noobs in order to make the ralink.conf file type nano, vim, geany, pico, or whatever your terminal text editor is before the path. IE: Nano /etc/modprobe.d/ralink.conf Also, helps if you are either signed in as root or in root terminal. Again thank you all, sorry for any typos it is 4am here and little sleepy. Cheers.
 
Old 12-16-2010, 04:56 AM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,112

Rep: Reputation: Disabled
Quote:
Originally Posted by Atrumsalus View Post
Just to clarify. Easiest way to get file is to use netpkg, aptitude or something like that
This is a Slackware forum. We do not have netpkg nor aptitude in Slackware...

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RaLink RT3090 Wireless help TrueBlue Linux - Networking 1 07-29-2010 05:32 AM
Slow adsl wireless connection using kernel ralink wireless driver vdemuth Slackware 2 01-02-2009 12:44 PM
Driver for Plexus/Tenda W302p with Ralink RT2760 chipset? SadPenguin Linux - Wireless Networking 3 05-31-2008 01:57 AM
Ralink Wireless Combination NIC thundersurfer Linux - Wireless Networking 2 03-20-2008 08:38 AM
Help Ubuntu with wireless card Ralink italiano40 Linux - Wireless Networking 1 10-14-2006 07:34 AM


All times are GMT -5. The time now is 03:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration