LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   RaLink RT2760 Wireless (http://www.linuxquestions.org/questions/slackware-14/ralink-rt2760-wireless-829973/)

cwizardone 09-02-2010 12:09 PM

RaLink RT2760 Wireless
 
Well, I decided to join the world of the wireless :) and bought the only (literally) wireless PCI card I could find in town.
According to lspci it is a, "RaLink RT2760 Wireless 802.11n 1T/2R Cardbus."
Running lsmod showed several references to rt28000 modules and some are being "used" by rt2x00pci and all are being used by rt2800pci or rt2800lib or rt2x00usb.
Regardless, the card is not being seen by wicd (1.70).
Any suggestions would be greatly appreciated.
Thank you very much.
:hattip:

serafean 09-02-2010 12:25 PM

Hi, I too have a ralink 802.11n card, and found that the rt2x00 drivers are completely useless (as they say in the kernel doc and on their web). I had to blacklist them and resort to using the ralink drivers from the kernel staging directory. I guess your card might work with the rt2860 module.
In any case, ralink provides official opensource drivers, which you can get on their website, and they usually work.

good luck, Serafean

Chuck56 09-02-2010 12:38 PM

I'm using a Ralink 2870 USB wireless adapter but this should work for your adapter as well. The rt2800 modules are loaded and conflict with the rt2x00 modules. The way I fixed this was to blacklist all the rt2800 modules by creating the file: /etc/modprobe.d/ralink.conf

Code:

# blacklist Ralink kernel drivers
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2800lib

That will take effect on the next reboot. I didn't have to install any additional drivers from Ralink with 13.1. Hope that works for you too!

cwizardone 09-02-2010 09:59 PM

Thank you, Chuck56 and Serafean, for your suggestions, they are greatly appreciated.
I have tried writing a blacklist just as suggested by Chuck56 and regardless of what I do
all the rt modules are still loaded and appear each time I run lsmod.
Here are the lines from lsmod that pertain to the rt drivers:
rt2860sta 557562 0
rt2800pci 9883 0
rt2800lib 21629 1 rt2800pci
rt2x00usb 7949 1 rt2800lib
rt2x00pci 5283 1 rt2800pci
crc_ccitt 1323 1 rt2800pci
rt2x00lib 26634 4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
led_class 2785 1 rt2x00lib
mac80211 171226 3 rt2x00usb,rt2x00pci,rt2x00lib
cfg80211 128711 2 rt2x0lib,mac80211
rfkill 15860 1 cfg80211
eeprom_93cx6 1368 1 rt2800pci

cwizardone 09-03-2010 08:14 PM

As mentioned in the message just above, the blacklist method doesn't work, i.e., the modules are still loaded.
Perhaps the list should be in a different directory?
Any suggestions?
Thanks.
:hattip:

Chuck56 09-03-2010 09:29 PM

It's never easy with some of these wireless cards. I did a little searching on your card and an Arch user reported success with "blacklist rt2800pci, rt2800usb, rt2x00pci and rt2x00usb, then modprobe rt2860sta".

The /etc/modprobe.d directory is right. If you like you can add your newlines directly to the blacklist.conf file but be prepared if an upgrade overwrites that file in the future.

Alien Bob 09-04-2010 03:39 AM

I had this issue with the RaLink driver too on my EEE pc - I wrote an artivcle about how I blacklisted the new drivers here: http://alien.slackbook.org/blog/upgr...epc-to-2-6-33/

Eric

serafean 09-04-2010 10:41 AM

I personnally simply blacklist the rt2x00lib module, and thats that. Absolutely no rt2x00 module gets loaded after that.
Code:

blacklist rt2x00lib
in /etc/modprobe.d/blacklist.conf

Serafean

cwizardone 09-04-2010 08:59 PM

Well.... :redface: Guess I was making it more difficult than necessary.
It is very embarrassing to admit this, but I was reading through other posts on the subject and after running a few line commands, e.g., ifconfig -a, iwconfig, iwlist, ifconfig wlan0 up and wlan0 scan, it was apparent the card was actually working. So.... I looked at the preferences for Wicd and realized I had forgotten to put "wlan0" in the wireless interface box...
:banghead: :banghead: :banghead:

Thanks to everyone for their patience and their help.

:hattip:

Atrumsalus 12-16-2010 04:47 AM

Thank you
 
Just to clarify. Easiest way to get file is to use netpkg, aptitude or something like that to install rt2860-firmware-26-fw-1.txz. If you webget use the site is http://www.ralinktech.com/support.php?s=2

Quote:

Originally Posted by Chuck56 (Post 4086189)
I'm using a Ralink 2870 USB wireless adapter but this should work for your adapter as well. The rt2800 modules are loaded and conflict with the rt2x00 modules. The way I fixed this was to blacklist all the rt2800 modules by creating the file: /etc/modprobe.d/ralink.conf

Code:

# blacklist Ralink kernel drivers
blacklist rt2800pci
blacklist rt2800usb
blacklist rt2800lib

That will take effect on the next reboot. I didn't have to install any additional drivers from Ralink with 13.1. Hope that works for you too!

This worked great for me. Just make sure you do ifconfig wlan0 up before you reboot. Also for Noobs in order to make the ralink.conf file type nano, vim, geany, pico, or whatever your terminal text editor is before the path. IE: Nano /etc/modprobe.d/ralink.conf Also, helps if you are either signed in as root or in root terminal. Again thank you all, sorry for any typos it is 4am here and little sleepy. Cheers.

Alien Bob 12-16-2010 04:56 AM

Quote:

Originally Posted by Atrumsalus (Post 4193318)
Just to clarify. Easiest way to get file is to use netpkg, aptitude or something like that

This is a Slackware forum. We do not have netpkg nor aptitude in Slackware...

Eric


All times are GMT -5. The time now is 03:42 AM.