LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2009, 05:07 PM   #46
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65

Quote:
Originally Posted by LJSBrokken View Post
Solved!

Although I get the following when running glxgears:
[code]$ glxgears
Mesa: Mesa 7.8-devel DEBUG build Dec 20 2009 20:54:44
Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable
Reply to self ;-)
libtxc_dxtn.so can be had from here:
http://homepage.hispeed.ch/rscheidegger/dri_experimental/s3tc_index.html
Now glxgears and the likes report
Code:
$ glxgears
Mesa: Mesa 7.8-devel DEBUG build Dec 20 2009 20:54:44
Mesa warning: software DXTn compression/decompression available
Mesa: Initializing x86-64 optimizations
Mesa: 3Dnow! detected
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
(for what it's worth)

Now on to the 'vblank_mode configuration'...

Last edited by BroX; 12-20-2009 at 05:10 PM.
 
Old 12-20-2009, 05:34 PM   #47
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
IRQs are not supported unless you are using the latest/greatest code in drm_next and have downloaded some extra firmware. Without that support you can't sync-to-vblank. It's really safe to ignore that message.

As for the DXTn stuff... That's actually completely broken on r6xx/r7xx cards, even with the libtxc_dxtn library.
 
Old 12-20-2009, 06:31 PM   #48
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Solved!

Quote:
Originally Posted by adamk75 View Post
IRQs are not supported unless you are using the latest/greatest code in drm_next and have downloaded some extra firmware. Without that support you can't sync-to-vblank. It's really safe to ignore that message.

As for the DXTn stuff... That's actually completely broken on r6xx/r7xx cards, even with the libtxc_dxtn library.
Thanks for getting this sorted! I'll leave it that then.
 
Old 12-21-2009, 02:02 AM   #49
mkoco
Member
 
Registered: Feb 2008
Location: US, New Jersey
Distribution: Slackware
Posts: 88

Rep: Reputation: 17
Compiling in 2.6.32.2:
from ./autogen.sh in xf86-video-ati/ -
Code:
configure.ac:35: error: xorg-macros version 1.3 or higher is required but 1.2.2 found
/usr/share/aclocal/xorg-macros.m4:45: XORG_MACROS_VERSION is expanded from...
configure.ac:35: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
 
Old 12-21-2009, 02:49 AM   #50
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Quote:
Originally Posted by mkoco View Post
Compiling in 2.6.32.2:
from ./autogen.sh in xf86-video-ati/ -
Code:
configure.ac:35: error: xorg-macros version 1.3 or higher is required but 1.2.2 found
/usr/share/aclocal/xorg-macros.m4:45: XORG_MACROS_VERSION is expanded from...
configure.ac:35: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
Updating xorg-macros:

(Copy/pasted from Xorg.wiki)
The build macros module contains a set of macros used by the build scripts across X.org modules. They are needed by both the Xserver and the drivers, if you are compiling from git.

Code:
$ git clone git://anongit.freedesktop.org/git/xorg/util/macros
$ cd macros
$ ./autogen.sh --prefix=/opt/xorg
$ make install
After installing the build macros, you should point your build environment to the newly installed macros. Add "/opt/xorg/share/aclocal" at the include patch of the aclocal tool:

Bash:

Code:
$ export ACLOCAL="aclocal -I /opt/xorg/share/aclocal"
C shell:

Code:
$ setenv ACLOCAL "aclocal -I /opt/xorg/share/aclocal"

Last edited by BroX; 12-21-2009 at 04:12 AM. Reason: corrected typo (git-clone -> git clone)
 
Old 12-21-2009, 05:11 AM   #51
dolphin77
Member
 
Registered: May 2009
Posts: 200

Original Poster
Rep: Reputation: 54
Code:
#!/bin/sh

PKGNAM=util-macros
VERSION=$(date +%Y%m%d)_git
ARCH=${ARCH:-x86_64}
BUILD=${BUILD:-1}

NUMJOBS=${NUMJOBS:--j8}
CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-util-macros

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

rm -rf $PKG
mkdir -p $TMP $PKG
cd macros 
git pull
#git checkout

# Make sure ownerships and permissions are sane:
chown -R root:root .
find . \
  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  -exec chmod 644 {} \;
make clean

./autogen.sh 

CFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --build=$ARCH-slackware-linux

make $NUMJOBS 
make install DESTDIR=$PKG 

mkdir -p $PKG/install

cd $PKG
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
mv $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz  $CWD
 
Old 12-21-2009, 11:46 AM   #52
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Radeon Mobility 7500 - AGP 1x mode

I enabled kms on my Thinkpad T41 with a Radeon Mobility 7500, which should be supported, right?

For some reason agp gets put in 1x mode (instead of 4x), fps in glxgears drop to about half of normal and there are problems with transparancy. No errors or warnings in Xorg.0.log.

intel_agp is built as module and gets loaded before radeon.

Code:
Linux agpgart interface v0.103
agpgart-intel 0000:00:00.0: Intel 855PM Chipset
agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
agpgart-intel 0000:00:00.0: AGP 2.0 bridge
agpgart-intel 0000:00:00.0: putting AGP V2 device into 1x mode
radeon 0000:01:00.0: putting AGP V2 device into 1x mode
Is this a know problem with this card? Google didn't help much. Except for specifying AGPMode in xorg.conf, but that would defeat the whole point of enabling kms. Is there some boot parameter to force 4x mode?
 
Old 12-21-2009, 11:59 AM   #53
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Well, bear in mind that 3D with KMS is still slower than 3D without KMS. It's possible that it's being put into agp mode 1x because of known stability issues. However, you can force it to another speed with the radeon.agpmode kernel option. For 4x, it would be 'radeon.agpmode=4'. Not sure how/why that would impact transparency, so I don't expect it to solve that problem. Maybe you could describe what you mean by that or, even better, grab a screenshot.

Adam
 
Old 12-21-2009, 02:29 PM   #54
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Quote:
Originally Posted by adamk75 View Post
Well, bear in mind that 3D with KMS is still slower than 3D without KMS. It's possible that it's being put into agp mode 1x because of known stability issues. However, you can force it to another speed with the radeon.agpmode kernel option. For 4x, it would be 'radeon.agpmode=4'. Not sure how/why that would impact transparency, so I don't expect it to solve that problem. Maybe you could describe what you mean by that or, even better, grab a screenshot.

Adam
Thanks. Indeed, setting agp to 4x does not increase the fps.

I attached a screenshot to illustrate the problem with transparency on the desktop. The task manager at the bottom is transparent but does not show anything when I enable composite using OpenGL (KDE4 desktop effects). If I use Xrender it looks ok but everything gets very sluggish. Besides this, darkening of the parent window (seen in the screenshot when there is a pup-up in firefox) colours the parent window pink...

One more thing, thefollowing pops up when running glxgears:
Code:
*********************************WARN_ONCE*********************************
File radeon_tcl.c function radeon_run_tcl_render line 499
Rendering was 96 commands larger than predicted size. We might overflow  command buffer.
***************************************************************************
I don't care too much about the eye candy, but I do like to find out why things are wrong.

Cheers, Leon.
Attached Images
File Type: png snapshot1.png (36.6 KB, 16 views)

Last edited by BroX; 12-21-2009 at 02:31 PM.
 
Old 12-21-2009, 03:39 PM   #55
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Quote:
Originally Posted by dolphin77 View Post
there is a bug in 2.6.32.2. I've seen a patch for it somewhere, but I am to busy for now. Try Googling if you want, or better stick to 2.6.32 or 2.6.32.1 for a while.
Would that be this patch?

http://patchwork.kernel.org/patch/69076/
 
Old 12-21-2009, 03:52 PM   #56
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
If I had to guess, I'd say you've hit a bug in Mesa, unfortunately. Are you using a specific release of Mesa, or did you update from git?

Adam
 
Old 12-21-2009, 04:05 PM   #57
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
Quote:
Originally Posted by adamk75 View Post
If I had to guess, I'd say you've hit a bug in Mesa, unfortunately. Are you using a specific release of Mesa, or did you update from git?

Adam
Updated from git 20091221. Is it a known bug?
 
Old 12-21-2009, 05:37 PM   #58
mkoco
Member
 
Registered: Feb 2008
Location: US, New Jersey
Distribution: Slackware
Posts: 88

Rep: Reputation: 17
After building the packages and installing them, startx boots up to a garbled and unworking desktop, with the errors:

Code:
(EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r300_dri.so failed (/usr/lib/xorg/modules/dri/r300_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Screen 0 is not DRI capable
(EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/swrast_dri.so failed (/usr/lib/xorg/modules/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
(EE) GLX: could not load software renderer
(II) GLX: no usable GL providers found for screen 0
But after installing these packages, these modules are in /usr/local/lib/dri. They are part of the mesa package which I got from git. In fact, almost everything from that package went into /usr/local.

Should I just move it all into the normal location? Fix the package? I tried symlinks, but that didn't work either.
 
Old 12-21-2009, 05:46 PM   #59
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
It's not a bug I know of. When building from git, you should pass the option --with-dri-driverdir=/usr/lib/xorg/modules/dri/ (or /usr/lib64/xorg/modules/dri/ on Slackware 64) to configure (or autogen.sh) to have the drivers installed in the proper location.

Adam
 
Old 12-21-2009, 08:14 PM   #60
mkoco
Member
 
Registered: Feb 2008
Location: US, New Jersey
Distribution: Slackware
Posts: 88

Rep: Reputation: 17
Well, X starts up okay now, no errors. Buts is a garbled and useless desktop. So I'm assuming this doesn't work with older drivers? I have an ATI Mobility Radeon x1400. Its a r520 chipset, which wants to use the r300 module.

In any case, anyone else with a similar chipset have success?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux KMS Intel 865G: Hacking KMS to use vesa... or disable hardware acceleration eantoranz Linux - Hardware 1 08-01-2009 01:58 PM
KMS with radeon gives garbled screen with x onlyolli Linux - Software 0 06-29-2009 05:14 PM
LXer: TTM, Radeon KMS Support Goes Into Linux 2.6.31 LXer Syndicated Linux News 0 06-17-2009 07:11 PM
LXer: The KMS, Plymouth Experience In Fedora 10 LXer Syndicated Linux News 0 11-28-2008 03:40 AM
Radeon 9600 Pro 2.6.6 Works, 2.6.7 doesn't AlgebraicSpore Linux - Hardware 4 07-14-2004 06:36 PM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration