LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-07-2007, 04:46 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Rep: Reputation: 222Reputation: 222Reputation: 222
Quota Limit reached


Well, I just got a new printer, an HP OfficeJet J5780 All-in-one. Its nice, CUPS actually sees this printer, and I was able to set it up relatively easily, and test printed a page. I then went back and changed a few settings for the DPI output, and decided to try another test print, and was met with a quota error page...
Quote:
Error:

Quota limit reached.

However I don't have any other jobs pending. I guess I missed something, but can't quite figure out what. How do I change the quota limit?
 
Old 08-07-2007, 05:21 PM   #2
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
looks like you have got to get on the command line with lpadmin

http://printing.kde.org/documentatio...als/quotas.php

tobyl
 
Old 08-07-2007, 05:30 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Thanks, I will have to play with lpadmin then.
 
Old 08-07-2007, 07:00 PM   #4
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Well, it seems that it didn't quite work out. I decided to just completely turn off all quotas, so I issued the following command.
Code:
root@slacker:/home/slackuser# lpadmin -p HP_OfficeJetJ5780 -o job-k-limit=0 -o job-page-limit=0
root@slacker:/home/slackuser#
But I am still getting a quota error. I didn't get any errors from the command, since I did specify the right printer name. What gives?

[edit]
This is what printers.conf looks like.
Code:
# Printer configuration file for CUPS v1.2.11
# Written by cupsd on 2007-08-08 18:21
<Printer HP_OfficeJetJ5780>
Info
Location
DeviceURI usb://HP/Officejet%20J5700%20series?serial=CN73HC40D404TB
State Idle
StateTime 1186605290
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
AllowUser slackuser
OpPolicy default
ErrorPolicy abort-job
</Printer>

Last edited by Jeebizz; 08-07-2007 at 07:28 PM.
 
Old 08-08-2007, 02:39 PM   #5
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
is there an error log in /var/log/cups?

sorry Jeebizz I'm not knowledgeable on HP printers

you might get some useful info here:

http://hplip.sourceforge.net/index.html
(I suppose you do have the Slackware hplip installed and if so, I think there is an rc file in /etc/rc.d for hplip)

tobyl

edit: actually it seems only slackware >11.0 has hplip, before it was hpijs
you may wish to investigate if this makes a difference to you...

Last edited by tobyl; 08-08-2007 at 03:00 PM.
 
Old 08-08-2007, 04:26 PM   #6
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Sorry, I failed to specify my version. I am running Slackware 12, and I made sure to enable hplip, since hplip was available in this version. I have looked at the hplip site at sourceforge, and it seems that hplip is the recommended default for deskjet, not hpjis. It seems that hpjis has been superseded by hplip. Anyways, this is the error log.
Code:
I [09/Aug/2007:15:26:13 -0500] Saving job cache file "/var/cache/cups/job.cache"...
I [09/Aug/2007:15:26:17 -0500] Listening to 127.0.0.1:631 (IPv4)
I [09/Aug/2007:15:26:17 -0500] Listening to /var/run/cups/cups.sock (Domain)
I [09/Aug/2007:15:26:17 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [09/Aug/2007:15:26:17 -0500] Using default TempDir of /var/spool/cups/tmp...
I [09/Aug/2007:15:26:17 -0500] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [09/Aug/2007:15:26:17 -0500] Configured for up to 100 clients.
I [09/Aug/2007:15:26:17 -0500] Allowing up to 100 client connections per host.
I [09/Aug/2007:15:26:17 -0500] Using policy "default" as the default!
I [09/Aug/2007:15:26:17 -0500] Full reload is required.
I [09/Aug/2007:15:26:17 -0500] Loaded MIME database from '/etc/cups': 34 types, 38 filters...
I [09/Aug/2007:15:26:17 -0500] Loading job cache file "/var/cache/cups/job.cache"...
I [09/Aug/2007:15:26:17 -0500] Full reload complete.
I [09/Aug/2007:15:26:17 -0500] Listening to 127.0.0.1:631 on fd 0...
I [09/Aug/2007:15:26:17 -0500] Listening to /var/run/cups/cups.sock on fd 2...
I [09/Aug/2007:15:26:45 -0500] commptr=""
I [09/Aug/2007:15:26:45 -0500] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=22718)
I [09/Aug/2007:15:26:52 -0500] commptr="?op=print-test-page"
I [09/Aug/2007:15:26:52 -0500] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=22719)
I [09/Aug/2007:15:26:53 -0500] Denying user "guest" access to printer "HP_OfficeJetJ5780"...
 
Old 08-09-2007, 12:08 PM   #7
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
I don't see a problem there, I think the 'guest' account is for samba.
I'm running out of ideas.
I read in the hplip site (Technical Documentation > Man Pages) that there are a number of command-line tools, eg
hp-setup, hp-toolbox, hp-check, hp-info etc (I think you will find them in /usr/share/hplip)
Documentation for their use is on the site.
I would be tempted to remove the printer and start again (probably removing the files in /var/spool/cups at the same time). These tools may help you get the correct set-up.

tobyl
 
Old 08-11-2007, 04:45 PM   #8
intergrator
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Wink I tried this trick and it worked

I had the same problem with my HP 1018 printer with a CUPS warning of out of quota.

I unplugged it from you linux box and plugged the printer into my Wintindo laptop.
Did a print test and of course it worked, but then I plugged it back into the linux
box and it started printing again. I think the issues is with the flame ram in the
printer and not the linux box. There must be a file that get dump in windows.

Just thought I would pass it along. Hope it helps someone.
 
Old 08-11-2007, 09:28 PM   #9
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
It might be some option under the printer itself then. Anyways, I just got another computer, and I moved the printer to that computer. It acts like a printer server, and after I set it up, I still get a quota limit error, see this link: http://www.linuxquestions.org/questi...d.php?t=576387. Hrmm..
 
Old 08-17-2007, 04:38 PM   #10
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Well I'm still at a loss here. I tried unplugging the printer completely just to clear it's memory, and still nothing. Plugged it in my XP notebook, seems to have worked temporarily. I don't want to have to plug it into my xp notebook every few times just to get it to work again. There has to be a better solution.
 
Old 08-17-2007, 08:44 PM   #11
guzzi
Member
 
Registered: Jun 2004
Location: Lawrence, KS
Distribution: Slackware
Posts: 294

Rep: Reputation: 32
Quota limit reached

I ran into this with the new CUPS.

To overcome, as root, I opened a browser and entered http://localhost:631/printers

This brought up the CUPs admin screen.

After clicking the tab for printer, the is a place to set allowed users. Enter the user name that is causing the quota limit problem, and that should take care of it.
 
Old 08-17-2007, 09:53 PM   #12
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
I already did that. Also, this is not on my local host, but on another computer I specifically setup as a print server. I made sure to add my user name. Nothing. I'm rather disappointed in the CUPS docs. No real help there, plus no real way of configuring it through the cups web interface.
 
Old 09-27-2007, 08:49 PM   #13
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Its been a while, and I wish to get back to this issue again. I have been scouring google and still no answer to this issue. Adding and removing doesn't change the quota status, so there is clearly a CUPS issue, but I tried all I can think of but still nothing. Anybody got any other suggestions?
 
Old 06-27-2008, 10:01 PM   #14
letrafe
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
try this

I rember that this problem have
turned on when I have added a new user to printers privilege. So I have added this line " AllowUser myusername" in printers.conf and when I reboot (leaving the printer turned on) the problem was fixed

Last edited by letrafe; 06-27-2008 at 10:09 PM.
 
Old 06-27-2008, 11:24 PM   #15
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,092

Original Poster
Rep: Reputation: 222Reputation: 222Reputation: 222
Never thought of that, I will have to try that. This issue was so annoying because I still never resolved it so I decided to leave it for a while. I hope that your suggestion will finally work for me.
 
  


Reply

Tags
cups, hp, laserjet, print


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS Quota Limit Reached ERROR Frame360 Linux - Newbie 4 03-09-2007 02:49 AM
VFS: file-max limit 25241 reached Toadman Mandriva 1 05-19-2005 11:39 PM
ftp quota probs - 0kb files at quota limit ph_xm Linux - Newbie 0 02-02-2005 12:13 PM
Location of mail storage once the quota has reached the limit jomy Linux - Enterprise 0 01-10-2005 08:09 AM
Quota issue, hard limit doesn't limit users Gratz Linux - Software 2 09-16-2003 08:35 AM


All times are GMT -5. The time now is 09:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration