LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-28-2005, 03:33 PM   #1
spamhippy
Member
 
Registered: Jul 2004
Location: wisconsin
Distribution: slackware, ubuntu studio
Posts: 124

Rep: Reputation: 16
quick question (LC_ALL locale)


hiya....
upgraded my box to slack current awhile back... everything seems to be working alright though i keep getting errors that say something about 'default langauge' fall back to local C using en_us something something (lol) tried searching on yahoo about it and came up with someone talking about somebody not setting the langauge and stuff for something and if you speak english... just nevermind it. and while i get these complaints... everything has run... so i ingored it... untill now... tried installing svn and i get an error when running it (here it is...)

svn: error: cannot set LC_ALL locale
svn: error: environment variable LANG is en_US
svn: error: please check that your locale name is correct
bash-2.05b$ LC_ALL
bash: LC_ALL: command not found

i searched around here for an answer... but frabkly everything i read about was kinda over my head. (lol) i imagine i gotta edit some text file somewhere and remove a couple of # signs. any idea where this is coming from? what do i need to do to reset the langauge on this?

thanks for your time
 
Old 11-28-2005, 05:11 PM   #2
AdaHacker
Member
 
Registered: Oct 2001
Location: Brockport, NY
Distribution: Kubuntu
Posts: 384

Rep: Reputation: 31
Apparently your LANG environment variable is set to the wrong value. Basically, this variable tells the system what your language and location preference is. Apparently en_US isn't valid on your system. You can probably find where it is being set under /etc, perhaps some file in /etc/profile.d.
 
Old 11-28-2005, 05:23 PM   #3
spamhippy
Member
 
Registered: Jul 2004
Location: wisconsin
Distribution: slackware, ubuntu studio
Posts: 124

Original Poster
Rep: Reputation: 16
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
perl: warning: Falling back to the standard locale ("C").

..it's stuff like this i'm getting.... (this is copied from another post.. this isn't actually mine...)
i did 'locale' and got....

LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=


how do i set LC_ALL ? is this right? ...haven't found the answer ...yet. lol
 
Old 11-28-2005, 05:25 PM   #4
spamhippy
Member
 
Registered: Jul 2004
Location: wisconsin
Distribution: slackware, ubuntu studio
Posts: 124

Original Poster
Rep: Reputation: 16
um... i speak english and from the u.s.

...lol. hmmm... trying to find LC_ALL .....
 
Old 11-28-2005, 05:37 PM   #5
spamhippy
Member
 
Registered: Jul 2004
Location: wisconsin
Distribution: slackware, ubuntu studio
Posts: 124

Original Poster
Rep: Reputation: 16
in etc/profile.d i find 2 files that seems to be about lang.... one is called...

lang.csh

in it the following is turned on...

setenv LANG en_US


and the other file is called.......

lang.sh

and it has.........

export LANG=en_US

export LC_COLLATE=C

..turned on....

there are other options in there that are for US english... but they are not recommended. should i turn them on? i guess i'm not really seeing what the problem is here. everything looks OK (as far as i can tell...)

thanks agian...
 
Old 11-29-2005, 03:06 AM   #6
spamhippy
Member
 
Registered: Jul 2004
Location: wisconsin
Distribution: slackware, ubuntu studio
Posts: 124

Original Poster
Rep: Reputation: 16
and after hours of looking the amazing answer to this question is!!!!!

export LC_ALL=C

...lol. geez.. it's always some simple thing... isn't it?
 
Old 11-29-2005, 05:49 AM   #7
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
You could use LC_ALL=en_US, it is valid

but you have to install glibc-i18n package and perhaps glibc-zoneinfo too
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 09:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
KDE locale question Belegdol Linux - General 1 11-21-2006 05:32 AM
Segmentation fault LC_ALL=C grep -q .initrd ssrini Red Hat 2 07-27-2005 09:56 AM
Locale question. Locura Slackware 3 07-01-2003 01:31 AM


All times are GMT -5. The time now is 12:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration