LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2004, 05:26 AM   #1
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Rep: Reputation: 30
Question on SSH ?


i just finished compiling a slack 10 box to 2.6.0... right after it came up on the network, i couldn't login remotely using SSH. i can SSH out of the box to another machine but when i try to connect using SSH to that machine it gives me this message:

ssh: connecto to host 192.168.1.103 port 22: Connection refused.

what can i do to fix this as i need to login to this box remotely because it doesn't have a monitor or a mouse or a keboard.

TIA
 
Old 10-27-2004, 05:45 AM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Get a keyboard and a monitor for that comp,

ps aux | grep sshd
do you see something like
Code:
root@fire:/etc# ps aux | grep sshd
root      1425  0.0  0.1  3140 1412 ?        Ss   Oct26   0:00 /usr/sbin/sshd
root     32036  0.0  0.0  1676  600 pts/3    R+   17:43   0:00 grep sshd
If not, that means your sshd (daemon) is not running. It could be that sshd daemon wasn't installed. Or /etc/rc.d/rc.sshd is not excutable.
 
Old 10-27-2004, 05:59 AM   #3
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
its giving me something like this :
root 973 0.0 0.0 188 tty1 R+ 03:51 0:00 grep sshd
 
Old 10-27-2004, 06:02 AM   #4
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
i restarted the sshd daemon by typing in:
<code>/etc/rc.d/rc.sshd restart</code>

still nothing
 
Old 10-27-2004, 06:41 AM   #5
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
it doesn't look like my sshd daemon is starting up.... how do i fix this ?
 
Old 10-27-2004, 06:54 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Did you generate a key-pair? ( On both computers )
Is the sshd daemon running?
Is port 22 open ( firewall settings )
Given the '192.168.' address, I'm assuming that you are trying to
access it from a machine on the local network.

You could add the public keys to the authorize_keys files on both computers.
This way, you wouldn't have to enter a pass-phrase. I believe you need generate rsa keys
for this to work.

One thing that could happen is if the wrong permissions are on the private key.
The server will refuse connections in that case.

Another possibility that I think could happen is if the IP address was used by a different computer before
you installed this one. However, I think that would more likely be the case if you changed things at the
client computer. But in any case, you could try deleting any information about the client at the server, and
information about the server on the client computer, in the known_hosts file. In effect, starting fresh on both ends.

I don't remember where the connection failures are logged, but it may contain the information on why the connection was refused.

There are several types of authentication, so you need to read through the man pages for 'ssh' and 'sshd'.

But if you need to get this connection working fast,

A) Make sure the sshd daemon starts.
B) Check the firewall. Does it allow local network ssh connections (port 22).
C) Generate new keys with ssh-keygen and use the RSA type key.
D) Add the contents of the ~/.ssh/id_rsa.pub file to the other computers ~/.ssh/authorized_keys

I hope this helps. There are things in site wide configuration configuration files in /etc/ssh/ that could cause a connection to be refused.
You would need to study them against the man pages to find out.
 
Old 10-27-2004, 07:23 AM   #7
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
thanks for your input, i did a kernel compile and maybe that caused something to go kaputz.... i'll go over the configuration again and see where i messed up. thanks again
 
Old 10-27-2004, 10:25 AM   #8
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
look at the networking part.

but i think it is not the kernel.

edit:
try
chmod +x /etc/rc.d/rc.sshd
sh /etc/rc.d/rc.sshd start

Last edited by carboncopy; 10-27-2004 at 10:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh question??? yenonn Linux - Security 5 02-25-2005 03:49 PM
ssh-agent/ssh-add question mega Slackware 2 01-26-2005 04:09 AM
SSH Question... Flipper Linux - Newbie 4 07-20-2003 04:29 PM
ssh question pdelucia Linux - Security 1 07-09-2003 03:54 PM
question about ssh minor Linux - Security 7 05-20-2001 09:24 PM


All times are GMT -5. The time now is 11:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration